[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#298246: installation-reports

Package: installation-reports


Debian-installer-version: Debian Sarge i386, weekly version of 1/17/05
uname -a: Linux local 2.6.8-1-386 #1 Thu Nov 25 04:24:08 UTC 2004 i686 GNU/Linux
Date: Feb. 15, 2005
Method: Boot from testing (Sarge) CDs (weekly version:  1/17/05)

Machine: Custom built, ATI Rage 128, UDMA(66)
Processor: AMD Duron 800MHz
Memory: 384 MB (PC-133)
Root Device: IDE: /dev/hde5
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.
Output of lspci and lspci -n:
gene@local:~$ lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 02)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
0000:00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 22)
0000:00:04.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 10)
0000:00:04.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 10)
0000:00:04.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 10)
0000:00:04.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
0000:00:09.0 Serial controller: 5610 56K FaxModem 56K FaxModem Model 5610 (rev 01)
0000:00:0a.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
0000:00:11.0 Unknown mass storage controller: Promise Technology, Inc. PDC20265 (FastTrak100 Lite/Ultra100) (rev 02)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 RF/SG AGP
gene@local:~$ lspci -n
0000:00:00.0 0600: 1106:0305 (rev 02)
0000:00:01.0 0604: 1106:8305
0000:00:04.0 0601: 1106:0686 (rev 22)
0000:00:04.1 0101: 1106:0571 (rev 10)
0000:00:04.2 0c03: 1106:3038 (rev 10)
0000:00:04.3 0c03: 1106:3038 (rev 10)
0000:00:04.4 0600: 1106:3057 (rev 30)
0000:00:09.0 0700: 12b9:1008 (rev 01)
0000:00:0a.0 0401: 1274:5880 (rev 02)
0000:00:11.0 0180: 105a:0d30 (rev 02)
0000:01:00.0 0300: 1002:5246

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [O]
Reboot:                 [O]


First, I'm a big fan of Debian.  I know that it's a moving target, and I
offer these comments in the hope that Debian will continue its progress
in becoming easier to install.

I encountered two problems:
1.  partitioning
2.  aptitude to install packages
3.  In setting up XF86Conf-4, I was offered a choice of "ati", I don't
    remember if I was also offered the r128 driver.  If it was there,
    I'm pretty sure it didn't appear as "ATI Rage 128", even though that's
    the full vendor and model.  After installation,
    I went back to the XF86Conf-4 generated by dexconf during install,
    and changed "ati" to "r128".

I have an older computer (circa 2001, 800 MHz Pentium).  The hard drive
is 40 GB UDMA(66), and is detected as /dev/hde.  I have a DVD drive as
/dev/hdc and a CD drive as /dev/hdd.  The IRQ probe on hda and hdb finds

I was reinstalling a newer Windows and then a newer Debian (Debian testing,
from Jan 15, 2005).  I discovered that the Debian installer doesn't
allow creating/resizing of partitions, etc.

So, I aborted and went
to Knoppix 3.7 (which has parted 2.9, and I believe a corresponding qtparted).
Within qtparted, I kept the Windows partition and created new partitions
for Debian.  When I wrote the partitions, qtparted froze at step 9,
with a 50% progress meter, saying it was checking /dev/hde5 (the first
ext3 partition).  After that, parted could print the partitions, but
when I asked parted to 'print 5' for /dev/hde5, it had an error message.

I tried to install Debian at that point, and it failed in the hardware
detect stage.  I went to a different console, and did 'ps -elf'.
I saw the following processes, among others:
  debconf -o d-i /usr/bin/main-menu
   udpkg --configure --force-configure hw-detect-full
   /var/lib/dpkg/info/hw-detect-full.postinst co
   /bin/hw-detect hw-detect-full/detect-progress
   /bin/hw-detect hw-detect-full/detect-progress  [Yes, repeated twice w/
   						   same pid in each case.]

I then went to DrakX from Mandrake 8.2.  That installer let me redo
the partitions.  I resized all of the Debian partitions, just to force
DrakX to rewrite the partition table.

I then went back to the Debian installer, and the partitioning stage
worked fine with no problem at that point.


In the debian installer, I chose "Desktop environment" and "Manual
selection".  I fed it the Debian CDs (install from first 5 Debian CDs).
After reading CDs 1, 2, and 3, it began installing the packages
from disk.  Inside scrollkeeper, it said that it would take a long time
to set up its database.  After a few minutes, I walked away.  I don't know
whether the computer rebooted or not while I was away.

However, when I came back, the Debian installer
was again asking me about time zone, hostname, and then again asking
me to insert the Debian CDs.  It then reported that there was a problem
installing the packages, and I could check it out manually later.
After the install, I found that /etc/X11/XF86Config-4 was a zero-length

3. XF86Config-4:  ATI Rage 128 [Already explained]

Reply to: