[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#292888: FWD: Re: Bug#292888: Installation story on Acer TravelMate 4000WLMi notebook

----- Forwarded message from Sarantos Kapidakis <sarantos@ionio.gr> -----

From: Sarantos Kapidakis <sarantos@ionio.gr>
Date: Tue, 1 Mar 2005 22:27:24 +0200
To: wen <wendelinhw@gmx.de>, Joey Hess <joeyh@debian.org>
Cc: debian-boot@lists.debian.org
Subject: Re: Bug#292888: Installation story on Acer TravelMate 4000WLMi notebook
User-Agent: Mutt/1.5.6+20040907i

Since there is followup interest, I should reply.
thank you for your answer.

On Fri, Feb 11, 2005 at 02:55:26PM -0500, Joey Hess wrote:
> Sarantos Kapidakis wrote:
> > There is an incompatibility between the kernel and my hardhare.
> > This prevents me booting on most normal ways - e.g. using knoppix or
> > Debian default boot methods.
> > I managed to boot knoppix, using the failsafe option.
> > Debian should also have a way to omit utilizing some of my hardware,
> > to help the system boot on kernel incompatibilities.
> The installer does. Type "expert" at the boot prompt and you will be
> prompted for which hardware drivers to load. Or are you talking only about
> problems after the base system is installed, such as your i810_audio
> problem?

My problems were since the initial kernel loading.
I did not try the expert option, though, and I cannot varify if this works, or the exact arguments for this.
At this moment, I already have a running system (by partitioning from a knoppix live CD system, and bootstrapping to debian).

> > In order to be able to boot later, I had to prohibit loading the i810_audio module.
> > Every time Debian rebuilds the modules.conf file, my system is not bootable, and I have to boot using knoppix to correct this (alias i810_audio off).
> A comment at the top of /etc/modules.conf explains that you should not
> edit the file directly and what to do instead.

I know.
To be safe, I completely removed the module code from my system.

I have also added a file "/etc/modutils/acerWLMi" containing
"alias i810_audio off # avoid system crash"

> -- 
> see shy jo

On Mon, Feb 28, 2005 at 02:53:23PM +0100, wen wrote:
> If I understand the answer (http://www.archivum.info/debian-boot%
> 40lists.debian.org/2005-02/msg00379.html) to that bug report correctly,
> the bug has been closed, recommending to boot with the option "expert"?
> I guess I got the same problem and I can't even boot from CD in expert
> mode. I got an ACER Travelmate 4002LMi. Trying to install sarge I get to
> the boot prompt. Trying to boot I either get a grey screen (with kernel
> 2.4) or the process hangs at 
> ACPI:IRQ9 SCI: Edge set to level Trigger 
> (when using kernel 2.6). Also the options acpi=off, nodma, noapic
> nolapic don't make a difference. Also typing "expert" makes the process
> hang at the mentioned line.
> I both tried to boot with the sarge netinstaller rc2 and a three weeks
> old CD 1 of the sarge CD-set. The results are the same.
> By the way: kanotix does boot when using the "acpi off, dma off"-mode.
> Output of lspci:
> 0000:00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 02)
> 0000:00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O
> Control Registers (rev 02)
> 0000:00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration
> Process Registers (rev 02)
> 0000:00:01.0 PCI bridge: Intel Corp. 855GME GMCH Host-to-AGP Bridge
> (Virtual PCI-to-PCI) (rev 02)
> 0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
> (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
> 0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
> (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
> 0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
> (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
> 0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB
> 2.0 EHCI Controller (rev 03)
> 0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 83)
> 0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller
> (rev 03)
> 0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA
> Storage Controller (rev 03)
> 0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
> SMBus Controller (rev 03)
> 0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
> (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
> 0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
> AC'97 Modem Controller (rev 03)
> 0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV350
> [Mobility Radeon 9600 M10]
> 0000:02:02.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T
> (rev 01)
> 0000:02:04.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev
> 05)
> 0000:02:06.0 CardBus bridge: Texas Instruments: Unknown device 8031
> 0000:02:06.2 FireWire (IEEE 1394): Texas Instruments: Unknown device
> 8032
> 0000:02:06.3 Unknown mass storage controller: Texas Instruments: Unknown
> device 8033

It could be part of the same problem, as my problems were not limited to the one mentioned above.  Here are some other problems I have as I interpret them:

The module i810_audio hangs the system [this was in my initial report].  Consequently, my sound card and modem do not work.

The kernel 2.6 ACPI hangs the system [this seems to be related to Wen's problem] - I get many lines of messages, and I have NEVER been able to boot a 2.6 kernel in my system.  On my 2.4 kernels I also have limited ACPI functionality: processor status and switch off, but no battery status, no suspend, ... etc (and this may be normal, but shows peculiarities on my ACPI).

The sendmail ignores the MX records on mail delivery connections and tris to connect directly with the email-target host (and most connections fail).  Exim could work, but I am familiar with sendmail.

I run "apt-get upgrade" my system very often (every week ?) trying to find possible corrections of the problems.

If you need more information about these, tell me what you want and I will send it.


----- End forwarded message -----

see shy jo

Attachment: signature.asc
Description: Digital signature

Reply to: