[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#295166: Partitioner bug

On Wed, Feb 16, 2005 at 10:49:35AM +0100, Kero-Chan wrote:
> On Mon, 14 Feb 2005 18:12:47 +0100, Sven Luther <sven.luther@wanadoo.fr> wrote:
> > > Then I tried with this setup:
> > > 20G /, First primary partition, Ext3, boot-flag on
> > > 384M swap, Second primary partition
> > > NB: This is the partitioning scheme the installer sets up when telling
> > > it to do it automatically.
> > > This resulted in a working Debian system :) However, It's near
> > > impossible to convert it to LVM and XFS (I'd need an other HD, etc).
> > > It'd be nice if I the partitioner worked.
> > >
> > > I also tried this:
> > > 256M swap, First primary partition
> > > 6GB /, Second primary partition, boot-flag on
> > > This also results in the GRUB GRUB GrUB GRUB syndrome :(
> > >
> > > Anyone able to install with any partition setup other than what the
> > > installer sets up automatically?
> > 
> > Just create a small /boot at the start of the disk as normal ext3 (or even
> > ext2). This will be enough for grub to boot, and then the kernel can take over
> > as usual.
> > 
> > Friendly,
> > 
> > Sven Luther
> I tried that setup now too:
> 128M /boot, First primary partition, Ext3, boot-flag on
> 256M swap, Second primary partition
> 6G /, Third primary partition, Ext3
> When I boot with expert26 I can select the bootloader.
> If I select GRUB, I get GRUB GRUB GRUB GRUB on reboot.
> When I select LILO, I get L 02 02 02 02  after reboot :(
> If I boot from the CD then, with linux26 root=/dev/hda3, I get a
> kernel panic, something like: VFS: Unable to mount root, unknown
> block(0,0).
> If I boot the installation CD, load the installer components, execute
> a shell, and start cfdisk, I get: FATAL: Unable to read disk.
> If I boot Knoppix 3.7 and start cfdisk, It can see the partition
> scheme I set up in the Debian installer. I can also mount hda3. fcsk
> finds no errors. The installed Debian system appears to be there.
> It appears that the bug is in the kernel used on the Sarge Installer
> NetInst CD, the partitioner, or the parameters it passes to grub/lilo
> when installing them.

Well, i believe the bug is most assuredly in your bios, or something. I am not
an x86 specialist so i cannot help you on this. Having the /boot outside of
the LVM setup should be enough to make it work.

Try creating a / of 512MB as first and only partition at the start, and do a
install into it, then if this works, try doing a /boot of 128MB and then a /
of 512MB, and see if it still works.

If both of these are ok, try a /boot of 128MB, followed by a LVM of 512MB in
which you put /. This should work too.

If i remember well, grub should not need anything outside of /boot, so it
should work. IF there is still trouble, probably grub-installer or
lilo-installer is broken.


Sven Luther

Reply to: