[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#294811: successful d-i rc2 install

Package: installation-reports

Debian-installer-version: RC2, from http://www.debian.org/devel/debian-installer
uname -a: Linux wunderdog 2.4.27-1-smp #1 SMP Thu Dec 2 08:58:06 CET 2004 alpha GNU/Linux
Date: 10 Feb 2005 18:00
Method: booted "netinst CD image, with Debian base" from SCSI cdrom drive.
Machine: Compaq DS20 clone (264DS motherboard), onboard
dual-channel adaptec 78xx scsi (unused), PCI Symbios 53c895 ultra2 SCSI
with the drives attached to it.  4gb Seagate barracuda, 18gb Seagate
Cheetah X15
Processor: dual 21264 @ 500mhz
Memory: 4GB
Root Device: Seagate Cheetah X15 (sdb, DKS200 in SRM)
Root Size/partition table: 

wunderdog:~# fdisk -l /dev/sda

Disk /dev/sda: 4551 MB, 4551129088 bytes
141 heads, 62 sectors/track, 1016 cylinders
Units = cylinders of 8742 * 512 = 4475904 bytes

2 partitions:
#       start       end      size     fstype   [fsize bsize   cpg]
  a:        1*     1017*     1016*      ext2                      
wunderdog:~# fdisk -l /dev/sdb

Disk /dev/sdb: 18.3 GB, 18351959552 bytes
64 heads, 32 sectors/track, 17501 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

6 partitions:
#       start       end      size     fstype   [fsize bsize   cpg]
  a:        1*        1*        0*      ext2                      
  b:        1*       78*       76*      ext2                      
  c:       78*     9614*     9536*      ext2                      
  d:    16698*    17502*      803*      swap                      
  e:     9614*    16698*     7083*      ext2                      

wunderdog:~# mount
/dev/sdb3 on / type xfs (rw)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/sdb2 on /boot type ext2 (rw)
/dev/sdb5 on /local/scratch0 type xfs (rw)
/dev/sda1 on /local/scratch1 type xfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
AFS on /afs type afs (rw)

Output of lspci and lspci -n:
wunderdog:~# lspci
0000:00:05.0 ISA bridge: Contaq Microsystems 82c693
0000:00:05.1 IDE interface: Contaq Microsystems 82c693
0000:00:05.2 IDE interface: Contaq Microsystems 82c693
0000:00:05.3 USB Controller: Contaq Microsystems 82c693
0000:00:07.0 VGA compatible controller: Texas Instruments TVP4020 [Permedia 2] (rev 01)
0000:00:08.0 Ethernet controller: Digital Equipment Corporation DECchip 21140 [FasterNet] (rev 22)
0000:01:07.0 SCSI storage controller: LSI Logic / Symbios Logic 53c895 (rev 02)
wunderdog:~# lspci -n
0000:00:05.0 0601: 1080:c693
0000:00:05.1 0101: 1080:c693
0000:00:05.2 0101: 1080:c693
0000:00:05.3 0c03: 1080:c693
0000:00:07.0 0300: 104c:3d07 (rev 01)
0000:00:08.0 0200: 1011:0009 (rev 22)
0000:01:07.0 0100: 1000:000c (rev 02)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


Everything worked, except that I had to manually set bootdef_dev in SRM
before the system would boot.  I understand that figuring out what SRM
names map to which Linux devices may be difficult, but there ought to at
least be some notification to the user at the end of the install process
about this.

Also, the system by default installs kernel symlinks at /vmlinuz and
/vmlinuz.old (and kernel install packages rotate these and the
associated initrd symlinks).  This is problematic because aboot can not
make use of cross-filesystem symlinks, especially when / is XFS.  In
order to make aboot behave correctly for new kernel installs, the
/vmlinuz and /vmlinuz.old symlinks should simply be moved into /boot.

| Ben Staffin
  perpetual nerd  |

Reply to: