[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#293644: [powerpc] [rc2] Sarge installation report on Powerbook Lombard

Package: installation-reports

Hello everybody,

this installation report does not focus so much on
debian-installer itself but on the overall installation process.
Most of the problems I have encountered were not in d-i itself
but in the later stages of the installation. Please feel free to
forward this report to other package maintainers as you see fit.
So here we go:

Debian-installer-version: rc2
uname -a: Linux lombard 2.6.8-powerpc #1 Sat Jan 8 22:01:09 CET 2005 ppc

Date: 2005/02/02
Method: netboot
Machine: Apple Powerbook Lombard
Processor: G3
Memory: 192MB
Root Device: IDE disk
Output of lspci and lspci -n:

0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:0e.0 USB Controller: Lucent Microelectronics USB (rev 12)
0000:00:10.0 ff00: Apple Computer Inc. Paddington Mac I/O
0000:00:11.0 VGA compatible controller: ATI Technologies Inc 3D Rage LT Pro
(rev dc)
0000:00:13.0 CardBus bridge: Texas Instruments PCI1211

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]

Booting itself worked fine, after I had a yaboot image and a
proper yaboot.conf. The installation manual states "On NewWorld
Power Macintosh machines, you will need to set up the yaboot boot
loader as the TFTP boot image. Yaboot will then retrieve the
kernel and RAMdisk images via TFTP itself. For net booting, use
the yaboot-netboot.conf. Just rename this to yaboot.conf in the
TFTP directory."
Unfortunately neither yaboot nor an appropriate yaboot.conf were
included with the netboot kernel and initrd in d-i rc2

Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ] (netboot, no CD)
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]

A "nice-to-have" thing would be an automatic entry for an
installed MacOS in yaboot.conf, like it is done with Windows
partitions in grub's menu.lst on i386. This is probably
nothing that has a chance to be implemented before the 
Sarge release, but I think it is worth to keep the idea
for the future.

Reboot:                 [O]


The part of the installation that is covered by Debian-Installer
went fine. For the rest (base-config and package selection) I
took the "desktop user" approach and opted for using aptitude
as package management tool instead of apt-get and GNOME as
desktop environment.
Base-config ran ok; when it came to the package selection, I did
not select "desktop environment" as the harddisk partition I have 
available is quite small and I did not want KDE and GNOME to be
both installed. I installed x-window-system and gnome with

On the first start into X I got lots of GNOME error messages. The
first one was "Wrong permissions for /dev/pmu device". The device
exists and it has the permissions root:root 660, which generally
looks sensible :-). I looked through the bug reports against
GNOME but did not find a report covering this. Later I was
pointed to a bug opened against udev (#284272). The flames that
followed this bugreport were not really helpful, but at
http://lists.debian.org/debian-powerpc/2005/01/msg00242.html is a
description of a workaround. Colin Watson pointed out that having
the possibility of several processes writing simultaneously to
/dev/pmu is unsafe and access should be handled via pmud. He
considers this to be a GNOME bug.
In any case this is very annoying for the user and one cannot
expect that a normal desktop user has to Google around to find
a (more or less limited) workaround for this, so this behaviour
should really be fixed before the Sarge release.

There were also several other identical windows with the
error message "Fehler beim Aktivieren der XKB-Konfiguration"
(Error on activating the XKB configuration) and the hint
to run the following commands and provide their output: 

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "de", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "de", "", ""
$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [de  de]
 model = pc105
 overrideSettings = false
 options = []
 update_handlers = []

Entering these commands was only possible by using cut and paste:
I have a German keyboard and there characters like @ (at-sign)
and | (pipe) are only available by using key combinations with
the right alt key (RightAlt+Q and RightAlt+<) - unfortunately
this does not work. On a Linux virtual console everything works
as expected, but not in X. This seems to be a general X problem,
nothing GNOME specific, as the behaviour is the same when tested
in a failsafe session (just an xterm and nothing else). Google
gave the hint to make sure the keyboard type is set to pc105 and
not pc101 oder pc104 and to add a line

Option "RightAlt" "ModeShift"

to the XF86Config keyboard section, but that did not help. Quite
a lot of people seem to have had this problem. Google shows lots
of questions but no working solutions except for manually
fiddling around with xmodmap to remap the keys, which is more a
workaround than a solution. I have run xev to see which keycodes
are generated:
Both the left and the right Alt key give keycode 64, keysym
Alt_L, the right "Apple" key gives keycode 108, keysym KP_Enter.
One of those should probably generate a Alt_R/ModeShift
event. As it is now, the German keymap is effectively unusable.

I then played around with GNOME (which I normally do not use) and
found that some applications which I did not need (gnome-games
and a few others) were installed, so I uninstalled them to get a
few more MB of free disk space. On the next run of aptitude I
got bitten by a feature of aptitude: aptitude remebers which
packages were installed as part of a dependency chain and removes
them when the depending package is removed. As I had uninstalled
e.g. gnome-games, which was installed as dependency of
gnome/gnome-desktop-environment, gnome and
gnome-desktop-environment got removed as well. On the next
aptitude run, almost all of the rest of GNOME, which had only been
installed as dependency of the gnome metapackage got uninstalled
as well.
Removal of unneeded dependencies is of course a feature of aptitude
and not a bug, but in a situation like this a user who does not
know about it might be very confused. Perhaps a hint in the
installation manual would be a good idea.

As this was intended as a desktop setup, I switched from aptitude
to synaptic as package management tool.

The next step was setting up printing. I installed cups and as
drivers selected the cupsys-drivers-gimpprint package.
Installation went fine, I could configure the printer (an HP
LaserJet 6P) with the GNOME printer configuration tool and
selected the suggested driver: "Laserjet 6 series: High quality
Image (GIMP-Print)". Everything looked ok, with just one problem:
it did not print :-). The cups log files finally gave the hint:
this gimp-print driver seems to require gs-esp and does not seem
to work properly with gs-gpl (which was installed). The
cupsys-drivers-gimpprint has a recommend on gs-esp | gs-gpl, but
no strict dependency. As gs-gpl was already installed, gs-esp was
not selected by synaptic, which caused the problem. After
installing gs-esp everything worked as expected, so I suggest to
actually depend on gs-esp.

#include <standard_disclaimer>
Nach Paragraph 28 Abs. 3 Bundesdatenschutzgesetz widerspreche ich der Nutzung
oder Uebermittlung meiner Daten fuer Werbezwecke oder fuer die Markt- oder

Reply to: