[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#293506: Debian sarge RC2 NewWorld PowerMac installation report

Package: installation-reports

Executive Summary:

All went well until it came time after the reboot to configure the software packages. After repeated failures, I tried "choose packages manually" (i.e. aptitude) and that went OK.

This is OK for experts, but not ready for the release to the great unwashed masses.


Debian-installer-version: <Fill in date and from where you got the image>
	PowerPC (Macintosh) RC2 businesscard CD
uname -a: <The result of running uname -a on a shell prompt>
	Linux ribbit 2.6.8-powerpc #1 Sat Jan 8 22:01:09 CET 2005 ppc GNU/Linux

Date: <Date and time of the install>
	Feb 3, 2004 5:30 PM US Eastern time

Method: How did you install? What did you boot off? If network install, from where? Proxied? CD-Direct boot (hold down "option" key to get graphical boot screen - choose CD)

Machine: <Description of machine (eg, IBM Thinkpad R32)>
	NewWorld PowerPC Macintosh grey deskside tower
	detected as: PowerMac G4 AGP Graphics

	PPC-7400 (G4) 350 MHz

	768 MB
Root Device: <IDE?  SCSI?  Name of device?>

Root Size/partition table: Feel free to paste the full partition table, with notes on which partitions are mounted where.
	/dev/hda (the master IDE disk) has MacOS on it.
/dev/hdb (the slave IDE disk) has the newly installed Debian "sarge" Linux on it.

ribbit:~# mac-fdisk -l
# type name length base ( size ) system /dev/hda1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map /dev/hda2 Apple_Driver43 Macintosh 54 @ 64 ( 27.0k) Driver 4.3 /dev/hda3 Apple_Driver43 Macintosh 74 @ 118 ( 37.0k) Driver 4.3 /dev/hda4 Apple_Driver_ATA Macintosh 54 @ 192 ( 27.0k) Unknown /dev/hda5 Apple_Driver_ATA Macintosh 74 @ 246 ( 37.0k) Unknown /dev/hda6 Apple_FWDriver Macintosh 200 @ 320 (100.0k) Unknown /dev/hda7 Apple_Driver_IOKit Macintosh 512 @ 520 (256.0k) Unknown /dev/hda8 Apple_Patches Patch Partition 512 @ 1032 (256.0k) Unknown /dev/hda9 Apple_HFS untitled 11264000 @ 1544 ( 5.4G) HFS /dev/hda10 Apple_HFS untitled 2 11264000 @ 11265544 ( 5.4G) HFS /dev/hda11 Apple_HFS untitled 3 17631422 @ 22529544 ( 8.4G) HFS /dev/hda12 Apple_Free Extra 22 @ 40160966 ( 11.0k) Free space

Block size=512, Number of Blocks=40160988
DeviceType=0x0, DeviceId=0x0
1: @ 64 for 23, type=0x1
2: @ 118 for 36, type=0xffff
3: @ 192 for 21, type=0x701
4: @ 246 for 34, type=0xf8ff

# type name length base ( size ) system /dev/hdb1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map /dev/hdb2 Apple_Bootstrap boot 195313 @ 64 ( 95.4M) NewWorld bootblock /dev/hdb3 Apple_UNIX_SVR2 root 6445313 @ 195377 ( 3.1G) Linux native /dev/hdb4 Apple_UNIX_SVR2 swap 1765085 @ 6640690 (861.9M) Linux swap

Block size=512, Number of Blocks=8405775
DeviceType=0x0, DeviceId=0x0
1: @ 64 for 23, type=0x1
2: @ 118 for 36, type=0xffff
3: @ 192 for 21, type=0x701
4: @ 246 for 34, type=0xf8ff

ribbit:~# df -m
Filesystem           1M-blocks      Used Available Use% Mounted on
/dev/hdb3                 3098       379      2562  13% /
tmpfs                      379         0       379   0% /dev/shm


Output of lspci and lspci -n:

ribbit:~# ( lspci -n ; lspci ) | sort
0000:00:0b.0 0600: 106b:0020
0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth AGP
0000:00:10.0 0300: 1002:5046
0000:00:10.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS
0001:10:0b.0 0600: 106b:001f
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth PCI
0001:10:0d.0 0604: 1011:0026 (rev 05)
0001:10:0d.0 PCI bridge: Digital Equipment Corporation DECchip 21154 (rev 05)
0001:11:02.0 0100: 9004:5078 (rev 03)
0001:11:02.0 SCSI storage controller: Adaptec AHA-7850 (rev 03)
0001:11:07.0 ff00: 106b:0022 (rev 02)
0001:11:07.0 ff00: Apple Computer Inc. KeyLargo Mac I/O (rev 02)
0001:11:08.0 0c03: 106b:0019
0001:11:08.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:11:09.0 0c03: 106b:0019
0001:11:09.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:11:0a.0 0c00: 104c:8019
0001:11:0a.0 FireWire (IEEE 1394): Texas Instruments TSB12LV23 IEEE-1394 Controller
0002:21:0b.0 0600: 106b:001e
0002:21:0b.0 Host bridge: Apple Computer Inc. UniNorth Internal PCI
0002:21:0f.0 0200: 106b:0021
0002:21:0f.0 Ethernet controller: Apple Computer Inc. UniNorth GMAC (Sun GEM)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O] Note 1 & 2
Configure network HW:   [O] Note 4
Config network:         [O] Note 5 & 6 & 7
Detect CD:              [O]
Load installer modules: [O] Note 3
Detect hard drives:     [O]
Partition hard drives:  [O] Note 8
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O] Note 9
Install boot loader:    [O]
Reboot:                 [O] Note 10


<Description of the install, in prose, and any thoughts, comments and ideas you had during the initial install.>

1)	Booted expert-powerpc kernel.
2)	Chose not to start  PCMCIA card services.
3)	Did not load any extra installer components.
4)	Offered to load sungem kernel module. I said "yes"
5) Configured network manually because I don't have a suitable DHCP server on this net.
6)	Chose mirror as debian.rutgers.edu because it is local on-campus.
7)	Chose "testing" version to install.
8) Manually partitioned disk (IDE slave 4.5 GB) -- IDE master drive has macOS
9)	Chose default kernel -- kernel-image-2.6.8-powerpc
10) Configured apt to use http (default was cdrom, curiously) to "testing" on debian.rutgers.edu mirror Chose "Desktop environment" and "Print server" tasks in "Debian software selection" screen. Got "There was a problem installing the selected software. One or more packages failed to install. ..." chose to "go back to the package selection step, and try again." Got same error. Went back and left out the "Desktop environment option" (i.e. just checked "Print server") Got same error. Went back and chose "manual package selection". Wound up in aptitude. Took default packages. I.e. did not add or delete any packages other than the ones that aptitude already had selected on startup. That seemed to work just fine -- no error messages.

Install logs and other status info is available in /var/log/debian-installer/.

	Log files will be made available on request.

Once you have filled out this report, mail it to submit@bugs.debian.org.

Reply to: