[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#293036: "testing" install doesn't handle RAID1 root partition

> Hmm. AFAIK (and I have a test installation sitting here telling me so),
> having root=/dev/md0 _should_ work.
> What errors do you get if you have root=/dev/md0?

I've done it twice now and the errors were different both times.  The first
time it was a number of errors about trying to reference a block that was
far past the end of the device (by far, I mean _double_).  The second time
just came up with a prompt for "Run Level:" and when I entered a number
said "no more processes to start at that level".

In both cases, there was severe filesystem corruption; so much so that I
had to re-install from scratch.  File contents were garbage or zero'd,
files were gone, and fsck complained for a couple minutes while it fixed

I have a theory, though that could explain the results.  I'm thinking that
the root mirror (raid1) did not finish syncing the disks either during
the original install or subsequent boots.  Then, when I tried to boot
with the 2.6 kernel it reversed which disk was the master and which was
the copy and so tried to sync in the opposite direction, copying random
data over the filesystem.

Last night I let the mirror sync before allowing the first reboot after
an install.  We'll see if that makes any difference.

                                 ( bcwhite@precidia.com )

             The best way to predict the future... is to create it.
  ( Couldn't verify my signature?  Use http://www.precidia.com/precidia.crt )

Reply to: