[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#292221: d-i: mkinitrd STILL omits medley.o (see also #265424)

Package: debian-installer
Version: daily build 25 Jan 2005

Method: Installed from boot & root floppies
Machine: ASUS A7N8X Deluxe 2.0
Processor: Athlon XP 3200+
Memory: 1 GB
Root Device: Silicon Image Sil 3112 SATA RAID
Hard disks: 2x Maxtor 6Y160M0 (160Gb) in a single 320Gb stripe set

This is *exactly* the same bug as #265424, which does not appear to have
been addressed or even acknowledged. 

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [ ]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Unlike Todd (the author of #265424), I did not attempt to use a CD
drive. Please see #286939 for my tribulations here (I was trying to use
via82cxxx instead of amd74xx - I suspect I will be able to use the CD
next time).

I had to use expert mode and manually modprobe siimage, ide-detect,
ide-disk, ataraid and medley, in that order. Using non-expert mode
caused a total freeze during loading of ide-detect, every time.

Once medley was loaded, I was able to partition and create filesystems
successfully. Note that Todd's point about the default options being
dangerous still stands - only by using manual partitioning could I see
the existing partitions of the stripe set.

After installation, I ignored grub and installed LILO, which worked
fine. It even detected my Windows installation on /dev/ataraid/d0p1 and
included it.

Then I rebooted, and it tried gamely to install hptraid and pdcraid, but
not medley! So it could not find the root device (/dev/ataraid/d0p3) and

It's now over 5 months since Todd submitted #265424, and it's surely a
simple matter of adding medley.o to that part of the script which tries
the other ataraid drivers. Grateful if someone could add this asap.
(Todd, if you've managed to work around this yourself, I'd love to know


Reply to: