[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#292111: installation-reports: FAILURE TO RECOGNIZE EXISTING PARTITIONS

Package: installation-reports

Debian-installer-version: Jan 17, 2005, official RC2, CD Image by
		 http from Debian Web pages
uname -a: INSTALL FAILED (both under linux26 and normal linux boot)
Date: Jan. 24, 2005
Method: Boot from CD; Initial install with Debian CD-1 already failed

Machine: Custom machine with SATA hard drive (Maxtor 6Y160M0)
Processor:  AMD Athlon 64, 3000+
Memory:  512 MB RAM
Root Device:  IDE SATA;  Other Linuxes call it /dev/hde (Knoppix 3.7
                                             or /dev/sda (Mandrake 10.1)
Root Size/partition table: SEE NOTES BELOW.
Output of lspci and lspci -n:  SEE NOTES BELOW.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


<Description of the install, in prose, and any thoughts, comments
      and ideas you had during the initial install.>

I tried to use the Debian installer with Debian testing
(Sarge, version of 1/17/05, rc2 release).  Unfortunately, when it
came to partitioning, I selected
  "manually partition"
and was presented only with the possibility of partitioning the whole
disk:  Maxtor 6Y160M0 (163 GB)
The installer knows the disk, but did not show me my existing
 partitions for reformatting.

I have a SATA drive (Maxtor 6Y160M0, 163 GB).
Windows XP reports that I am using:
    IRQ 20	NVIDIA CK8S Serial ATA Controller (v2.5)
It reports the following sharing:
  IRQ 20	Standard Enhanced PCI to USB Host Controller
  IRQ 20	NVIDIA CK8S Serial ATA Controller (v2.5)

I have 6 partitions:  NTFS/FAT32/Linux swap/ext3/ext3/ext3
The ext3 partitions are currently occupied by:  Knoppix3.6/home/Knoppix3.7
It was my intention to overwrite one of the Knoppix partitions with
  the Debian system.
The Debian installer apparently didn't recognize my partitions.
I aborted the Debian install, and tested my partitions both with
parted using Knoppix, and with the Mandrake Official 10.1 installer.
The Mandrake installer read my partitions fine, and I successfully resized
  the last partition as a test.  (I plan to overwrite it with Debian.)
I tested with parted 1.6.9, and parted was not able to see my partitions.
I'm guessing that the Debian installer uses some of the same code as parted.

Can you suggest a workaround?

Mandrake Official 10.1:
After selecting "custom partition", Drake tells me during install:
  ATA Maxtor 6Y160M0
  Device:  sda, 152 GB
  Partition table type:  table::dos
     on channel 0 id0
When I select the individual partitions, I see:
  Partition sda1
  Device name:  scsi/host0/bus0/target0/lun0/part1
  start sector 63
  size:  122961447 sectors
  Cylinder 0 to 7653
  Parttion booted by default
  Partition sda5, FAT32 (10 GB)
  Partition sda3 Linx swap (2 GB)
  Partition sda6 ext3 (29 GB)  [ Currently containing Knoppix 3.6]
  Partition sda7 ext3 (19 GB)  [ Currently containing /home]
  Partition sda8 ext3 (32 GB)  [ Currently containing Knoppix 3.7]

root@ttyp0[knoppix]# parted /dev/hde
GNU Parted 1.6.9
Using /dev/hde
Warning: Unable to align partition properly.  This probably means that another
partitioning tool generated an incorrect partition table, because it didn't have
the correct BIOS geometry.  It is safe to ignore,but ignoring may cause
(fixable) problems with some boot loaders.
Ignore/Cancel? c
Information: The operating system thinks the geometry on /dev/hde is
19929/255/63.  Therefore, cylinder 1024 ends at 8032,499M.

[And if I choose Ignore: ]
Ignore/Cancel? i
Error: Unable to satisfy all constraints on the partition.

root@ttyp0[knoppix]# fdisk -l /dev/hde

[Sorry for the German.  I was using Knoppix 3.7, and forgot to set the lang.]
Platte /dev/hde: 163.9 GByte, 163928604672 Byte
255 Köpfe, 63 Sektoren/Spuren, 19929 Zylinder
Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes

    Gerät Boot      Start         End      Blocks   Id  System
    /dev/hde1   *           1        7654    61480723+   7  HPFS/NTFS
    /dev/hde2            7655       19930    98605773    5  Erweiterte [Ext.]
    /dev/hde3            8990        9254     2128581   82  Linux Swap
    /dev/hde5            7655        8989    10723356    b  W95 FAT32
    /dev/hde6            9255       13128    31117873+  83  Linux
    /dev/hde7           13129       15651    20265966   83  Linux
    /dev/hde8           15652       19930    34369839   83  Linux

Results of lspci (from Knoppix 3.7)

knoppix@ttyp0[knoppix]$ lspci
0000:00:00.0 Host bridge: nVidia Corporation: Unknown device 00e1 (rev a1)
0000:00:01.0 ISA bridge: nVidia Corporation: Unknown device 00e0 (rev a2)
0000:00:01.1 SMBus: nVidia Corporation: Unknown device 00e4 (rev a1)
0000:00:02.0 USB Controller: nVidia Corporation: Unknown device 00e7 (rev a1)
0000:00:02.1 USB Controller: nVidia Corporation: Unknown device 00e7 (rev a1)
0000:00:02.2 USB Controller: nVidia Corporation: Unknown device 00e8 (rev a2)
0000:00:05.0 Bridge: nVidia Corporation: Unknown device 00df (rev a2)
0000:00:06.0 Multimedia audio controller: nVidia Corporation: Unknown device 00ea (rev a1)
0000:00:08.0 IDE interface: nVidia Corporation: Unknown device 00e5 (rev a2)
0000:00:0a.0 IDE interface: nVidia Corporation: Unknown device 00e3 (rev a2)
0000:00:0b.0 PCI bridge: nVidia Corporation: Unknown device 00e2 (rev a2)
0000:00:0e.0 PCI bridge: nVidia Corporation: Unknown device 00ed (rev a2)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]
0000:02:07.0 Modem: Smart Link Ltd. SmartLink SmartPCI562 56K Modem (rev 04)

knoppix@ttyp0[knoppix]$ lspci -n
0000:00:00.0 0600: 10de:00e1 (rev a1)
0000:00:01.0 0601: 10de:00e0 (rev a2)
0000:00:01.1 0c05: 10de:00e4 (rev a1)
0000:00:02.0 0c03: 10de:00e7 (rev a1)
0000:00:02.1 0c03: 10de:00e7 (rev a1)
0000:00:02.2 0c03: 10de:00e8 (rev a2)
0000:00:05.0 0680: 10de:00df (rev a2)
0000:00:06.0 0401: 10de:00ea (rev a1)
0000:00:08.0 0101: 10de:00e5 (rev a2)
0000:00:0a.0 0101: 10de:00e3 (rev a2)
0000:00:0b.0 0604: 10de:00e2 (rev a2)
0000:00:0e.0 0604: 10de:00ed (rev a2)
0000:00:18.0 0600: 1022:1100
0000:00:18.1 0600: 1022:1101
0000:00:18.2 0600: 1022:1102
0000:00:18.3 0600: 1022:1103
0000:01:00.0 0300: 1002:5159
0000:02:07.0 0703: 163c:3052 (rev 04)

Reply to: