[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#279610: marked as done (Install on Alpha XS1000 and 500au)

Your message dated Thu, 13 Jan 2005 16:47:24 -0500
with message-id <E1CpCoO-0002yD-00@newraff.debian.org>
and subject line Bug#279610: fixed in srm-reader 0.07
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 31 Oct 2004 17:39:42 +0000
>From tbm@cyrius.com Sun Oct 31 09:39:42 2004
Return-path: <tbm@cyrius.com>
Received: from sorrow.cyrius.com [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1COJg6-0006A5-00; Sun, 31 Oct 2004 09:39:42 -0800
Received: by sorrow.cyrius.com (Postfix, from userid 10)
	id 2BDF564D4A; Sun, 31 Oct 2004 17:39:42 +0000 (UTC)
Received: by deprecation.cyrius.com (Postfix, from userid 1000)
	id 4E85F4F254; Sun, 31 Oct 2004 17:39:24 +0000 (GMT)
Date: Sun, 31 Oct 2004 17:39:24 +0000
From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: Install on Alpha XS1000 and 500au
Message-ID: <20041031173924.GA5199@deprecation.cyrius.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
X-Debbugs-Cc: vorlon@debian.org
User-Agent: Mutt/1.5.6+20040907i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-11.0 required=4.0 tests=BAYES_00,HAS_PACKAGE,
	X_DEBBUGS_CC autolearn=ham version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports

Debian-installer-version: 28-Oct-2004 14:12
uname -a: 2.4.27-1
Date: Oct 30
Method: netboot via DHCP/TFTP, install via HTTP
Machine: Alpha XS1000 and 500au, both using SRM firmware
Processor: Alpha
Memory: 128 MB (XS1000) and 64 MB (500au)
Root Device: SCSI

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E] default option from manual doesnt' work
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E] default option won't boot


I installed on two Alpha machines, an XS1000 and an 500au.  I didn't know
anything about Alpha when I started, so I used the installation manual to
find out what I need to do.  First of all, boot-installer/alpha.xml refers
to MILO which I think is not in Debian anymore.  If this is no longer
supported, this should be removed (fortunately I had some machines with

Unfortunately, the "boot ewa0 -flags 0" suggested there doesn't work.  When
I tried this, I got something like:

VFS: Mounted root (ext2 filesystem).
attempt to access beyond end of device
01:00: rw=0, want=10472, limit=8192
attempt to access beyond end of device
01:00: rw=0, want=10472, limit=8192
VFS: Cannot open root device "" or 08:02
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:02

After adding a ramdisk_size=16384, it would complain that it cannot find
root.  When I used
   boot ewa0 -flags "console=ttyS0 ramdisk_size=16384 root=/dev/ram0"
it worked.

The next thing was that the default language was Albanian (the first in the

The installation went smoothly; I used the guided partitioner, etc.

After rebooting, it automatically tried to boot from the net ("boot
ewa0. -flags a"); this is very strange considering that originally
the machine was configured to boot from disk.  Anyway, after a while I
figured out I need:
  boot dka0 -flags console=ttyS0   (or "dkc0" on another machine)
Maybe this can be documented somewhere (or aboot-installer should
print a message saying how to boot), or the machine configured to
boot from disk automatically.

In aboot, the default configs didn't work because they didn't have an
console=ttySX option.  It seems that aboot-installer doesn't generate a
config file at all but uses the standard from aboot (?).  If this is the
case, this won't work with custom partitions... in any case,
aboot-installer should realize that I did a serial console install and add
appropriate entries.  FWIW, I managed to boot with:
    aboot> b 2/vmlinuz ro initrd=/initrd.img root=/dev/sda3 console=ttyS0

Martin Michlmayr

Received: (at 279610-close) by bugs.debian.org; 13 Jan 2005 21:53:46 +0000
>From katie@ftp-master.debian.org Thu Jan 13 13:53:46 2005
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CpCuY-0000hS-00; Thu, 13 Jan 2005 13:53:46 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1CpCoO-0002yD-00; Thu, 13 Jan 2005 16:47:24 -0500
From: Jeff Bailey <jbailey@raspberryginger.com>
To: 279610-close@bugs.debian.org
X-Katie: $Revision: 1.54 $
Subject: Bug#279610: fixed in srm-reader 0.07
Message-Id: <E1CpCoO-0002yD-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Thu, 13 Jan 2005 16:47:24 -0500
Delivered-To: 279610-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 2

Source: srm-reader
Source-Version: 0.07

We believe that the bug you reported is fixed in the latest version of
srm-reader, which is due to be installed in the Debian FTP archive:

  to pool/main/s/srm-reader/srm-reader_0.07.dsc
  to pool/main/s/srm-reader/srm-reader_0.07.tar.gz
  to pool/main/s/srm-reader/srm-reader_0.07_alpha.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 279610@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Jeff Bailey <jbailey@raspberryginger.com> (supplier of updated srm-reader package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Thu, 13 Jan 2005 16:11:00 -0500
Source: srm-reader
Binary: srm-reader
Architecture: source alpha
Version: 0.07
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Jeff Bailey <jbailey@raspberryginger.com>
 srm-reader - Read SRM variables to get defaults for language, etc (udeb)
Closes: 260814 279610
 srm-reader (0.07) unstable; urgency=low
   * Joey Hess
     - Use debhelper's udeb support.
     - debhelper v4.
   * Alastair McKinstry
     - use lib/debian-installer-startup.d instead of /etc/rcS.d
       Closes: #260814.
   * Joey Hess
     - Fix language preseeding to use "new" (6 months old..) languagechooser
       values. Closes: #279610
     - Did not make it preseed the countrychooser country, due to lack of time
       for testing. Added TODO item to add this feature back later.
     - Remove some obvious comments.
   * Steve Langasek
     - Add support for Flemish (Belgian Dutch), per Christian Perrier,
       and also for Japanese.
   * Jeff Bailey
     - Add myself to Uploaders.
 ca4ed486eff7cc03f1f3d9c0ed05b2ee 658 debian-installer optional srm-reader_0.07.dsc
 7495bbbac560d9e9f5265fd8e255b839 5912 debian-installer optional srm-reader_0.07.tar.gz
 085d64893a8565efd8c7e498653043ac 1164 debian-installer optional srm-reader_0.07_alpha.udeb
package-type: udeb

Version: GnuPG v1.2.5 (GNU/Linux)


Reply to: