[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#287610: Installation failed at hardware detection (module ide-disk hangs system)

Package: installation-reports

Debian-installer-version: tried rc2 and "current" floppy images,
                          and netboot 2.4 and 2.6 rc2 images.
uname -a: <don't get that far>
Date: 28th/29th Dec, 2004
Method: Machine doesn't boot from CD, so tried both floppy and netboot
        from hd as per section 5.1.2 of installation manual.

Machine: Pentium II 233
Processor:  Pentium II 233
Memory: 64Mb
Root Device: <don't get that far>
Root Size/partition table: <don't get that far>
Output of lspci and lspci -n:
    <from previous installation>
    00:00.0 Host bridge: VIA Technologies, Inc. VT82C585VP [Apollo VP1/VPX] (rev 10)
    00:07.0 ISA bridge: VIA Technologies, Inc. VT82C586/A/B PCI to ISA [Apollo VP] (rev 25)
    00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
    00:08.0 VGA compatible controller: S3 Inc. 86c764/765 [Trio32/64/64V+] (rev 54)
    00:09.0 Ethernet controller: Intel Corp. 82557 [Ethernet Pro 100] (rev 02)

    00:00.0 Class 0600: 1106:0585 (rev 10)
    00:07.0 Class 0601: 1106:0586 (rev 25)
    00:07.1 Class 0101: 1106:0571 (rev 06)
    00:08.0 Class 0300: 5333:8811 (rev 54)
    00:09.0 Class 0200: 8086:1229 (rev 02)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


I have an old installation of woody on the machine that hasn't been updated for
almost 18 months (been sitting turned off in the corner), with a whole lot of
stuff installed that I neither need or remember. I wanted to do some testing
of configuration before making changes to our main server, so was trying to install
sarge (with full reformat) from new to clean out the cruft.

Installation progresses to the point of loading the module ide-disk, and then
consistently hangs/hard locks. No keyboard, no error message if load by 
'modprobe -v ide-disk'
on a console in medium/expert install, no difference when passing ide=nodma (which
the previous install did need), noapic nolapic also do not fix it.

This occurs 100% of the time, in every version of the installer that I tried.

If this module is not loaded, the installer doesn't see the hard drives.

Any suggestions (apart from using the machine as a boat anchor)?


Reply to: