[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#286939: Medley driver claims "No usable RAID sets found", which is wrong!

Package: debian-installer
Version: RC2, and 22 Dec 04 daily build

I have two Maxtor 6Y160M0 (160Gb) drives on a Silicon Image 3112 "RAID"

You may remember me from #258500, which was simply nobody pointing me
towards the medley driver! I've now found it, and a few months ago I got
it to work (I got as far as the partitioning stage and then chickened
out, but it saw the 320Gb RAID array ok) - by manually doing "modprobe
medley" in the busybox console on Alt-F2 just after "Detect hardware"
and just before "Partition disks". [Incidentally I have tried several
times to close down #258500, but with no success.]

Now I've backed everything up and decided to try a real install, and it
doesn't work any more! The sata_sil module installs ok, and the
installer can see the drives (and indeed offers me the chance to install
on them directly if I'm prepared to nuke one of the volumes ...!), but
when I try "modprobe medley" on the Alt-F2 console it says

Insmod: init_module: medley: no such device

... and the log console (Alt-F4) says: 

Medley RAID: No usable RAID sets found

... which is clearly wrong because (i) it's got hundreds of gigs of
Windoze rubbish on it, and is working fine under XP, and (ii) it's the
SAME array that the installer found perfectly well a couple of months

I've tried RC2 and today's daily build. I've tried the silraid driver as
well as the medley driver, to no avail. The silraid driver says

Driver for Silicon Image(tm) Medley(tm) hardware version 0.0.1: No RAID
array found

... which is essentially the same thing. 

So something has gone wrong since RC1 (which is what I was using when I
got it to work, and no longer have available). 

Very grateful for any tips,


Reply to: