[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#286901: debian-installer: install-grub fails with RAID1

On (22/12/04 22:49), Lukas Matasovsky wrote:
> Package: debian-installer
> Severity: normal
> Hi,
> tried to setup a new system with a two harddisks (hda, hdc) raid1 array.
> Configuring raid volumes and raid device using the installer seemed to
> be fine but installation of grub fails.
> Tried to use ash to setup it like:
> 	grub>device (hd0) /dev/hdc
> 	grub>root (hd0,0)       
> 	grub>setup (hd0)
> and vice versa but does not boot this way?
Booting from Raid is not for the fainthearted ;)  However, there are
some good docs:


FWIW I installed (d-i rc2) on a separate IDE drive and then mounted two
SATA drives as a raid array /dev/md0 created an ext3 file system:
$ mdadm -Cv /dev/md0 -l1 n2 /dev/sda1 /dev/sdb1
$ mkfs.ext3 /dev/md0

and then mounted it as /home

Works a treat ;)



www.clivemenzies.co.uk ...
...strategies for business

Reply to: