[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#286534: (no subject)

Package: installation-reports

Debian-installer-version: sarge netinst installer (RC2) from debian
installer home page
uname -a: <The result of running uname -a on a shell prompt>
Date: 12/20/04
Method: I tried to install from the netinst cd. 

Machine: Dell Precision 340 Workstation
Processor: Pentium 4 2.40 GHz
Memory: 1 GB 
Root Device: IDE 80 GB (WDC WD800BB-75CAA0)
Root Size/partition table: 

Output of fdisk -l /dev/hda:

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1           5       40131   de  Dell Utility
/dev/hda2   *           6        5902    47367652+   7  HPFS/NTFS
/dev/hda3            5903        7049     9213277+  83  Linux
/dev/hda4            7050        9729    21527100    f  W95 Ext'd (LBA)
/dev/hda5            7050        9597    20466778+   c  W95 FAT32 (LBA)
/dev/hda6            9598        9729     1060258+  82  Linux swap

Output of parted /dev/hda:
GNU Parted 1.6.9
Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003 Free Software
Foundation, Inc.
This program is free software, covered by the GNU General Public

This program is distributed in the hope that it will be useful, but
WARRANTY; without even the implied warranty of MERCHANTABILITY or
PARTICULAR PURPOSE.  See the GNU General Public License for more

Using /dev/hda
Information: The operating system thinks the geometry on /dev/hda is
9729/255/63.  Therefore, cylinder 1024 ends at 8032.499M.
(parted) p
Disk geometry for /dev/hda: 0.000-76319.085 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031     39.221  primary   fat16
2         39.221  46296.694  primary   ntfs        boot
3      46296.694  55294.035  primary   ext3
4      55294.036  76316.594  extended              lba
5      55294.066  75281.154  logical   fat32       lba
6      75281.186  76316.594  logical   linux-swap

Output of lspci:
0000:00:00.0 Host bridge: Intel Corp. 82850 850 (Tehama) Chipset Host
Bridge (MCH) (rev 04)
0000:00:01.0 PCI bridge: Intel Corp. 82850 850 (Tehama) Chipset AGP
Bridge (rev 04)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 04)
0000:00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 04)
0000:00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 04)
0000:00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev
0000:00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 04)
0000:00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97
Audio (rev 04)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon
RV100 QY [Radeon 7000/VE]
0000:02:0c.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M
[Tornado] (rev 78)

Output of lspci -n:
0000:00:00.0 0600: 8086:2530 (rev 04)
0000:00:01.0 0604: 8086:2532 (rev 04)
0000:00:1e.0 0604: 8086:244e (rev 04)
0000:00:1f.0 0601: 8086:2440 (rev 04)
0000:00:1f.1 0101: 8086:244b (rev 04)
0000:00:1f.2 0c03: 8086:2442 (rev 04)
0000:00:1f.3 0c05: 8086:2443 (rev 04)
0000:00:1f.4 0c03: 8086:2444 (rev 04)
0000:00:1f.5 0401: 8086:2445 (rev 04)
0000:01:00.0 0300: 1002:5159
0000:02:0c.0 0200: 10b7:9200 (rev 78)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [E]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


As you can see from my partition table I have a main windows partition
with ntfs (windows 2000 - hda2), a small dell utility partition (hda1),
and a fat32 windows partition for data to share with linux (hda5). I
also prepared a partition to install linux on, and a swap partition. But
when the debian installer got to the partitioning section it wouldn't
recognize my partition table. I selected the option to edit the
partitions manually, but then the only thing in the menu was the entire
hard drive. According to the output of fdisk I tried to pass the
following line to the installer:

linux hd=9729,255,63

but that didn't help. This computer originally just had two partitions,
the ntfs windows 2000 partition and the small dell utility partition. I
made extra partitions with an old version of partition magic (don't know
which version) and installed Suse linux on those partitions. I've since
removed that and played with the partitions some using the windows 'Disk
Management' tool. I think the problem is with parted or partman or
whatever you guys use, since fdisk shows the partition and the ubuntu
installer had the same problem. I don't want to overwrite my disk and I
think there should be a way to read this partition table. I used knoppix
to generate the commands above.

Reply to: