[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283452: No SCSI module support in Debian Installer RC2

Package: installation-reports

Debian-installer-version:  RC2, 20041118 floppy image set
uname -a:   N/A
Date:  11/28/2004  2100 EST
Method: How did you install?  Network.
	What did you boot off?  Floppy
	If network install, from where?  ftp://debian.uchicago.edu  Proxied?  No.
	Connected through masquerading hardware firewall box.

Machine:  Compaq Deskpro
Processor:  Pentium 1  133 MHz
Memory:     32 MB
Root Device: SCSI?  Yes.  Name of device?  /dev/sda3
Root Size/partition table:  Unable to access drives in this attempt
Output of lspci:
0000:00:00.0 Host bridge: Intel Corp. 430HX - 82439HX TXC [Triton II] (rev 01)
0000:00:03.0 Ethernet controller: Digital Equipment Corporation DECchip 21041 [Tulip Pass 3] (rev 11)
0000:00:07.0 ISA bridge: Intel Corp. 82371SB PIIX3 ISA [Natoma/Triton II] (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82371SB PIIX3 IDE [Natoma/Triton II]
0000:00:0f.0 VGA compatible controller: Cirrus Logic GD 5436 [Alpine]

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [E]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


1.	The situation with SCSI modules has deteriorated since RC1.  This
time I was unable to bring any SCSI drivers into
/lib/modules/2.4.27-1-386/kernel/drivers from the net-drivers floppy, the
cd-drivers floppy, or the Debian mirror.  As a result, I couldn't even
manually load the aha1542 driver with a modprobe command this time.  That
made it impossible to access any of my hard disks or my CD-ROM drive.  The
partitioner listed only the IDE device.
2.	RC2 still doesn't deal gracefully with devices that aren't
auto-detected.  It saw my Tulip card and loaded the module, but didn't
detect either of the NE-2000 cards.  The ne.o driver was present in the
kernel driver tree, and I was able to load it with a modprobe command.  I
was able to use that driver to load driver components from the mirror;
except that no SCSI modules were included in the download, or in the list of
installer components to select for downloading.
	There needs to be a place, either in the main menu, or after the
program lists the hardware that was detected, where it asks the user
whether there is any additional hardware that wasn't detected.  If the
answer is yes, it should list the available drivers for that class of
device, and allow the user to select additional drivers to be loaded. 
That's the way it used to be done.  Old hardware needs that level of manual
	Once the basic functionality is provided to make the names of the
available driver modules visible to the user for manual loading, it would be
desirable to add some help information to list the product names of hardware
devices alongside their driver modules.

Reply to: