[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283071: [Fwd: Package: installation-reports]

Package: installation-reports

Debian-installer-version: 2004-11-25, boot and root diskette images from http://people.debian.org/~joeyh/d-i/images/daily/floppy/

uname -a: Linux myhostname #1 Thu Nov 11 13:18:29 EST 2004 i686 GNU/Linux

Date: 2004-11-25 03z00
Method: Boot floppies, only boot.img and root.img needed as 8129 NIC in kernel img. I love floppies. Pls keep them, recycleable. Used expert mode. Used mirrors.kernel.org, no proxy.

Machine: Homegrown dinosaur, mobo has more ISA slots than PCI slots! Old Award BIOS. Realtek 8129 PCI NIC. I use this old dog as an OGG/mp3 fileserver and a browser cache via NFS. It's basically a power supply for 4 old IDE drives. It's a headless machine which lives in the closet with the cat.

Processor: Cyrix/IBM 6x86MX

Memory: about 164MB mem, mixed manufacturers, old, slow

Root Device: hdb. hda is swap (I like to put important stuff on heads/cylinders away from head/cylinder zero. It's a 'me' thing. Still superstious about head/cylinder zero.)

Root Size/partition table: 2GB
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda2             1.8G  381M  1.5G  21% /
tmpfs                  78M     0   78M   0% /dev/shm
/dev/hdc               38G   33M   38G   1% /home

Output of lspci and lspci -n:

0000:00:00.0 Host bridge: Intel Corp. 430TX - 82439TX MTXC (rev 01)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 01)
0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10) 0000:00:0f.0 VGA compatible controller: Trident Microsystems TGUI 9660/938x/968x (rev d3)

lspci -n:
0000:00:00.0 0600: 8086:7100 (rev 01)
0000:00:07.0 0601: 8086:7110 (rev 01)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 01)
0000:00:0b.0 0200: 10ec:8139 (rev 10)
0000:00:0f.0 0300: 1023:9660 (rev d3)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked: [O]
Configure network HW: [O]
Config network: [O]
Detect CD: [ ] no CD
Load installer modules: [O]
Detect hard drives: [ ]
Partition hard drives: [O]
Create file systems: [O]
Mount partitions: [O]
Install base system: [O]
Install boot loader: [O]
Reboot: [O]


<Description of the install, in prose, and any thoughts, comments
and ideas you had during the initial install.>

1. During the package selection process, I chose File Server and also Manual Select (or whatever it is), which threw me into aptitude, which I have not used (I have been using dselect). So it was an 'unplanned surprise', and I had to carefully learn aptitude on-the-fly without messing up the last part of the install. Perhaps a user-choice here between manual using dselect or manual using aptitude, because this is the last part of the install and it would be sad to mess it up just because of not being familiar with aptitude. Anyway, it seems to have installed well for me, and must therefore be donkey-proof.

2. I originally chose 'manual' to unselect the exim package, as I don't need a mail-server, and could not find it in aptitude to unselect, so it probably installed it anyway. The base system configuration menu asked me to configure the MTA. I just chose 'no configure at this time', then later uninstalled exim4 with dselect. Perhaps a specific user choice as to whether a mail service is required.

3. I saw some hda IDE0 timeout/crc errors during boot when reiserfs was playing the transaction log, but this could be my hardware, which is very old. They dissappeared when I turned off the cpu overclocking in the BIOS. Looks like might not like overclocking. 2.4.18-bf2.4 didnt mind it.

4. I though it odd that appletalk is installed by default as I have never used it myself. I killed it and its modules with dselect. Perhaps a user-choice if the user selects fileserver in tasksel?

5. It went very smoothly for me. The Debian U.S. mirror was down, and, for a while, it looked like an installer script had hung. I ctrl-C'd out, changed to the kernel.org mirror, and went along without problems. Perhaps a timeout to tell user that the mirror, not the installed, is dead. Perhaps a sig trap for people like me who Ctrl-C out of a script to see if the mirror had been contacted at all, and, if not, to ask for another mirror.

Reply to: