[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283010: Installation Report RC2 on Compaq AlphaServer DS20E

Package: installation-reports


Debian-installer-version: 24/11/2004 (rc2) http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/alpha/rc2/sarge-alpha-netinst.iso
uname -a: Linux jupiter 2.4.27-1-generic #1 Sat Sep 4 01:15:04 CEST 2004 alpha unknown
Date: Mi Nov 24 20:14:38 UTC 2004
Method: sarge-alpha-netinst.iso boot from CDROM using serial console
        ftp from sunsite.informatik.rwth-aachen.de (no proxy)
Machine: Compaq AlphaServer DS20E
Processor: Alpha EV67, 2way SMP
Memory: 1024 MB
Root Device: SCSI Harddisk on aic7xxx, ID 0, /dev/sda, 36GB
Root Size/partition table:
#       start       end      size     fstype   # NOTES #
  a:        1*        1*        0*      ext2   aboot
  b:        1*       78*       76*      ext2   /target/boot
  c:       78*      345*      267*      ext2   /target
  d:      345*     5113*     4768*      ext2   /target/usr
  e:     5113*     7974*     2861*      ext2   /target/var
  f:     7974*    10990*     3015*      swap   swap
  g:    10990*    11371*      381*      ext2   /target/tmp
  h:    11371*    35004*    23632*      ext2   /target/home
  i:  2097152*        0*  2097151*        ff   ?, see comment below

0000:00:05.0 ISA bridge: Contaq Microsystems 82c693
0000:00:05.1 IDE interface: Contaq Microsystems 82c693
0000:00:05.2 IDE interface: Contaq Microsystems 82c693
0000:00:05.3 USB Controller: Contaq Microsystems 82c693
0000:00:06.0 SCSI storage controller: Adaptec AHA-2940U/UW / AHA-39xx / AIC-7895 (rev 04)
0000:00:06.1 SCSI storage controller: Adaptec AHA-2940U/UW / AHA-39xx / AIC-7895 (rev 04
0000:00:07.0 VGA compatible controller: Texas Instruments TVP4020 [Permedia 2] (rev 01)
0000:01:08.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
0000:02:00.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)
0000:02:01.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)
0000:02:02.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)
0000:02:03.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)

lspci -n:
0000:00:05.0 0601: 1080:c693
0000:00:05.1 0101: 1080:c693
0000:00:05.2 0101: 1080:c693
0000:00:05.3 0c03: 1080:c693
0000:00:06.0 0100: 9004:7895 (rev 04)
0000:00:06.1 0100: 9004:7895 (rev 04)
0000:00:07.0 0300: 104c:3d07 (rev 01)
0000:01:08.0 0604: 1011:0024 (rev 03)
0000:02:00.0 0200: 1011:0019 (rev 41)
0000:02:01.0 0200: 1011:0019 (rev 41)
0000:02:02.0 0200: 1011:0019 (rev 41)
0000:02:03.0 0200: 1011:0019 (rev 41)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]

The installation of aboot, the bootloader for alpha SRM, fails. When I
select the "install aboot" option from the menu again, it tells me to select
the ext2 partition (disklabel, actually, but i'm going to stick with
'partition') for aboot, but only /dev/sda2 (/boot) can be selected, which
fails, too. 

The system has been partitioned with "Erase entire disk", "Multi-user
workstation" options, and the problem seems to occur only with this specific

The problem seems to be the 'i' partition (see above), which confuses swriteboot.

And since the partition confuses me too, not making any sense, I delete it
from a commandline (since it did not show up in the partitioner).
After deleting the partition I select 'install aboot' again, which works
like a charm. After that I continue with the rest of the installation, which
runs without problems, resulting in a well-configured and booting system. (I
even get a getty on the serial console - nice work).

Anyway, it seems the that the strange additional partition of type ff, which
was created by the partitioning software, triggered the problem.

I've tried again on another box, this time selection manual partitioning and
this time the partition did not appear and the installation finshed without
a problem, so i guess this is auto-partitioning (for the lack of a better
word) related. On yet another box I selected auto-partitioning with only one
partition "All files on one partition" and that does also not seem to
trigger the problem.

Feel free to contact me for further details or anything you want me to try,
i'm more than willing to put in a couple of hours to help improving the
alpha installer. I also have a number of currently-unused systems lying
around, so if you want me to help with other known issues with the d-i on
alpha let me know or point me in the right direction in the BTS.


Nils Juergens

Reply to: