[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#282696: Installation Report

Package: installation-reports


Debian-installer-version: pre-rc2, 11/19/04 and 11/21/04

uname -a: Linux debian 2.4.27-1-386 #1 Fri Sep 3 06:24:46 UTC 2004 i686 GNU/Linux

Date: 11/20/04 and 11/22/04

Method: boot from net install CD,
                   both manual install and automatic install,
use local sarge binaries mirror updated on 11/15/04, no proxy
Machine: White Box Dual Xeon Server from Promicro

Processor: Dual Xeon 2.4GHz

Memory: 4 GB DDR PC2100 Registered ECC

Root Device: 3ware hardware raided SATA logical drive (/dev/sda)

Root Size/partition table: df -kl:
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda2               933393     76864    806728   9% /
tmpfs                   452704         0    452704   0% /dev/shm
/dev/sda1                90297     15201     70279  18% /boot
/dev/sda7              5905972     32872   5573088   1% /home
/dev/sda8              1874267      8239   1766025   1% /opt
/dev/sda5              3937220    293904   3443312   8% /usr
/dev/sda6               933361     61455    822107   7% /var

Output of lspci and lspci -n:
debian:~# lspci
0000:00:00.0 Host bridge: Intel Corp. E7501 Memory Controller Hub (rev 01)
0000:00:00.1 ff00: Intel Corp. E7500/E7501 Host RASUM Controller (rev 01)
0000:00:02.0 PCI bridge: Intel Corp. E7500/E7501 Hub Interface B PCI-to-PCI Bridge (rev 01)
0000:00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #2) (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #3) (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 42)
0000:00:1f.0 ISA bridge: Intel Corp. 82801CA LPC Interface Controller (rev 02) 0000:00:1f.1 IDE interface: Intel Corp. 82801CA Ultra ATA Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801CA/CAM SMBus Controller (rev 02)
0000:01:1c.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 04)
0000:01:1d.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 04)
0000:01:1e.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 04)
0000:01:1f.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 04)
0000:02:01.0 RAID bus controller: 3ware Inc 3ware 7000-series ATA-RAID (rev 01) 0000:03:02.0 Ethernet controller: Intel Corp. 82546EB Gigabit Ethernet Controller (Copper) (rev 01) 0000:03:02.1 Ethernet controller: Intel Corp. 82546EB Gigabit Ethernet Controller (Copper) (rev 01) 0000:04:01.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)

debian:~# lspci -n
0000:00:00.0 0600: 8086:254c (rev 01)
0000:00:00.1 ff00: 8086:2541 (rev 01)
0000:00:02.0 0604: 8086:2543 (rev 01)
0000:00:1d.0 0c03: 8086:2482 (rev 02)
0000:00:1d.1 0c03: 8086:2484 (rev 02)
0000:00:1d.2 0c03: 8086:2487 (rev 02)
0000:00:1e.0 0604: 8086:244e (rev 42)
0000:00:1f.0 0601: 8086:2480 (rev 02)
0000:00:1f.1 0101: 8086:248b (rev 02)
0000:00:1f.3 0c05: 8086:2483 (rev 02)
0000:01:1c.0 0800: 8086:1461 (rev 04)
0000:01:1d.0 0604: 8086:1460 (rev 04)
0000:01:1e.0 0800: 8086:1461 (rev 04)
0000:01:1f.0 0604: 8086:1460 (rev 04)
0000:02:01.0 0104: 13c1:1001 (rev 01)
0000:03:02.0 0200: 8086:1010 (rev 01)
0000:03:02.1 0200: 8086:1010 (rev 01)
0000:04:01.0 0300: 1002:4752 (rev 27)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]

1. I will say this is a smooth installation. Kudos to the debian installer team!

2. The installer failed to recognize the SMP and installed the genuine 2.4.27-1-386 kernel after finishing the base installation. I had to manually grab and install kernel 2.4.27-1-686-smp. This happened to both manual and automatic installation.

3. During automatic installation, an empty root password would cause the installer trapped in a endless loop of alerting insecure empty root password.

4. The apt setup kept contacting security.debian.org and made the automatic installation interrupted. I don't think it a bug, but really hope to go around it. (Use a proxy?)

5. Exim is slow to start and reload. (I know it's not a bug)

6. The installer seems only add one additinal user. I specified 3 in the preseed but only got the last one. :)

7. No HIGHMEM64G compiled kernels in sarge. (This is not a problem of the installer. )

We have a couple dozens of servers with 6GB or 8GB RAM and I am in a process of purchasing new ones with 16GB RAM! Most of these servers are runing old expired Redhat 7.2~9, and I am testing a quick and easy way to migrate them to Debian sarge. So far the CD boot net installation testings look promising and I am preparing to test the net-boot automatic installation. Hopefully the installer can find the SMP/HIGHMEM and install the right kernel, otherwise I may need some post installation scripts to deal with it.


Reply to: