[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#282652: installation report

Package: installation-reports


Debian-installer-version: Alpha 20041118 for Sarge
uname -a: Linux undead 2.6.8-1-generic #1 Mon Oct 11 06:38:27 CEST 2004
alpha GNU/Linux
Date: 20041119 thru 20041122
Method: I used a tftp/bootp server with boot.img from the,

SRM command as follows:

P00>>boot ewa0 -fl "root=/dev/ram ramdisk_size=16384" -fi

I used my local LAN mirror and also http://ftp.us.debian.org to do the
installs (more than once)

Machine: Digital 2100 Server, A500MP
Processor: EV4/233
Memory: 256MB
Root Device: /dev/sda3
Root Size/partition table:
undead:~# fdisk -l /dev/sda
Disk /dev/sda: 4290 MB, 4290600960 bytes
132 heads, 62 sectors/track, 1023 cylinders
Units = cylinders of 8184 * 512 = 4190208 bytes

5 partitions:
#       start       end      size     fstype   [fsize bsize   cpg]
  a:        1*        1*        0*      ext2
  b:        1*       20*       19*      ext2
  c:       20*      971*      951*      ext2
  d:      971*     1024*       53*      swap

Tried to do the Multi-User thing and aboot just would not install. This
is the guided one-partition thing. I have a gaggle of disk for this
thing too.

Output of lspci and lspci -n:

undead:~# lspci
0000:00:00.0 Ethernet controller: Digital Equipment Corporation DECchip
21040 [Tulip] (rev 22)
0000:00:01.0 Non-VGA unclassified device: LSI Logic / Symbios Logic
53c810 (rev 01)
0000:00:02.0 Non-VGA unclassified device: Intel Corp. 82375EB/SB PCI to
EISA Bridge (rev 03)
undead:~# lspci -n
0000:00:00.0 0200: 1011:0002 (rev 22)
0000:00:01.0 0000: 1000:0001 (rev 01)
0000:00:02.0 0000: 8086:0482 (rev 03)

I also have a Q-Vision VGA card in this thing, on the EISA bus.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ] (O but didn't do final from CD)
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O & E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O & E]
Reboot:                 [O]

The system installed flawlessly from tftp on my final installation.
Found my local mirror on a few tries and also found ftp.us.debian.org
and other ones I tried as well.

Okay, onto the issues:
On first install from CD-ROM, I was very impressed. Until I got to the
aboot installation. It failed. I had selected the Multi-User guided
setup. It could not write the aboot to the bootblock and
partition #1. I could do a manual install of aboot, (swriteboot -f1
boot/bootlx) but the point was to have it done automagically. Would not
do it, time and time again. I switched to using one partition
for / and one partition for /boot, and one for swap. Of course #1 for
aboot. And voila, it installed perfectly. This is not the way I like my
machines setup, but for now I'll deal.

I installed kernel-image-2.4.27-1-generic. It installed OK, but the
sym53c8xx module would not load at all. It would not detect the card. I
even passed along boot parametrs to get things work, no go. (This
I believe is a kernel bug). The funny thing is the installer was using
2.4.26-something. This lead me to try kernel-image-2.6.8-1-generic
(v2.6.8-8). I know about v2.6.8-9. I booted from tftp again and
did a chroot into the just install system. I installed the
2.6.8-1-generic kernel and rebooted.

That booted really well, except for this "sym0:0:0:M_REJECT to send
for : 1-2-3-1." was scrolling everything off the screen. Eventually the
machine locked up. This was all before the base config was completed. So
I ended up booting the installer again and doing a chroot into the
installed machine and added ' sym53c8xx="debug:0x80" ' to the boot lines
in aboot. That allowed me to boot proper into the base-config at first
boot and quell 99% of the debug info.

Once I got the machine to boot proper, I have edited aboot.conf to
"appear" to work similarly to update-grub. Someone (if I can hack it)
should consider doing a update-aboot script similar to update-grub. It
would make things much more simple. It would allow to update the kernel
without having to futz with the aboot.conf and hope you got it right.
There are some limitations in aboot.conf, but those could be written
into the script. Then you could also use this script to actually help
the people maintain or change the auto-boot sequence in SRM as well.

Also, some explanation of the whole SRM auto-boot setup should probably
be discussed during the aboot install. Not that it is hard, just that
some people have really never had to deal with SRM. Only ARC (for
Windows NT on Alpha). There are even fewer people that have done a
conversion from VMS-AXP to Debian Linux as well, dealing with SRM is
very archaic to some people.

Also, see attached backup of the /var/log/debian-installer/ directory.

Attachment: debian-installer.tgz
Description: application/compressed-tar

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: