[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#281724: problem with root on software raid

On Wed, 17 Nov 2004 16:08:26 +0100 Alexander A. Vlasov wrote:
> Recently I installed sarge on a few machines (~5), and I used a software
> raid as a root device. Installation progress was successfull until
> bootloader has to be installed. 
> When I tried a "next step -- install bootloader", I got a choice: where
> MBR should be placed. Menu consisted of three options: "/dev/md0: root
> device", "/dev/md0: new debian partition" and "other: for experts".
> I tried /dev/md0 (both of. They are the same, I suspect). I got a
> pop-up, saying that /dev/md0 isn't active. (During partitioning. I
> marked both partitions /dev/md0 consist of as "bootable"). Popup asked,
> if I want to make /dev/md0 active. When I selected "yes", I got the
> error message saying "An error occured during installing boot
> loader", and I returned to previous menu. When I selected "no", I got a
> message saying "error: lilo returns -1 as exit code", and again, I was
> returned to previous menu.

I have had the same problem, with a slightly different setup, /boot on
it's own small RAID-1 partition, root on LVM on RAID-1.  My /boot
filesystem is ext2, root filesystem ext3.

If I understand correctly, if you choose "/dev/md0: root device", LILO
should install into the MBR.  If you choose "/dev/md0: new debian
partition" LILO should install into the superblock of the RAID device.
In actual fact, LILO will install into the superblock in either case,
because to install into the MBR with /boot on RAID-1, you have to pass
raid-extra-boot=mbr (to install into the superblock of the device _and_
into the MBR of each member device of the RAID) or
raid-extra-boot=mbr-only (to install only into the MBR of each member
device of the RAID).  From my testing, debian-installer does not do this.

My hunch is that the error that Alexander and I get has something to do
with different device names: /dev/md/0 vs /target/dev/md0, but I am
fully prepared to be wrong, I've just spent one day playing with d-i.



Reply to: