[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#281724: problem with root on software raid

Package: installation-reports

Debian-installer-version: pre-rc2
uname -a: various
Date: November 2004
Method: from CD (sarge-i386-businesscard)
Machine: various 
Processor: various x86
Memory: various, 128M .. 1G
Root Device: software raid
Root Size/partition table: root on /dev/md0, consisting of a pair of
 identical partitions on two disks. Tried both ide & scsi.
Output of lspci and lspci -n: various

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]


Recently I installed sarge on a few machines (~5), and I used a software
raid as a root device. Installation progress was successfull until
bootloader has to be installed. 
When I tried a "next step -- install bootloader", I got a choice: where
MBR should be placed. Menu consisted of three options: "/dev/md0: root
device", "/dev/md0: new debian partition" and "other: for experts".
I tried /dev/md0 (both of. They are the same, I suspect). I got a
pop-up, saying that /dev/md0 isn't active. (During partitioning. I
marked both partitions /dev/md0 consist of as "bootable"). Popup asked,
if I want to make /dev/md0 active. When I selected "yes", I got the
error message saying "An error occured during installing boot
loader", and I returned to previous menu. When I selected "no", I got a
message saying "error: lilo returns -1 as exit code", and again, I was
returned to previous menu.

So only way to install was select "do not make /dev/md0 active", get an
error (during this step, file /etc/lilo.conf on /target was created),
log in on second console, chroot to /target, manually edit
/etc/lilo.conf, appending 'raid-extra-boot=mbr-only', manually run lilo,
return to first console and select "continue without bootloader". After
this, everything is went OK. Reboot, base config and so on... 

This bug/strange behavior is 100% reproduceable, I get it five times
during five installs.

WBR, Alexander A. Vlasov 
 Gala.Net System Administrator
 nic-hdl:                       ZULU-UANIC

Reply to: