[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#281556: s390 installation report, installed system does not boot

Package: installation-reports


Debian-installer-version: http://ftp.de.debian.org/debian/dists/unstable/main/
uname -a: Linux debian 2.4.27-1-s390 #1 SMP Tue Aug 17 12:18:33 CEST 2004 s390 GNU/Linux
Date: 2004.11.15-2004.11.16
Method: ipl from tape, used ssh after

Machine: hercules, version 2.17.1-2 
Root Device: <IDE?  SCSI?  Name of device?>
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.
Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E/-]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]

 I was not able to format dasd using d-i (known problem, should be fixed now), so
I formated dasd manually and formated it with cfdisk. After successfull firts stage
I rebooted hercules but I was not able to boot using zipl defaul setup. Linux was
not able to find root partition (zipl.conf attached).
 After using google.com I found that I need to pass dasd=0120 to zipl in order
to boot. That worked. It is posible that dasd parameter is missing because I
did not use d-i for formating dasd and partitioning.
defaultmenu = menu

target = /boot
1 = debian
2 = old
default = 1
prompt = 1
timeout = 10

target = /boot
image = /boot/vmlinuz
parameters = ro vmpoff="LOGOFF" root=/dev/dasda1

target = /boot
image = /boot/vmlinuz.old
parameters = ro vmpoff="LOGOFF" root=/dev/dasda1
optional = 1

Reply to: