[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Woody->Sarge upgrade report

Hash: SHA1

Upgrade test Woody->Sarge

Method: remote over SSH
Procedure: used Sarge Release Notes as basis, but deviated at some points
Machine: Compaq Deskpro in use as a general server
Running: BIND9, DHCP3, NFS-server, SAMBA, Apache, MySQL, Exim, logcheck

I copied my whole installation to a spare disk, made that installation
bootable and performed the upgrade on that.

The typescript for the upgrade and the log from aptitude are attached.

I'm not sure how to proceed on all issues. Should I file (RC?) bugs

1. Install Woody's aptitude

==> This is not described correctly in Release Notes.

2. Mark all libs and some other packages as "automatically installed"
3. Change sources.list to point to Sarge
4. Set debconf frontend to "readline" and start 'script'
   - Hmmm. I later discovered that this does not show the old choices
     and default values for questions.
5. Run 'aptitude update' -> FAILS
   Run 'apt-get update'  -> SUCCESS

ISSUE 1: 'aptitude update' fails, but 'apt-get update' has no problems
Aptitude fails with (see also typescript):
W: Couldn't stat source package list http://ftp.nl.debian.org sarge/main Packages
   - stat (2 No such file or directory)
W: You may want to update the package lists to correct these missing files

==> This needs to be fixed or changed in Release Notes.

7. Update dpkg and aptitude to Sarge with 'aptitude install dpkg aptitude'
   - This also upgrades libc
   - Installing only dpkg or aptitude is not enough (aptitude will pull in
     apt and apt-get)
   - Why is dselect shown as a NEW package (it was installed)

==> This is not described correctly in Release Notes.

ISSUE 2: Apache pass phrase dialog for SSL not asked during libc6 upgrade
Apache was restarted during this upgrade. Normally, during boot, I am
shown a prompt asking to enter the pass phrase.
Now, the upgrade just stopped (seemed to hang).
I blindly entered the pass phrase and the upgrade continued.

==> This needs to be fixed.

8. I don't really like the suggestion to run aptitude with --with-suggests,
   so I decided to just run aptitude and select my packages manually there.
   - deselect old gcc version in "Obsolete packages"
   - Woody's ide-smart is not automatically replaced by Sarge's smartmontools
   - Select some extra packages from "Suggested packages" after pressing 'g'
   - Start upgrade with second 'g'
   - During this phase the "Enter pass phrase" prompt _was_ shown when
     starting Apache:
       Starting web server: apacheEnter pass phrase:
     (Note the missing newline, but that's minor.)

As I need 'megaraid' support in my kernel, I decided to compile a new 2.4.27
kernel (from Debian kernel-source package) before rebooting.
I used 'make oldconfig' to update my kernel config (from non-Debian 2.4.21).

ISSUE 3 (before reboot): Logcheck errors
After the installation completed, while I was compiling the new kernel,
I noticed two mails in my mailbox.
- - From mail from Cron Daemon to root, subject "Cron <logcheck@elrond> ..."
  /usr/sbin/logcheck: line 1: /var/log/exim/paniclog: Permission denied
- - From mail from logcheck@elrond.fjphome.nl to root, subject:
    "Logcheck: elrond 2004-11-15 00:02 exiting due to errors"
  Warning: If you are seeing this message, your log files may not have been checked!
  Details: Could not run logtail or save output
  Check temporary directory: /tmp/logcheck.79g576
  declare -x HOME="/var/lib/logcheck"
  declare -x LOGNAME="logcheck"
  declare -x MAILTO="root"
  declare -x OLDPWD
  declare -x PATH="/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin"
  declare -x PWD="/var/lib/logcheck"
  declare -x SHELL="/bin/sh"
  declare -x SHLVL="2"

==> I think these are separate issues that should be fixed.
ISSUE 4: lilo
A dangling symlink is left in /boot: boot.b -> boot-menu.b

ISSUE 5: Again no pass phrase prompt for Apache during reboot
Again the reboot seems to hang and blindly entering the pass phrase solves
the problem.

During boot of my Woody system I used to get:
  Starting web server: apacheApache/1.3.26 mod_ssl/2.8.9 (Pass Phrase Dialog)
  Some of your private key files are encrypted for security reasons.
  In order to read them, you have to provide us with the pass phrases.
  Server www.fjphome.nl:443 (RSA)
  Enter pass phrase:
  Ok: Pass Phrase Dialog successful

If manually I run /etc/init.d/apache restart, I get the same shortened dialog
as before:
  Starting web server: apacheEnter pass phrase:

ISSUE 6: mount errors during reboot
The following are lines copied from console. I have no idea where the
mount errors come from. All filesystems are properly mounted at the
end of the boot.
  INIT: version 2.86 booting
  mount: wrong fs type, bad option, bad super block on tmpfs,
         or too many mounted file systems
  Setting disc parameters: done.
  Activating swap.
  Adding Swap: 192740k swap-space (priority -1)
  Checking root file system...
  fsck 1.35 (28-Feb-2004)
  /dev.sda1: clean, 115812/1622016 files, 502863/3239097 blocks
  ext3 fs 2.4-0.9.19, 19 August 2002 on sd(8,1), internal journal
  mount: wrong fs type, bad option, bad super block on tmpfs,
         or too many mounted file systems
  <some lines skipped>
  Cleaning /tmp /var/run /var/lock
  mount: wrong fs type, bad option, bad super block on tmpfs,
         or too many mounted file systems

ISSUE 7: Under-documented change in run-parts (?)
I had two scripts in /etc/network/if-up.d and if-down.d called "local.sh".
After the upgrade these were not run anymore by ifup and ifdown, I think
because of a change in run-parts.
Renaming the scripts to "local" solved the problem.


Version: GnuPG v1.2.4 (GNU/Linux)


Attachment: aptitude.gz
Description: GNU Zip compressed data

Attachment: upgrade-to-sarge.typescript.gz
Description: GNU Zip compressed data

Reply to: