[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#278841: marked as done (does not detect megaraid2)

Your message dated Tue, 09 Nov 2004 13:02:06 -0500
with message-id <E1CRaJi-0008T3-00@newraff.debian.org>
and subject line Bug#278841: fixed in discover1-data 1.2004.11.09
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 29 Oct 2004 17:12:06 +0000
>From fournie@gmx.net Fri Oct 29 10:12:06 2004
Return-path: <fournie@gmx.net>
Received: from c2cpc2.camptocamp.com [] 
	by spohr.debian.org with smtp (Exim 3.35 1 (Debian))
	id 1CNaII-0004JD-00; Fri, 29 Oct 2004 10:12:06 -0700
Received: (qmail 15320 invoked by uid 1000); 29 Oct 2004 17:12:03 -0000
Date: Fri, 29 Oct 2004 19:12:03 +0200
From: Marc Fournier <fournie@gmx.net>
To: submit@bugs.debian.org
Subject: debian-installer
Message-ID: <20041029171203.GA9504@zalou.c2c>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.5.4i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports

Debian-installer-version: 27 0ct 04, from http://cdimage.debian.org/pub/cdimage-testing/sid_d-i/i386/pre-rc2/sarge-i386-netinst.iso
uname -a: Linux eiger 2.4.27 #2 SMP Fri Oct 29 19:09:45 CEST 2004 i686 GNU/Linux
Date: thursday 28 october
How did you install? netinst CD
What did you boot off? CD
If network install, from where? ftp.de.debian.org
Proxied? no

Machine: DELL PowerEdge 2850
Processor: Intel(R) Xeon(TM) CPU 3.00GHz (2 processors with Hyper-Threading)
Memory: 1033060
Root Device: SCSI (/dev/sda1)
Root Size/partition table:

Disk /dev/sda: 146.5 GB, 146548981760 bytes
255 heads, 63 sectors/track, 17816 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         122      979933+  83  Linux
/dev/sda2             123         244      979965   82  Linux swap
/dev/sda3             245       17816   141147090   8e  Linux LVM

Output of lspci and lspci -n:
eiger:~# lspci 
0000:00:00.0 Host bridge: Intel Corp. Server Memory Controller Hub (rev 09)
0000:00:02.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port A0 (rev 09)
0000:00:04.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port B0 (rev 09)
0000:00:05.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port B1 (rev 09)
0000:00:06.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port C0 (rev 09)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
0000:01:00.0 PCI bridge: Intel Corp. 80332 [Dobson] I/O processor (rev 06)
0000:01:00.2 PCI bridge: Intel Corp. 80332 [Dobson] I/O processor (rev 06)
0000:02:0e.0 RAID bus controller: Dell PowerEdge Expandable RAID controller 4 (rev 06)
0000:05:00.0 PCI bridge: Intel Corp. PCI Bridge Hub A (rev 09)
0000:05:00.2 PCI bridge: Intel Corp. PCI Bridge Hub B (rev 09)
0000:06:07.0 Ethernet controller: Intel Corp. 82541GI/PI Gigabit Ethernet Controller (rev 05)
0000:07:08.0 Ethernet controller: Intel Corp. 82541GI/PI Gigabit Ethernet Controller (rev 05)
0000:08:00.0 PCI bridge: Intel Corp. PCI Bridge Hub A (rev 09)
0000:08:00.2 PCI bridge: Intel Corp. PCI Bridge Hub B (rev 09)
0000:0b:0d.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]
eiger:~# lspci -n
0000:00:00.0 0600: 8086:3590 (rev 09)
0000:00:02.0 0604: 8086:3595 (rev 09)
0000:00:04.0 0604: 8086:3597 (rev 09)
0000:00:05.0 0604: 8086:3598 (rev 09)
0000:00:06.0 0604: 8086:3599 (rev 09)
0000:00:1d.0 0c03: 8086:24d2 (rev 02)
0000:00:1d.1 0c03: 8086:24d4 (rev 02)
0000:00:1d.2 0c03: 8086:24d7 (rev 02)
0000:00:1d.7 0c03: 8086:24dd (rev 02)
0000:00:1e.0 0604: 8086:244e (rev c2)
0000:00:1f.0 0601: 8086:24d0 (rev 02)
0000:00:1f.1 0101: 8086:24db (rev 02)
0000:01:00.0 0604: 8086:0330 (rev 06)
0000:01:00.2 0604: 8086:0332 (rev 06)
0000:02:0e.0 0104: 1028:0013 (rev 06)
0000:05:00.0 0604: 8086:0329 (rev 09)
0000:05:00.2 0604: 8086:032a (rev 09)
0000:06:07.0 0200: 8086:1076 (rev 05)
0000:07:08.0 0200: 8086:1076 (rev 05)
0000:08:00.0 0604: 8086:0329 (rev 09)
0000:08:00.2 0604: 8086:032a (rev 09)
0000:0b:0d.0 0300: 1002:5159

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]

The PowerEdge 2850 comes with a Perc 4e/Di RAID adapter, which seems to
require the "megaraid2" kernel module. Unfortunately the hardware detection
script tried to load the "megaraid" module, which failed. So I opened a
shell, typed "modprobe megaraid2" (which succedded). The drives were then
detected and I was able to finish the installation.

But at the first reboot, the kernel paniked because he couldn't find any
hard drive: using the "megaraid" driver once again.

This guy seems to have had exactly the same problem:

Unfortunatly I was unable to use the workaround his suggests (lack of
sufficient knowledge with mkinitrd) so I installed woody and apt-get

Hope this will help, feel free to ask for additional information.

Best regards and thanks for the great work,

Received: (at 278841-close) by bugs.debian.org; 9 Nov 2004 18:08:11 +0000
>From katie@ftp-master.debian.org Tue Nov 09 10:08:11 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CRaPb-0008Hn-00; Tue, 09 Nov 2004 10:08:11 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1CRaJi-0008T3-00; Tue, 09 Nov 2004 13:02:06 -0500
From: Joshua Kwan <joshk@triplehelix.org>
To: 278841-close@bugs.debian.org
X-Katie: $Revision: 1.51 $
Subject: Bug#278841: fixed in discover1-data 1.2004.11.09
Message-Id: <E1CRaJi-0008T3-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Tue, 09 Nov 2004 13:02:06 -0500
Delivered-To: 278841-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 6

Source: discover1-data
Source-Version: 1.2004.11.09

We believe that the bug you reported is fixed in the latest version of
discover1-data, which is due to be installed in the Debian FTP archive:

  to pool/main/d/discover1-data/discover1-data-udeb_1.2004.11.09_all.udeb
  to pool/main/d/discover1-data/discover1-data_1.2004.11.09.dsc
  to pool/main/d/discover1-data/discover1-data_1.2004.11.09.tar.gz
  to pool/main/d/discover1-data/discover1-data_1.2004.11.09_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 278841@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joshua Kwan <joshk@triplehelix.org> (supplier of updated discover1-data package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Tue,  9 Nov 2004 09:38:58 -0800
Source: discover1-data
Binary: discover1-data discover1-data-udeb
Architecture: source all
Version: 1.2004.11.09
Distribution: unstable
Urgency: medium
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joshua Kwan <joshk@triplehelix.org>
 discover1-data - hardware lists for libdiscover1
 discover1-data-udeb - hardware lists for libdiscover1 (short list) (udeb)
Closes: 255705 267302 276379 277655 278203 278841 278888
 discover1-data (1.2004.11.09) unstable; urgency=medium
   * Joshua Kwan
     - Change 1011:0019 to de4x5. closes: #267302
     - Add scsi/megaraid2 for 1028:0013, 1000:0408, and 1000:0409.
       (Use megaraid on 2.6 with pci-26.lst.) closes: #276379, #278888, #278841
     - Bind 1259:a11e to 8139too, closes: #277655
     - Add sound/snd-ens1371 for 1274:5580 to pci-26.lst. closes: #255705
     - Sync up piix and ata_piix bindings from upstream source PCI IDs.
       Thanks Sven Luther for the initial help with this. closes: #278203
     - Add scsi/esp for SUNW,fas. Thanks Steve Pacenka for alerting me to
       this esp variant.
 ee4d68a733039f8a5244caefafa018ac 1380 libs optional discover1-data_1.2004.11.09.dsc
 9b135419f5fff13b54417dca29f70349 101417 libs optional discover1-data_1.2004.11.09.tar.gz
 84f69db9909ecdffd94c798309cce97e 92466 libs optional discover1-data_1.2004.11.09_all.deb
 94cfbd703d820228841aa2dc0dea0276 16002 debian-installer extra discover1-data-udeb_1.2004.11.09_all.udeb
package-type: udeb

Version: GnuPG v1.2.5 (GNU/Linux)


Reply to: