[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Package: installation-reports


Debian-installer-version: pre-rc2, 5/11/2004

uname -a: 2.4.27-1-686-smp #1 SMP Fri Sep 3 06:34:36 UTC 2004 i686 GNU/Linux
Date: 5/11/2004
Method: CD-ROM boot of Debian-installer pre-rc2
Machine: Custom Build
Processor: Dual Xeon 2.4 Ghz (Hyperthreading)
Memory: 1024 Mb
Root Device: /dev/hda1
Root Size/partition table:  
proc            /proc           proc    defaults        0       0
/dev/hda4       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda1       /boot           ext3    defaults        0       2
/dev/hda3       /var            ext3    defaults        0       2
/dev/hda5       none            swap    sw              0       0
/dev/hdd        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/sda1	/raid		ext3 # 12x160Gb SATA disks, RAID10

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Intel Corp. E7501 Memory Controller Hub (rev 01)
0000:00:00.1 ff00: Intel Corp. E7500/E7501 Host RASUM Controller (rev 01)
0000:00:02.0 PCI bridge: Intel Corp. E7500/E7501 Hub Interface B PCI-to-PCI Bridge (rev 01)
0000:00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #2) (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #3) (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 42)
0000:00:1f.0 ISA bridge: Intel Corp. 82801CA LPC Interface Controller (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801CA Ultra ATA Storage Controller (rev 02)
0000:01:1c.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 04)
0000:01:1d.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 04)
0000:01:1e.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 04)
0000:01:1f.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 04)
0000:02:04.0 RAID bus controller: 3ware Inc 3ware 7000-series ATA-RAID (rev 01)
0000:02:05.0 SCSI storage controller: Adaptec AIC-7902B U320 (rev 10)
0000:02:05.1 SCSI storage controller: Adaptec AIC-7902B U320 (rev 10)
0000:03:03.0 Ethernet controller: Intel Corp. 82544GC Gigabit Ethernet Controller (LOM) (rev 02)
0000:04:01.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet Controller (rev 02)
0000:04:02.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)


0000:00:00.0 0600: 8086:254c (rev 01)
0000:00:00.1 ff00: 8086:2541 (rev 01)
0000:00:02.0 0604: 8086:2543 (rev 01)
0000:00:1d.0 0c03: 8086:2482 (rev 02)
0000:00:1d.1 0c03: 8086:2484 (rev 02)
0000:00:1d.2 0c03: 8086:2487 (rev 02)
0000:00:1e.0 0604: 8086:244e (rev 42)
0000:00:1f.0 0601: 8086:2480 (rev 02)
0000:00:1f.1 0101: 8086:248b (rev 02)
0000:01:1c.0 0800: 8086:1461 (rev 04)
0000:01:1d.0 0604: 8086:1460 (rev 04)
0000:01:1e.0 0800: 8086:1461 (rev 04)
0000:01:1f.0 0604: 8086:1460 (rev 04)
0000:02:04.0 0104: 13c1:1001 (rev 01)
0000:02:05.0 0100: 9005:801d (rev 10)
0000:02:05.1 0100: 9005:801d (rev 10)
0000:03:03.0 0200: 8086:100d (rev 02)
0000:04:01.0 0200: 8086:100e (rev 02)
0000:04:02.0 0300: 1002:4752 (rev 27)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [O]
Reboot:                 [O]


base-config -> tasksel -s :
The following packages have unmet dependencies:
    Conflicts: libreadline4 (< 4.3-13) but 4.3-11 is to be installed
-> solved by installing version 4.3-14 (unstable dist)

Recompiling kernel to add SMP support:
Using kernel-source-2.4.27, no SMP option available in .config file.  
Manually adding in CONFIG_SMP=y and running menuconfig triggers
CONFIG_NR_CPUS option to become available, but still the SMP option not
visible. Running make-kpkg OK, but dpkg -i kernel_image does not create
any initrd.img.  We did not try any further kernel recompilation , but
installed instead kernel-image-2.4.27-1-686-smp

RAID performance: 
Running Bonnie on the Raid array using kernel-image-2.4.27-1-686-smp gives
an unexpected 5% decrease in I/O compared to using the preinstalled
2.4.27-1-386 kernel.  We are still happy: we get 114Mb/s write, 74Mb/s
read.  If you wish more info on this, please let me know.

'Ghost' devices on boot:
Discover finds non-existent ich2rom device. 

Best regards,
Peter Sorensen
Nordic Optical Telescope

Reply to: