[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How do I get around small / partition?


I had several problems during install with RC1 (my questions in 
272626 went unanswered :-( ), but the problem that makes me think 
I have to start over is the 130MB partition the installer chose
for my root partition.  This was on a 160GB disk.  I figured at 
the time that perhaps there was some BIOS boot partition size
limit, and more stuff in sarge than woody would be on another

Apparently I was wrong.

After a few weeks running, and trying to install a 2.4.27 kernel
I built, I discovered that / was full:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1               135468    135346         0 100% /
tmpfs                   452668         0    452668   0% /dev/shm
/dev/hda8            145122904  33842032 103909048  25% /home
/dev/hda7               369000     10510    338830   4% /tmp
/dev/hda5              4807056   2178020   2384852  48% /usr
/dev/hda6              2885780    383096   2356096  14% /var

But when I tried to set the / partition to a number greater than
130MB, the installer told me that exceeded some limit.  I tried
reducing the size of other partitions first, which worked fine, 
but nothing would let me increase the size of /.

Is this a bug in the RC1 partition software?  If not, what was I
supposed to do?

I assume at this point, I have to wipe the disk and reinstall, 
but if anyone knows of a way to resize the partitions, that would
be great.

Most importantly, how do I keep this problem from repeating when
I re-install?

(Please cc me on replies.)


Do you Yahoo!?
Declare Yourself - Register online to vote today!

Reply to: