[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#274994: Installation via PPPoE uneasy

Package: installation-reports

Debian-installer-version: 03 Oct 2004

uname -a: Linux XXXX 2.6.8-1-386 #1 Mon Sep 13 23:29:55 EDT 2004 i586 GNU/Linux
(I installed with 2.4.x kernel, then switched to 2.6 after instalation)
Date: 03 Oct 2004
Method: Network install from business card image (the >100MB one).

Machine: Standard, old PC.
Processor: AMD k6-2 500MHz
Memory: 256MB
Root Device: IDE
Root Size/partition table: n
Output of lspci and lspci -n:
   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          36      289138+  83  Linux
/dev/hda2              37        1247     9727357+  8e  Linux LVM

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


1. It only detected one of my network cards, with pcnet32 module.
The second one, smc_ultra (an ISA card) wasn't detected.  After
the installation I had to add smc-ultra to /etc/modules.

2. Installer tried to use DHCP to configure network.  It failed
because I use ADSL/PPPoE.  It was far from obvious that I should
choose "do not configure network at this time" in my case (I was
honestly wondering what should I do).  I guess many people have
PPPoE connections and at least some _hint_ would be nice.

3. After the reboot I had an option to "Use PPP to install system".
I tried to use it, but it only allowed me to use PPP, not PPPoE.
Apparently it was not possible at all to install with PPPoE.

Having the root password already set up I switched to second console
where I found out that pppoe and pppoeconfig are already installed.
Why using them is not an available option during installation?

But the problems were not over yet.  pppoeconfig utility failed
to communicate with "concentrator" and was unable to configure the
connection.  This pretty much dumped me into editing /etc/ppp
files.  Forunatelly I had my notes where to put what to make it work
and in 5 minutes I had my connection up and running.

I would not expect a regular user to do such things simply to
get his PPPoE connection (Actually it's ADSL or DSL from his POV)
to work.

Could PPPeE installation be made somewhat more straightforward?

Thansk guys for terrific installer anyway.  *I* personally do not
complain at all, but a somewhat less experienced user would not
be able to use his Debian at all.  How would he "call" for help w/o
network connectivity? ;-)


				Grzegorz B. Prokopski
Grzegorz B. Prokopski <gadek@debian.org>
Debian http://www.debian.org - The Free Operating System
SableVM - LGPL'ed Free Java Virtual Machine - http://sablevm.org/

Reply to: