[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#271978: marked as done (netcfg: WEP key containing space not set after reboot)

Your message dated Sun, 03 Oct 2004 21:47:05 -0400
with message-id <E1CEHwP-00080z-00@newraff.debian.org>
and subject line Bug#271978: fixed in netcfg 1.03
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 16 Sep 2004 15:46:15 +0000
>From chadmill@gmail.com Thu Sep 16 08:46:15 2004
Return-path: <chadmill@gmail.com>
Received: from rproxy.gmail.com (mproxy.gmail.com) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1C7ySc-00004q-00; Thu, 16 Sep 2004 08:46:14 -0700
Received: by mproxy.gmail.com with SMTP id 73so108153rnl
        for <submit@bugs.debian.org>; Thu, 16 Sep 2004 08:45:27 -0700 (PDT)
Received: by with SMTP id 73mr524718rnk;
        Thu, 16 Sep 2004 08:45:27 -0700 (PDT)
Received: by with HTTP; Thu, 16 Sep 2004 08:45:27 -0700 (PDT)
Message-ID: <233794550409160845793c5448@mail.gmail.com>
Date: Thu, 16 Sep 2004 11:45:27 -0400
From: Chad MILLER <chadmill@gmail.com>
Reply-To: ext@chad.org
To: submit@bugs.debian.org
Subject: netinst, wep key with spaces w/ patch
In-Reply-To: <20040915203222.GA9066@chad.org>
Mime-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit
References: <20040915203222.GA9066@chad.org>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.5 required=4.0 tests=BAYES_10,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: debian-installer

(adding to BTS so it doesn't get dropped.)

I recently installed on a friend's network, which had a WEP key with a
space in it.  The installer worked, but it wrote a
/etc/network/interfaces file that didn't work.  After boot, the key was
set to the substring up to and not including the space in the WEP key.

I _think_ that a backslash before the space solved the problem, but I'm
not certain.

I don't know if there's a more general problem to be solved or whether
the patch below even compiles.  It's a proof of concept patch, more than
anything else.

Nice work, BTW.  The installer is beautiful.

                                                - chad

Pardon the unsigned e-mail -- I was installing because of a disc crash,
and I haven't fully restored yet.

Index: packages/netcfg/dhcp.c
--- packages/netcfg/dhcp.c      (revision 21745)
+++ packages/netcfg/dhcp.c      (working copy)
@@ -52,7 +52,17 @@
               (mode == MANAGED) ? "managed" : "adhoc");
           fprintf(fp, "\twireless-essid %s\n", essid ? essid : "any");
           if (wepkey != NULL)
-            fprintf(fp, "\twireless-key %s\n", wepkey);
+          {
+            int i;
+            fprintf(fp, "\twireless-key ");
+            for (i = 0; wepkey[i] != '\0'; i++)
+            {
+              if (wepkey[i] == ' ' || wepkey[i] == '\\')
+              { /* escape spaces and backslashes for the shell */
+                fprintf(fp, "\\");
+              }
+              fprintf(fp, "%c", wepkey[i]);
+            }
Index: packages/netcfg/static.c
--- packages/netcfg/static.c    (revision 21745)
+++ packages/netcfg/static.c    (working copy)
@@ -267,7 +267,18 @@
          fprintf(fp, "\twireless-essid %s\n", essid ? essid : "any");

          if (wepkey != NULL)
-           fprintf(fp, "\twireless-key %s\n", wepkey);
+         {
+           int i;
+           fprintf(fp, "\twireless-key ");
+           for (i = 0; wepkey[i] != '\0'; i++)
+           {
+             if (wepkey[i] == ' ' || wepkey[i] == '\\')
+             { /* escape spaces and backslashes for the shell */
+               fprintf(fp, "\\");
+             }
+             fprintf(fp, "%c", wepkey[i]);
+           }
+         }
         * Write resolvconf options

Received: (at 271978-close) by bugs.debian.org; 4 Oct 2004 01:53:05 +0000
>From katie@ftp-master.debian.org Sun Oct 03 18:53:05 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CEI2D-0002gV-00; Sun, 03 Oct 2004 18:53:05 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1CEHwP-00080z-00; Sun, 03 Oct 2004 21:47:05 -0400
From: Joshua Kwan <joshk@triplehelix.org>
To: 271978-close@bugs.debian.org
X-Katie: $Revision: 1.51 $
Subject: Bug#271978: fixed in netcfg 1.03
Message-Id: <E1CEHwP-00080z-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Sun, 03 Oct 2004 21:47:05 -0400
Delivered-To: 271978-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Source: netcfg
Source-Version: 1.03

We believe that the bug you reported is fixed in the latest version of
netcfg, which is due to be installed in the Debian FTP archive:

  to pool/main/n/netcfg/netcfg-dhcp_1.03_i386.udeb
  to pool/main/n/netcfg/netcfg-static_1.03_i386.udeb
  to pool/main/n/netcfg/netcfg_1.03.dsc
  to pool/main/n/netcfg/netcfg_1.03.tar.gz
  to pool/main/n/netcfg/netcfg_1.03_i386.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 271978@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joshua Kwan <joshk@triplehelix.org> (supplier of updated netcfg package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun,  3 Oct 2004 17:13:42 -0700
Source: netcfg
Binary: netcfg-static netcfg-dhcp netcfg
Architecture: source i386
Version: 1.03
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joshua Kwan <joshk@triplehelix.org>
 netcfg     - Configure the network (udeb)
 netcfg-dhcp - Configure the network via DHCP (udeb)
 netcfg-static - Configure a static network (udeb)
Closes: 271978
 netcfg (1.03) unstable; urgency=low
   * Joshua Kwan
     - mii-diag support is back, but once again, as a function. Hopefully
       it works better than the old one. This time, it only chooses a
       default interface based on the first connected one it finds. It also
       prefers ethtool to MII.
     - Also add a rudimentary wireless link detection heuristic to go with
       the new ethtool support.
     - Apply Andrew Pollock's WEP key patch. Thanks!
   * Thomas Hood
     - Use "wireless-key1" option in /e/n/i rather than "wireless-key"
       since the former allows the key string to contain whitespace
       whereas the latter does not.  (Closes: #271978)
   * Updated translations:
     - Arabic (ar.po) by Ossama M. Khayat
     - Bulgarian (bg.po) by Ognyan Kulev
     - Catalan (ca.po) by Steve Langasek
     - Czech (cs.po) by Miroslav Kure
     - Danish (da.po) by Claus Hindsgaul
     - German (de.po) by Dennis Stampfer
     - Greek (el.po) by Greek Translation Team
     - Spanish (es.po) by Javier Fernandez-Sanguino Peña
     - Basque (eu.po) by Piarres Beobide Egaña
     - Finnish (fi.po) by Tapio Lehtonen
     - French (fr.po) by French Team
     - Gallegan (gl.po) by Héctor Fenández López
     - Hebrew (he.po) by Lior Kaplan
     - Croatian (hr.po) by Krunoslav Gernhard
     - Indonesian (id.po) by Debian Indonesia Team
     - Italian (it.po) by Giuseppe Sacco
     - Japanese (ja.po) by Kenshi Muto
     - Korean (ko.po) by Changwoo Ryu
     - Lithuanian (lt.po) by KÄ?stutis BiliÅ«nasn
     - Latvian (lv.po) by Aigars Mahinovs
     - Norwegian (nb.po) by Bjorn Steensrud
     - Dutch (nl.po) by Bart Cornelis
     - Norwegian (nn.po) by HÃ¥vard Korsvoll
     - Polish (pl.po) by Bartosz Fenski
     - Portuguese (Brazil) (pt_BR.po) by André Luís Lopes
     - Portuguese (pt.po) by Miguel Figueiredo
     - Romanian (ro.po) by Eddy Petrisor
     - Russian (ru.po) by Russian L10N Team
     - Slovak (sk.po) by Peter KLFMANiK Mann
     - Slovenian (sl.po) by Jure Ä?uhalev
     - Albanian (sq.po) by Elian Myftiu
     - Swedish (sv.po) by Per Olofsson
     - Turkish (tr.po) by Recai OktaÅ?
     - Ukrainian (uk.po) by Eugeniy Meshcheryakov
     - Simplified Chinese (zh_CN.po) by Carlos Z.F. Liu
     - Traditional Chinese (zh_TW.po) by Tetralet
 a3d76a4c677beb2b242222f85e2cc9ac 1561 debian-installer optional netcfg_1.03.dsc
 0172baa602e90036c06041916792024b 186196 debian-installer optional netcfg_1.03.tar.gz
 ddca9b959609bacb20bbdfc0dc2bdd5a 156570 debian-installer optional netcfg_1.03_i386.udeb
 4de2f1a2ae69a10e3bce66696fad302c 122536 debian-installer optional netcfg-dhcp_1.03_i386.udeb
 c1fbf9588f47f646290a1aeab207d2c2 118198 debian-installer optional netcfg-static_1.03_i386.udeb
package-type: udeb

Version: GnuPG v1.2.5 (GNU/Linux)
Comment: http://triplehelix.org/~joshk/pubkey_gpg.asc


Reply to: