[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#265949: marked as done (GRUB /dev/fd0 fails, solved by adding to device.map manually)

Your message dated Sun, 03 Oct 2004 18:47:11 -0400
with message-id <E1CEF8J-0002Zj-00@newraff.debian.org>
and subject line Bug#265949: fixed in grub-installer 1.05
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 15 Aug 2004 21:36:00 +0000
>From ericgies@kabelfoon.nl Sun Aug 15 14:36:00 2004
Return-path: <ericgies@kabelfoon.nl>
Received: from pelian.kabelfoon.nl [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BwSfX-0006XB-00; Sun, 15 Aug 2004 14:36:00 -0700
Received: from desktop (kf-nawij-tg01-0513.dial.kabelfoon.nl [])
	by pelian.kabelfoon.nl (Postfix) with ESMTP id 65ED8319549
	for <submit@bugs.debian.org>; Sun, 15 Aug 2004 23:35:27 +0200 (CEST)
From: Eric <ericgies@kabelfoon.nl>
Reply-To: ericgies@kabelfoon.nl
To: submit@bugs.debian.org
Subject: GRUB /dev/fd0 fails, solved by adding to device.map manually
Date: Sun, 15 Aug 2004 23:37:44 +0200
User-Agent: KMail/1.6.2
MIME-Version: 1.0
Content-Disposition: inline
Content-Type: text/plain;
Content-Transfer-Encoding: 7bit
Message-Id: <200408152337.44390.ericgies@kabelfoon.nl>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports


Debian-installer-version: 42729472 Aug 10 22:37 sarge-i386-businesscard-1.iso
uname -a: Linux desktop 2.4.26-1-k7 #1 Thu Jul 22 13:24:02 JST 2004 i686 GNU/Linux
Date: 15 aug 2004, 20:00
Method: network install, atapi CDROM, mirror debian.essentkabel.com, no proxy.
Machine: bits and pieces
Processor: AMD K7
Memory: 384MB
Root Device: IDE (maxtor) on /dev/hda7
Root Size/partition table:  
Disk /dev/hda: 30.7 GB, 30735581184 bytes
255 heads, 63 sectors/track, 3736 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         153     1228941    b  W95 FAT32
/dev/hda2             154        3736    28780447+   f  W95 Ext'd (LBA)
/dev/hda5   *         154         535     3068383+  83  Linux
/dev/hda6             536         596      489951   82  Linux swap
/dev/hda7             597        1123     4233096   83  Linux
/dev/hda8            1124        1378     2048256    c  W95 FAT32 (LBA)
/dev/hda9            1379        3225    14835996    b  W95 FAT32
/dev/hda10           3226        3378     1228941   1b  Hidden W95 FAT32
/dev/hda11           3379        3736     2875603+  83  Linux
This install uses /dev/hda6 (swap) and /dev/hda7 (root)

Output of lspci:
0000:00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] System Controller (rev 25)
0000:00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] AGP Bridge (rev 01)
0000:00:03.0 Network controller: Cologne Chip Designs GmbH ISDN network controller [HFC-PCI] (rev 02)
0000:00:04.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
0000:00:04.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
0000:00:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 15)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 06)
0000:00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 10)
0000:00:09.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
0000:01:05.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]

Comments/Problems: GRUB fails to install on /dev/fd0 (same for (fd0) notation). 

- Syslog:
Aug 15 21:08:07 grub-installer: info: Installing grub on '/dev/fd0'
Aug 15 21:08:07 grub-installer: info: grub-install supports --no-floppy
Aug 15 21:08:07 grub-installer: info: Running chroot /target /sbin/grub-install --no-floppy "/dev/fd0"
Aug 15 21:08:07 grub-installer: error: Running 'grub-install --no-floppy "/dev/fd0"' failed.
Aug 15 21:08:09 main-menu[294]: WARNING **: Configuring 'grub-installer' failed with error code 1 
Aug 15 21:08:09 main-menu[294]: WARNING **: Menu item 'grub-installer' failed. 

- Executing grub-install from shell (chroot /target /sbin/grub-install /dev/fd0) gave:
/dev/fd0 does not have any corresponding BIOS drive.

- I booted an existing install on hda5 and mounted hda7, but same problem.

- Then changed device.map to include fd0 (workaround?)
  original /boot/grub/device.map:
(hd0)   /dev/hda
  changed /boot/grub/device.map:
(hd0)   /dev/hda
(fd0)   /dev/fd0

- This worked (/dev/hda7 mounted to /dock):
debian:/# chroot /dock /sbin/grub-install /dev/fd0
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(hd0)   /dev/hda
(fd0)   /dev/fd0

- Reboot went fine.

Received: (at 265949-close) by bugs.debian.org; 3 Oct 2004 22:54:23 +0000
>From katie@ftp-master.debian.org Sun Oct 03 15:54:23 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CEFFH-0002A5-00; Sun, 03 Oct 2004 15:54:23 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1CEF8J-0002Zj-00; Sun, 03 Oct 2004 18:47:11 -0400
From: Joey Hess <joeyh@debian.org>
To: 265949-close@bugs.debian.org
X-Katie: $Revision: 1.51 $
Subject: Bug#265949: fixed in grub-installer 1.05
Message-Id: <E1CEF8J-0002Zj-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Sun, 03 Oct 2004 18:47:11 -0400
Delivered-To: 265949-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 4

Source: grub-installer
Source-Version: 1.05

We believe that the bug you reported is fixed in the latest version of
grub-installer, which is due to be installed in the Debian FTP archive:

  to pool/main/g/grub-installer/grub-installer_1.05.dsc
  to pool/main/g/grub-installer/grub-installer_1.05.tar.gz
  to pool/main/g/grub-installer/grub-installer_1.05_i386.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 265949@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated grub-installer package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun,  3 Oct 2004 18:34:50 -0400
Source: grub-installer
Binary: grub-installer
Architecture: source i386
Version: 1.05
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 grub-installer - Install GRUB on a hard disk (udeb)
Closes: 224636 252562 260486 265949
 grub-installer (1.05) unstable; urgency=low
   * Joey Hess
     - Call grub-install with --recheck to ensure that it scans for devices
       anew when, for example, it's run a second time and told to install to a
       floppy this time. Closes: #265949
     - Support device notation for floppy drive, not just grub notation.
       Closes: #224636, #252562, #260486
   * Updated translations:
     - Czech (cs.po) by Miroslav Kure
     - Greek, Modern (1453-) (el.po) by Greek Translation Team
     - Hebrew (he.po) by Lior Kaplan
     - Indonesian (id.po) by Debian Indonesia Team
     - Italian (it.po) by Stefano Melchior
     - Lithuanian (lt.po) by KÄ?stutis BiliÅ«nasn
     - Latvian (lv.po) by Aigars Mahinovs
     - Bøkmal, Norwegian (nb.po) by Bjorn Steensrud
     - Dutch (nl.po) by Bart Cornelis
     - Norwegian Nynorsk (nn.po) by HÃ¥vard Korsvoll
     - Romanian (ro.po) by Eddy Petrisor
     - Russian (ru.po) by Russian L10N Team
     - Slovak (sk.po) by Peter KLFMANiK Mann
     - Slovenian (sl.po) by Jure Ä?uhalev
     - Albanian (sq.po) by Elian Myftiu
     - Traditional Chinese (zh_TW.po) by Tetralet
 fdceb71288184eba6071a68a0dd20a4e 650 debian-installer standard grub-installer_1.05.dsc
 14591ce5b0a257acbbed2136fd6771f3 71638 debian-installer standard grub-installer_1.05.tar.gz
 7a15c7e35d5ef69007f0fcc94bd02854 54042 debian-installer standard grub-installer_1.05_i386.udeb
package-type: udeb

Version: GnuPG v1.2.5 (GNU/Linux)


Reply to: