[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#252562: marked as done (Should allow creating a boot floppy)

Your message dated Sun, 03 Oct 2004 18:47:11 -0400
with message-id <E1CEF8J-0002Zf-00@newraff.debian.org>
and subject line Bug#252562: fixed in grub-installer 1.05
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 4 Jun 2004 03:44:26 +0000
>From dischord@myrealbox.com Thu Jun 03 20:44:26 2004
Return-path: <dischord@myrealbox.com>
Received: from sccrmhc12.comcast.net [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BW5d4-0003eg-00; Thu, 03 Jun 2004 20:44:26 -0700
Received: from chives.local (h0005028e4f3a.ne.client2.attbi.com[])
          by comcast.net (sccrmhc12) with ESMTP
          id <20040604034355012001leofe>; Fri, 4 Jun 2004 03:43:55 +0000
Received: by chives.local (Postfix, from userid 211)
	id 0E4ED2026; Thu,  3 Jun 2004 22:37:48 -0400 (EDT)
Date: Thu, 3 Jun 2004 22:37:48 -0400
From: Jack Carroll <dischord@myrealbox.com>
To: submit@bugs.debian.org
Subject: Multiple SCSI bugs, etc, worked around, succeeded
Message-ID: <20040604023747.GA660@chives.local>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.4i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports

Debian-installer-version: Beta-4 20040528 floppy images
uname -a: Linux (none) 2.4.26-1-386 #2 Sat May 1 16:31:24 EST 2004 i586
Date:     5/30/2004, 5/31/2004
Method:   Network
What did you boot off?  Floppies
If network install, from where?
Proxied?  No
	Machine #1, Compaq Deskpro
	Machine #2, Rackmount server, Tyan S2469 motherboard
	Machine #1, Pentium 133
	Machine #2, single Athlon MP
	Machine #1, 32 MB
	Machine #2, 512 MB
Root Device: 
	Machine #1, SCSI, AHA-1542 ISA non-PNP.  Installed successfully on
	/dev/sda, couldn't install using partitions on both /dev/sda and
	/dev/sdb.  IDE drive /dev/hda present, but not touched.
	Machine #2, SCSI, AIC-7902 PCI.  Installed on /dev/sda.  No other
	hard drives present.
Root Size/partition table:
	Machine #1, / 1.6 GB, /boot 50 MB
	Machine #2, / 8.4 GB, /boot 100 MB, /var 2.1 GB, /home 14.2 GB
Output of lspci:
	Machine #1, no drives connected to PCI devices.

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O/E]
Detect CD:              [ ]
Load installer modules: [O/E]
Detect hard drives:     [O/E]
Partition hard drives:  [O/E]
Create file systems:    [O/E]
Mount partitions:       [O/E]
Install base system:    [O/E]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


	Made several test runs on each machine.

1.  Partman is the weakest link.  It has multiple severe problems dealing
with SCSI drives and host adapters.
   Neither ISA nor PCI SCSI host adapters are detected automatically.  At
the screen where a long list of kernel modules is offered for manual
selection, no SCSI modules are listed.  Supposedly this was corrected, but
it has not been at this time.  Neither help screens nor the installer manual
lists the kernel modules available for loading by hand; I simply had to know
the names of the modules to load from the command line; otherwise I would
have been stopped dead.  This was the worst problem I encountered.
   Once I loaded the proper module from the command line and then called
"Detect hardware" and then the partitioner from the menu, all drives and
existing partitions were listed.
   The partitioner didn't recognize any pre-existing Linux file systems
created by previous Debian distros (Libranet 2.7, 2.8.1).  It only
recognized filesystems it had created itself, including filesystems it
created on previous runs.
   On machine #1, attempting to partition /dev/sdb, create filesystems, and
assign mountpoints caused the partitioner to hang during its attempt to
mount /dev/sdb2.  Attempting to restart it from the menu caused it to abort
repeatedly.  Rebooting into LN 2.7 showed good partitions and filesystems,
and during the next run with debian-installer, fdisk showed good partitions,
and it was possible to mount them by hand.  Continued the install using only

2.  DHCP was erratic.  Sometimes it would get an IP address from the DHCP
server, sometimes manual configuration with a fixed address was necessary. 
This has not been observed with installed kernels.

3.  "Loading Components of Debian Installer" always hung without an error
message and then timed out after about 5 minutes, at anywhere between 40%
and 90%, never on the same package twice.  Retry always ran to completion. 
Changing mirrors, protocols, or target machines had no effect.  Since nobody
else seems to have reported this, it might be something in the installer
interacting with the behavior of the ISP, router, or cable modem.  I'm on
Comcast, in Nashua, N.H., connecting through a Siemens 2614 masquerading
router with internal DHCP server and DNS proxy. Machine #1 connects directly
to the router, Machine #2 was tested both directly and through Machine #1
operating as a masquerading firewall under Libranet 2.7.  No differences
seen in behavior, and download rates are about the same, randomly varying
from about 80 to 400 KB/S.  uchicago and MIT FTP servers seem to be fastest.

4.   Can't create a custom boot floppy.  GRUB could install to /dev/sda OK
on either machine, but trying either (fd0) or /dev/fd0 as a target failed
with a message about it not being a hard disk.  Of course it's not a hard
disk, but GRUB is supposed to be installable on a floppy.  Didn't try
running the grub command directly from the command line.
   Installer doesn't offer to create a conventional kernel-and-initrd boot
disk, either.  This option is necessary, because some systems can't be
booted from GRUB.  Generally, only the first two drives can be booted from
GRUB; /dev/sdc and higher are generally not accessible until a Linux kernel
is running.

Received: (at 252562-close) by bugs.debian.org; 3 Oct 2004 22:54:25 +0000
>From katie@ftp-master.debian.org Sun Oct 03 15:54:25 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CEFFI-0002AU-00; Sun, 03 Oct 2004 15:54:25 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1CEF8J-0002Zf-00; Sun, 03 Oct 2004 18:47:11 -0400
From: Joey Hess <joeyh@debian.org>
To: 252562-close@bugs.debian.org
X-Katie: $Revision: 1.51 $
Subject: Bug#252562: fixed in grub-installer 1.05
Message-Id: <E1CEF8J-0002Zf-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Sun, 03 Oct 2004 18:47:11 -0400
Delivered-To: 252562-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 2

Source: grub-installer
Source-Version: 1.05

We believe that the bug you reported is fixed in the latest version of
grub-installer, which is due to be installed in the Debian FTP archive:

  to pool/main/g/grub-installer/grub-installer_1.05.dsc
  to pool/main/g/grub-installer/grub-installer_1.05.tar.gz
  to pool/main/g/grub-installer/grub-installer_1.05_i386.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 252562@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated grub-installer package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun,  3 Oct 2004 18:34:50 -0400
Source: grub-installer
Binary: grub-installer
Architecture: source i386
Version: 1.05
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 grub-installer - Install GRUB on a hard disk (udeb)
Closes: 224636 252562 260486 265949
 grub-installer (1.05) unstable; urgency=low
   * Joey Hess
     - Call grub-install with --recheck to ensure that it scans for devices
       anew when, for example, it's run a second time and told to install to a
       floppy this time. Closes: #265949
     - Support device notation for floppy drive, not just grub notation.
       Closes: #224636, #252562, #260486
   * Updated translations:
     - Czech (cs.po) by Miroslav Kure
     - Greek, Modern (1453-) (el.po) by Greek Translation Team
     - Hebrew (he.po) by Lior Kaplan
     - Indonesian (id.po) by Debian Indonesia Team
     - Italian (it.po) by Stefano Melchior
     - Lithuanian (lt.po) by KÄ?stutis BiliÅ«nasn
     - Latvian (lv.po) by Aigars Mahinovs
     - Bøkmal, Norwegian (nb.po) by Bjorn Steensrud
     - Dutch (nl.po) by Bart Cornelis
     - Norwegian Nynorsk (nn.po) by HÃ¥vard Korsvoll
     - Romanian (ro.po) by Eddy Petrisor
     - Russian (ru.po) by Russian L10N Team
     - Slovak (sk.po) by Peter KLFMANiK Mann
     - Slovenian (sl.po) by Jure Ä?uhalev
     - Albanian (sq.po) by Elian Myftiu
     - Traditional Chinese (zh_TW.po) by Tetralet
 fdceb71288184eba6071a68a0dd20a4e 650 debian-installer standard grub-installer_1.05.dsc
 14591ce5b0a257acbbed2136fd6771f3 71638 debian-installer standard grub-installer_1.05.tar.gz
 7a15c7e35d5ef69007f0fcc94bd02854 54042 debian-installer standard grub-installer_1.05_i386.udeb
package-type: udeb

Version: GnuPG v1.2.5 (GNU/Linux)


Reply to: