[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#274741: With two ethernets, installer looses which is "primary" across the reboot.

Package: installation-reports


Debian-installer-version: <Fill in date and from where you got the image>

	Index of /pub/cdimage-testing/daily/powerpc/pre-rc2
	 Name                           Last modified       Size  Description
	 Parent Directory               02-Oct-2004 00:08      -
	 MD5SUMS                        01-Oct-2004 00:21     1k
	 sarge-powerpc-businesscard.iso 01-Oct-2004 00:12   112M
>>>	 sarge-powerpc-netinst.iso      01-Oct-2004 00:20   259M
	Apache/1.3.31 Server at cdimage.debian.org Port 80

uname -a: <The result of running uname -a on a shell prompt>

Linux debian 2.6.8-powerpc #1 Tue Sep 14 00:15:52 CEST 2004 ppc GNU/Linux

Date: <Date and time of the install>
	Sun Oct  3 05:34:03 EDT 2004
Method: How did you install? What did you boot off? If network install, from where? Proxied?

PowerPC Oldworld Macintosh with BootX bootloader using 2.6.8 kernel and initrd
	network components from ftp.us.debian.org "testing" repository
	not proxied

Machine: <Description of machine (eg, IBM Thinkpad R32)>

	PowerPC Oldworld Macintosh beige G3 minitower


processor       : 0
cpu             : 740/750
temperature     : 35-37 C (uncalibrated)
clock           : 300MHz
revision        : 2.2 (pvr 0008 0202)
bogomips        : 600.06
machine         : Power Macintosh
motherboard     : AAPL,Gossamer MacRISC
detected as     : 48 (PowerMac G3 (Gossamer))
pmac flags      : 00000000
L2 cache        : 1024K unified pipelined-syncro-burst
memory          : 384MB
pmac-generation : OldWorld


	384 MB

Root Device: <IDE?  SCSI?  Name of device?>

	IDE controller "Ultra ATA 133/100 pro" from SIIG, Inc.
	hdc: Maxtor 6Y160P0, ATA DISK drive

	hw-detect: Detected module 'aec62xx' for 'IDE chipset support'
	hw-detect: Trying to load module 'aec62xx'
	kernel: AEC6880R: IDE controller at PCI slot 0000:00:0e.0
	kernel: AEC6880R: chipset revision 6
	kernel: AEC6880R: ROM enabled at 0x81910000

	kernel: hdg: Maxtor 6Y160P0, ATA DISK drive

Root Size/partition table: Feel free to paste the full partition table, with notes on which partitions are mounted where.

	debian:~# mac-fdisk -l /dev/hdg
# type name length base ( size ) system /dev/hdg1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map /dev/hdg2 Apple_Driver43 Macintosh 54 @ 64 ( 27.0k) Driver 4.3 /dev/hdg3 Apple_Driver43 Macintosh 74 @ 118 ( 37.0k) Driver 4.3 /dev/hdg4 Apple_Driver_IOKit Macintosh 512 @ 192 (256.0k) Unknown /dev/hdg5 Apple_Patches Patch Partition 512 @ 704 (256.0k) Unknown /dev/hdg6 Apple_HFS untitled 2097152 @ 1216 ( 1.0G) HFS /dev/hdg7 Apple_UNIX_SVR2 root 19531251 @ 2098368 ( 9.3G) Linux native /dev/hdg8 Apple_UNIX_SVR2 swap 1953126 @ 21629619 (953.7M) Linux swap /dev/hdg9 Apple_UNIX_SVR2 root 19531251 @ 23582745 ( 9.3G) Linux native /dev/hdg10 Apple_UNIX_SVR2 Root-10 5859376 @ 43113996 ( 2.8G) Linux native /dev/hdg11 Apple_UNIX_SVR2 root-11 5859376 @ 48973372 ( 2.8G) Linux native /dev/hdg12 Apple_UNIX_SVR2 root-12 5859376 @ 54832748 ( 2.8G) Linux native /dev/hdg13 Apple_UNIX_SVR2 root-13 5859376 @ 60692124 ( 2.8G) Linux native /dev/hdg14 Apple_Free Extra 253621556 @ 66551500 (120.9G) Free space
	Block size=512, Number of Blocks=320173056
	DeviceType=0x0, DeviceId=0x0
	1: @ 64 for 23, type=0x1
	2: @ 118 for 36, type=0xffff
	debian:~# mount
	/dev/hdg13 on / type ext3 (rw,errors=remount-ro)
	proc on /proc type proc (rw)
	sysfs on /sys type sysfs (rw)
	devpts on /dev/pts type devpts (rw,gid=5,mode=620)
	tmpfs on /dev/shm type tmpfs (rw)
	usbfs on /proc/bus/usb type usbfs (rw)

	Root on hdc12
	Swap on hdc8
	Other partitions are unused in this installation.

Output of lspci and lspci -n:

	debian:~# lspci
	0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:0d.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10) 0000:00:0e.0 SCSI storage controller: Artop Electronic Corp ATP865 (rev 06) 0000:00:0f.0 PCI bridge: Hint Corp HB6 Universal PCI-PCI bridge (non-transparent mode) (rev 13)
	0000:00:10.0 ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 9a)
	0000:01:08.0 USB Controller: NEC Corporation USB (rev 41)
	0000:01:08.1 USB Controller: NEC Corporation USB (rev 41)
	0000:01:08.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
0000:01:0b.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller (Link)
	debian:~# lspci -n
	0000:00:00.0 0600: 1057:0002 (rev 40)
	0000:00:0d.0 0200: 1186:1300 (rev 10)
	0000:00:0e.0 0100: 1191:0009 (rev 06)
	0000:00:0f.0 0604: 3388:0021 (rev 13)
	0000:00:10.0 ff00: 106b:0010 (rev 01)
	0000:00:12.0 0300: 1002:4754 (rev 9a)
	0000:01:08.0 0c03: 1033:0035 (rev 41)
	0000:01:08.1 0c03: 1033:0035 (rev 41)
	0000:01:08.2 0c03: 1033:00e0 (rev 02)
	0000:01:0b.0 0c00: 104c:8020

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [o]
Configure network HW:   [o]
Config network:         [o] Note 1
Detect CD:              [o]
Load installer modules: [o]
Detect hard drives:     [o]
Partition hard drives:  [o]
Create file systems:    [o]
Mount partitions:       [o]
Install base system:    [o]
Install boot loader:    [ ] Note 2
Reboot:                 [o]
Post-reboot:            [e] Note 1 & 2.


<Description of the install, in prose, and any thoughts, comments and ideas you had during the initial install.>

	Note 1:
	This machine has two ethernet interfaces.
	One is the on-board "bmac" chip (limited to 10 Mbit/sec 10Base-T).
The other is a PCI card from D-Link that uses the 8139too driver (capable of operation at 100Mbit/sec 100Base-TX).
The installer correctly identified both of these interfaces, and correctly asked me which one I wanted to use as "Primary". I chose the D-Link as primary because it's faster.

The DHCP discovery on the "primary" (D-link) interface worked OK -- as expected.

However, after the reboot, it seems to have forgotten which interface was "primary". It attempted to do DHCP discovery on the "bmac" interface. This (of course) failed because there was no network connected to that interface for it to talk to.

After DHCP discovery timed out and the reboot proceeded to a point where I could do so, I edited /etc/network/interfaces and changed "eth0" to "eth1" in two places. it now looks like this:

		debian:~# cat /etc/network/interfaces
		# This file describes the network interfaces available on your system
		# and how to activate them. For more information, see interfaces(5).
		# The loopback network interface
		auto lo
		iface lo inet loopback
		# The primary network interface
		auto eth1
		iface eth1 inet dhcp
	I then rebooted, and everything went as expected from there out.
Suggested fix -- remember the ethernet address of the interface that the user chooses as "primary" before the reboot. Use that to figure out which interface to use after the reboot.

If that proves impossible, then how about simply asking the user again -- after the reboot -- which interface to use as primary. This kind of redundant questioning is mildly annoying, but it's done in several places in the install process, so one more isn't going to hurt.

	Note 2:
	I'm using the BootX bootloader for this test.
I specifically skipped installing the "quik" bootloader in the part of the installation before the reboot.
However, when we got to the the after-reboot part it again tried to install the quik bootloader. I had to answer "No" specifically.

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.

Reply to: