[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#249299: marked as done (Varius problems with grub-installer)

Your message dated Sat, 2 Oct 2004 11:37:57 -0400
with message-id <20041002153757.GA18720@kitenet.net>
and subject line closing
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 16 May 2004 15:35:00 +0000
>From tbm@cyrius.com Sun May 16 08:35:00 2004
Return-path: <tbm@cyrius.com>
Received: from sorrow.cyrius.com [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BPNfI-0001XY-00; Sun, 16 May 2004 08:35:00 -0700
Received: by sorrow.cyrius.com (Postfix, from userid 10)
	id 5EE9464D3B; Sun, 16 May 2004 15:35:00 +0000 (UTC)
Received: by deprecation.cyrius.com (Postfix, from userid 1000)
	id D73501002F; Sun, 16 May 2004 16:34:00 +0100 (BST)
Date: Sun, 16 May 2004 16:34:00 +0100
From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: Varius problems with grub-installer
Message-ID: <20040516153400.GA2580@deprecation.cyrius.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.5.6i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.1 required=4.0 tests=BAYES_44,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: grub-installer

----- Forwarded message from Kevin Goodsell <generic1.20.fusion@neverbox.com> -----

From: Kevin Goodsell <generic1.20.fusion@neverbox.com>
Subject: Sarge install -- complete failure (long)
Date: Sat, 15 May 2004 19:48:04 -0600
To: debian-boot@lists.debian.org
User-Agent: Mozilla Thunderbird 0.5 (Windows/20040207)
X-Accept-Language: en-us, en

Yesterday I attempted (several times) to install Sarge with the beta 4 
installer (single 110 Megabyte CD). This went badly, to say the least. 
Fortunately I was able to recover my Windows installation with some 
work, but I was never able to complete the Debian installation.

There are several factors that may have complicated the situation for 
me, so I will describe them before going into details about what went 
wrong with the actual installation.

First, the system (a home-built PC, Athlon XP) was initially a dual-boot 
Win2k and Mandrake 8 (I think) system. I've never really used the 
Mandrake OS, though. In fact, I never really used this system for 
anything other than games up until recently. So, my intent was to use 
the space that the Mandrake install was using and keep the Windows 
installation intact.

The Windows installation itself is kind of screwy. I had an 
ill-conceived idea of using separate partitions for Windows itself, my 
files, and programs (there may be ways of making this work well, but in 
my case it seems to have been a mistake). In Windows I had the "Files" 
partition mounted as a separate drive and the "Programs" partition 
mounted in the C: file system as C:\Program Files\more.

The partitioning goes like this: 1 primary partition containing Win2k, 1 
extended partition with several logical drives, 2 for the Files and 
Programs partitions (all 3 of these partitions used for Windows are 
NTFS), then 3 for Mandrake. The Master Boot Record was as Windows leaves 
it -- boot loading was done via NTLDR. LILO was (I think) on the 
Mandrake root partition's boot sector.

So, getting to the installation itself. I booted from the CD with no 
problems, and the first steps went fine. At the partitioning step, I 
deleted the last 3 partitions (logical drives containing Mandrake) then 
selected the option to automatically partition the space. I chose the 
option that puts everything except swap on one partition. The result was 
that the swap partition was created as a logical drive in the extended 
partition, and the root was created as a primary partition after the 
extended partition. This was also set as the "active" partition (not 
sure if that's the right terminology). The lightning bolt arrow icon was 
placed on it, instead of the Windows partition. I don't really know what 
this means, but I got the impression it was not what I wanted, so I set 
the Windows partition as active again, then continued.

The GRUB installation is where I started to get concerned again. First 
it failed to detect Windows and said something along the lines of "It 
appears Debian is the only OS on the system. In that case, you should 
install GRUB on the Master Boot Record." According to what I had read, 
this is one option for dual booting, but I wanted to leave the Windows 
stuff as untouched as possible and boot with NTLDR (as I had with the 
Mandrake installation). To do this, I wanted to install GRUB on the boot 
sector of the Debian root partition (if I understand correctly).

So I answered "No" to installing GRUB on the MBR. Next it asked me where 
to install it. I had no idea what to enter. The default was (hd0). I 
reasoned that I /did/ want it on that disk (in a boot sector of a 
partition that I was hoping I could specify later), so I accepted that 
default. And it apparently installed on the MBR, making it impossible to 
boot Windows. I had to use a recovery disk and fdisk /mbr to get back, 
and then things were screwed up. First, Windows said something about 
installing new hardware, then my "Files" and "Programs" partitions 
weren't mounted correctly anymore, and I had to manually restore them. 
After that things seemed OK.

I had no idea what to do at the GRUB installation, so I sought help from 
#debian on irc.debian.org (I was using the nick "ThisGuy" for anyone who 
might have been there and/or wants to check the logs). First I was told 
to try giving it the partition I wanted instead of (hd0), and was told I 
could find out the "name" for that partition by using Ctrl-Alt-F2, then 
"fdisk -l /dev/hda". I re-ran the installation up to the GRUB 
installation portion, and tried this. It didn't report anything back at 
all. I tried examining sizes of partitions with fdisk -s, and I think it 
said that /dev/hda didn't exist (I certainly couldn't see it with 'ls').

So, I tried to guess what the "name" for the partition would be. In the 
partitioning part of the setup, it was labeled as #4, so I figured it 
would be (hd0,3) or /dev/hda3. I think I tried the former. It didn't 
complain, but eventually when I tried to boot Debian (after using 
bootpart as described on this page: 
http://www.aboutdebian.com/dualboot.htm), it failed. I don't remember 
the exact error, but it sounded like there was no boot loader, and it 
froze with some random pattern on the screen.

I returned to #debian to seek more help. This time I got the impression 
from someone there that the GRUB installer would /only/ install on a 
MBR. It was suggested that I should use a console to install GRUB 
manually. After looking at the manual, I didn't feel very good about 
this, but decided to give it a shot anyway. When I reached that phase of 
the installation again, I switched to the console and tried to run grub, 
but it wasn't found. Apparently it wasn't in the path, and I had no idea 
where it might be. At this point I threw in the towel, returned to 
Windows, and ran bootpart to remove the Debian option.

The fact that I was utterly unable to complete the installation (at 
least not without trashing Windows) reflects rather poorly on the 
installer, I think. The fact that GRUB was installed on the MBR after I 
explicitly said that I didn't want it there is even worse. It's also 
pretty bad that the installer didn't notice an existing Windows 
installation, and that the GRUB installation screen is extremely 
unhelpful (a list of options, instead of just the (hd0) default, would 
be nice, as would some explanation of what all that means -- I only have 
a vague understanding).

If anyone can explain what went wrong, and/or what I might do 
differently the next time I try, I'd like to hear it. I can't make 
another attempt right away because that machine is about 100 miles away 
now, but maybe when I return in a few days I'll give it another shot.



To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

----- End forwarded message -----

Martin Michlmayr

Received: (at 249299-done) by bugs.debian.org; 2 Oct 2004 15:42:39 +0000
>From joey@kitenet.net Sat Oct 02 08:42:39 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CDm1v-0005fH-00; Sat, 02 Oct 2004 08:42:39 -0700
Received: from dragon.kitenet.net (unknown [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 14E4D18743
	for <249299-done@bugs.debian.org>; Sat,  2 Oct 2004 15:36:56 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id 261E06E0D4; Sat,  2 Oct 2004 11:37:57 -0400 (EDT)
Date: Sat, 2 Oct 2004 11:37:57 -0400
From: Joey Hess <joeyh@debian.org>
To: 249299-done@bugs.debian.org
Subject: closing
Message-ID: <20041002153757.GA18720@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="VbJkn9YxBvnuCH5J"
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040907i
Delivered-To: 249299-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

I think all the problems referenced in this bug report have been fixed.

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.5 (GNU/Linux)



Reply to: