[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fwd: Grub install fails.

Joey, I partially retract my email response to you.  I
resolved the problem but I still think there's a bug. 
(Luckily, it's been raining here and I've had time to
play with the new installer.)

The first time i tried the installer, i manually
entered "fd0" as the location for grub to be
installed.  This didn't work (no parentheses).  So i
selected 'go back' and entered "/dev/fd0" - this
didn't work either.  I selected 'go back' again and
entered "(fd0)" - which should have worked, but it

The installation screen states that you can install to
the floppy by manually entering either "(fd0)" OR
"/dev/fd0".  So far, neither of these had worked for
me.  As noted in my earlier message, the logs
indicated that grub was being run with the --no-floppy
option.  I see now that was only when using

By watching the logs, i've subsequently noted that
"(fd0)" doesn't cause the --no-floppy option to be
used, whereas using "/dev/fd0" does cause that option
to be used.  (The first part of the bug??)  However,
that didn't explain why "(fd0)", when entered
correctly, didn't work.

I then discovered a bug report that noted that "(fd0) 
/dev/fd0" wasn't being written to
/target/boot/grub/device.map during installation:

That bug report suggested editing the device.map file
to include the fd0 line.  In the process of attempting
to do exactly that, i observed that the fd0 line was
only omitted if anything other than "(fd0)" is entered
for the first time at the grub installation stage. 
Might this be why "(fd0)" entered *subsequently* to
"/dev/fd0" fails?  (The second part of the bug??)

Ie. should the files in the grub directory be
re-written/deleted whenever grub installation fails
and a user selects 'go back'?  (I note that selecting
the 'continue' option also takes the user back to the
main menu.)

In summary, "(fd0)" did work for me but only if it was
the very first thing i entered manually at the grub
install stage.  If i entered anything else such as
"/dev/fd0" or just "fd0" then going back and CORRECTLY
entering "(fd0)" fails.  It seems to me that many
users might incorrectly enter the value here for the
first time.  It also seems that would cause the
correct value to, subsequently, not work.



--- Brian Laflum <blaflum@yahoo.com> wrote:

> Date: Fri, 1 Oct 2004 16:00:51 -0700 (PDT)
> From: Brian Laflum <blaflum@yahoo.com>
> Subject: Re: Fwd: Grub install fails.
> To: Joey Hess <joeyh@debian.org>
> Hi,
> Thanks but that's the problem; that's exactly what i
> did.  That is: I did manually enter fd0, but the
> installer still appears to have used the --no-floppy
> option.  (Which is why I'm wondering whether it's a
> bug.)
> > 
> > Tell it to install to (fd0). It understands that
> > that is a floppy, and
> > will omit the --no-floppy in that case.
> > 
> > -- 
> > see shy jo
> > 
> > ATTACHMENT part 2 application/pgp-signature
> name=signature.asc
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam
> protection around 
> http://mail.yahoo.com 

Do you Yahoo!?
Yahoo! Mail - Helps protect you from nasty viruses.

Reply to: