[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fwd: Grub install fails.

This is a more informative followup to my earlier bug
report.  This message is feedback for the developers
of the new Debian installer.

I tried the new Debian installer again - this time I
monitored /var/log/messages and /var/log/syslog on
consoles 3 and 4.

As noted below, when the installer reaches the stage
of installing grub, I attempted to install it to fd0. 
The installer provides the option of selecting fd0
(among others) as the place to install it to.  (I
prefer to leave my MBR untouched when trying a new
install.)  The installer was unable to install grub to

The relevant output to /var/log/messages was:
Unpacking grub (from
.../grub_0.95+cvs20040624-3_i386.deb) ...
Setting up grub (0.95+cvs20040624-3) ...
Probing devices to guess BIOS drives. This may take a
long time.
/dev/fd0 does not have any corresponding BIOS drive.

My floppy drive is set (in BIOS) to the first boot
device (followed by CDROM and then first HDD).  The
installer also generated the same error messages if my
BIOS drives were set to CDROM->HDD->nil.

The relevant ouput to /var/log/syslog was:
Oct  1 17:53:24 grub-installer: info: Installing grub
on '/dev/fd0'
Oct  1 17:53:24 grub-installer: info: grub-install
supports --no-floppy
Oct  1 17:53:24 grub-installer: info: Running chroot
/target /sbin/grub-install --no-floppy "/dev/fd0"
Oct  1 17:53:26 grub-installer: error: Running
'grub-install --no-floppy "/dev/fd0"' failed.

It appears to me that the installer runs grub with the
'--no-floppy' option (ie. it doesn't probe any floppy
drive).  Is this the cause of the problem?  If so, it
would appear to be a bug, because the installer
purports to allow grub to be installed to fd0.  Is
there any way to override this within the installer?


--- Brian Laflum <blaflum@yahoo.com> wrote:

> Date: Wed, 29 Sep 2004 18:29:01 -0700 (PDT)
> From: Brian Laflum <blaflum@yahoo.com>
> Subject: Grub install fails.
> To: debian-boot@lists.debian.org
> I just tried the netinst CD image from:
> http://www.debian.org/devel/debian-installer/
> When I got to the stage of installing GRUB, I chose
> to
> install on fd0.  It failed, and all I could do was
> go
> back and install it somewhere else.
> I tried:
> (fd0)
> fd0
> "fd0"
> "(fd0)"
> /dev/fd0
> "/dev/fd0"
> None worked.  There is nothing wrong with the
> floppy. 
> Installing the bootloader to the floppy works with
> the
> Woody installer and other distros too.
> <rant> Hopefully this will reach the list (i'm not
> subscribed).  I couldn't be bothered with:
> a) subscribe
> b) confirm subscribe
> c) post message
> d) receive numerous messages that i'm not interested
> in
> e) find unsubscribe instructions
> f) unsubscribe
> g) confirm unsubscribe
> just to post a simple bug report/observation.  There
> must be a better way.
> Thanks
> _______________________________
> Do you Yahoo!?
> Declare Yourself - Register online to vote today!
> http://vote.yahoo.com

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

Reply to: