[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#273986: Quasi-successful Installation - Sarge netinst rc1 on Beige G3

Package: installation-reports


Debian-installer-version: 20040928 Sarge Debian Installer rc1
    From: http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/powerpc/20040928/
uname -a: Linux ppc 2.6.7-powerpc #1 Sat Jul 10 03:47:45 CEST 2004 ppc GNU/Linux
Date: 2004-09-29 1:38am EST
Method: BootX into installer from MacOS 9.0.4; Base system from CD; Final installation from mirrors.kernel.org; no proxy.

Machine: Apple Power Macintosh G3
Processor: 233 MHz G3
Memory: 64 MB
Root Device: Seagate Mesh SCSI /dev/sda

Root Size/partition table:
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda3               915192     54609    811755   7% /
tmpfs                    31016         0     31016   0% /dev/shm
/dev/hda9              3588204     32872   3373060   1% /home
/dev/sda7                27968      1043     25433   4% /tmp
/dev/sda5              3748768    191724   3366616   6% /usr
/dev/sda6              1830418      8239   1724523   1% /usr/src
/dev/sda4              1830418     47546   1685216   3% /var
/dev/hda8               511984    326976    185008  64% /mac

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:10.0 ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 9a)

0000:00:00.0 0600: 1057:0002 (rev 40)
0000:00:10.0 ff00: 106b:0010 (rev 01)
0000:00:12.0 0300: 1002:4754 (rev 9a)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]

Comments/Problems: (verbosity reflects pain of prior, desperate search)
ERRORS SUMMARY (Detailed below)

Initial boot worked:    [E]
The OldWorld Macs do not boot off the CD without major headache.

Detect hard drives:     [E]
Mesh scsi module was available but not loaded to detect SCSI (fix is uploaded, AFAIK).

Install boot loader:    [E]
Quik is either broken, malconfigured, or the wrong tool for this box. It installed and ran, but I haven't gotten it to work. Some scripting/help should be included to guide us dual-booties to copy the new kernel and initrd to the MacOS partition.


Note - I had an NFS export ready, but got no option to use it :(
  NFS mount should be available on a netinst disk, I think.

Step by step:

In MacOS 9.0.4
- Downloaded BootX-1.2.2 from penguinppc.org
- Unstuffed .sit archive
- Placed BootXApp in System Folder/Control Panels
- Placed BootX extension in System Folder/Extensions
- Created new folder in System Folder called Linux Kernels
- Ran BootX 1.2.2/Utilities/GrabG3CacheSettings
- Opened Debian Sarge rc1 netinst iso CD
- Put cd:/install/powerpc/initrd.gz into System Folder
- Put cd:/install/powerpc/vmlinux into System Folder/Linux Kernels
- Ran BootXApp from AppleMenu/Control Panels
- Selected Options -> Use specific RAM Disk -> Choose...
- Browsed to System Folder to select initrd.gz
- Selected Set G3 cache -> "OK"
- Selected save preferences
- Selected Linux

Observed frame buffer penguin and scrolling boot messages.

mem_pieces_remove: [2eb000,77c000) not in any region
Total memory = 64MB; using 128kB for hash table (at c0780000)
Linux version 2.6.7-powerpc (jens@yorick) (gcc version 3.3.4 (Debian 1:3.3.4-3)) #1 Sat Jul 10 03:47:45 CEST 2004
Found a Heathrow mac-io controller, rev: 1, mapped at 0xfddff000
PowerMac motherboard: PowerMac G3 (Gossamer)
Found Grackle (MPC106) PCI host bridge at 0x80000000. Firmware bus number: 0->0
L2CR overriden (0xa9100000), backside cache is enabled
nvram: OF partition at 0x1800
nvram: XP partition at 0x1300
nvram: NR partition at 0x1400
On node 0 totalpages: 16384
  DMA zone: 16384 pages, LIFO batch:4
  Normal zone: 0 pages, LIFO batch:1
  HighMem zone: 0 pages, LIFO batch:1
Built 1 zonelists
Kernel command line: ramdisk_size=8192
System has 64 possible interrupts
PID hash table entries: 512 (order 9: 4096 bytes)
GMT Delta read from XPRAM: -240 minutes, DST: on
via_calibrate_decr: ticks per jiffy = 16708 (1002497 ticks)
Console: colour dummy device 80x25
serial8250_console_init: nothing to do on PowerMac
Memory: 57072k available (1656k kernel code, 1188k data, 160k init, 0k highmem)
Calibrating delay loop... 465.92 BogoMIPS
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
checking if image is initramfs...it isn't (ungzip failed); looks like an initrd
Freeing initrd memory: 4676k freed
NET: Registered protocol family 16
PCI: Probing PCI hardware
PCI: Cannot allocate resource region 2 of device 0000:00:12.0
Registering pmac pic with sysfs...
atyfb: 3D RAGE (GT) [0x4754 rev 0x9a] 2M SGRAM, 14.31818 MHz XTAL, 200 MHz PLL, 67 Mhz MCLK
atyfb: monitor sense=717, mode 12
fb0: ATY Mach64 frame buffer device on PCI
MacOS display is /pci/ATY,mach64_3DU
Thermal assist unit using timers, shrink_timer: 2000 jiffies
audit: initializing netlink socket (disabled)
audit(1096435444.197:0): initialized
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
Console: switching to colour frame buffer device 80x30
Generic RTC Driver v1.07
Macintosh non-volatile memory driver v1.1
serial8250_init: nothing to do on PowerMac
pmac_zilog: 0.6 (Benjamin Herrenschmidt <benh@kernel.crashing.org>)
ttyS0 at MMIO 0xf3013020 (irq = 15) is a Z85c30 ESCC - Serial port
ttyS1 at MMIO 0xf3013000 (irq = 16) is a Z85c30 ESCC - Serial port
fd0: SWIM3 floppy controller 
Using anticipatory io scheduler
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
divert: not allocating divert_blk for non-ethernet device lo
MacIO PCI driver attached to Heathrow chipset
input: Macintosh mouse button emulation
Macintosh CUDA driver v0.5 for Unified ADB.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
adb: starting probe task...
adb devices: [2]: 2 2 [3]: 3 1
ADB keyboard at 2, handler 1
Detected ADB keyboard, type ANSI.
input: ADB keyboard on adb2:2.02/input
ADB mouse at 3, handler set to 2
input: ADB mouse on adb3:3.01/input
adb: finished probe task...
ide0: Found Apple Heathrow ATA controller, bus ID 0, irq 13
Probing IDE interface ide0...
hda: MDMA, cycleTime: 120, accessTime: 75, recTime: 45
hda: Set MDMA timing for mode 2, reg: 0x00211526
hda: Enabling MultiWord DMA 2
ide0 at 0xc5862000-0xc5862007,0xc5862160 on irq 13
ide1: Found Apple Heathrow ATA controller, bus ID 1, irq 14
Probing IDE interface ide1...
Unhandled interrupt e, disabled
hdc: MDMA, cycleTime: 150, accessTime: 75, recTime: 75
hdc: Set MDMA timing for mode 1, reg: 0x00221526
hdc: Enabling MultiWord DMA 1
ide1 at 0xc5867000-0xc5867007,0xc5867160 on irq 14
mice: PS/2 mouse device common for all mice
NET: Registered protocol family 2
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 4096 bind 8192)
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 4676 blocks [1 disk] into ram disk... |/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|done.
VFS: Mounted root (cramfs filesystem) readonly.
Freeing unused kernel memory: 160k init 4k chrp 32k prep
NET: Registered protocol family 1
SCSI subsystem initialized
mesh: configured for synchronous 5 MB/s
mesh: performing initial bus reset...
scsi0 : MESH
mesh: target 0 synchronous at 5.0 MB/s
  Vendor: SEAGATE   Model: ST39216N          Rev: 0010
  Type:   Direct-Access                      ANSI SCSI revision: 03
SCSI device sda: 17942584 512-byte hdwr sectors (9187 MB)
SCSI device sda: drive cache: write back
 /dev/scsi/host0/bus0/target0/lun0: [mac] p1 p2 p3 p4 p5 p6 p7
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Adding 249992k swap on /dev/sda2.  Priority:-1 extents:1
divert: allocating divert_blk for eth0
eth0: BMAC at 00:05:02:de:08:33
hdc: ATAPI 24X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20
hda: max request size: 128KiB
hda: 8418816 sectors (4310 MB) w/80KiB Cache, CHS=14848/9/63, (U)DMA
 /dev/ide/host0/bus0/target0/lun0: [mac] p1 p2 p3 p4 p5 p6 p7 p8 p9
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda9, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda7, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda4, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
ts: Compaq touchscreen protocol output
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd: block sizes: ed 64 td 64
USB Universal Host Controller Interface driver v2.2
phy registers:
 0000 0000 0000 0000 0000 0000 0000 0000
 0000 0000 0000 0000 0000 0000 0000 0000
 0000 0000 0000 0000 0000 0000 0000 0000
 0000 0000 0000 0000 0000 0000 0000 0000
cdrom: open failed.
NET: Registered protocol family 5

- Made language selections

Observed Partioner startup.

- Pressed <OPTION><RIGHT-CURSOR-ARROW> then <RETURN> to enter console.
- Entered "modprobe mesh" at command prompt
- Pressed <OPTION><LEFT-CURSOR-ARROW> to continue installer
- Tabbed to "Back" then chose to "Choose next step"
- Chose "Detect Hardware" then "Continue"
- Chose to not start PCMCIA services

Observed Partioner return with SCSI disk available

- Partioned SCSI (installation) disk
Partition notes:
  As I was playing around in the partitioner, I decided to delete the 
32.2K partion #1 on the scsi drive called Apple. After the partitions 
were displayed once again on the screen, I noticed a 32.2K hole on the 
IDE Master disk at partition #1! It's a new dance I'm learning called 
the Mac Twist. I'm not experienced with the OF, but maybe that's really 
a space on the /AAPL/ROM??
  Also, I fooled around and selected the entire scsi disk and followed 
the installer to delete all the partions. Guess what didn't go away! 
That 32.2K _'taint_meat_ pinch!

Observed installation of Debian Base System from CD.

At main menu...

- Pressed <OPTION><RIGHT-CURSOR-ARROW> then <RETURN> to enter console.
- Entered "chroot /target /bin/bash" at command prompt
- Entered "mkdir /mac"
- Entered "modprobe hfs"
- Entered "mount /dev/hda8 /mac"
- Entered "cp /boot/vmlinux-2.6.7-powerpc /mac/System\ Folder/Linux\ 
- Entered "cp /boot/initrd.img--2.6.7-powerpc /mac/System\ Folder/"
- Pressed <OPTION><LEFT-CURSOR-ARROW> to return to installer
- Selected Finish Installation

Machine booted into MacOS.

- Ran BootX App from Control Panels
- Selected vmlinux-2.6.7-powerpc in kernel selector
- Chose Options -> Choose 
- Browsed to initrd.img-2.6.7-powerpc in System Folder the OK
- Selected Save to prefs then Linux

Machine booted into Sarge.

- Followed dialog to enter various setup preferences.
- Chose http for apt configuration then a mirror
- Chose to use Debian security updates
- Finished installation

Thanks Rick and Sven!
Duane Cottle

Reply to: