[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#271890: Installation process on Sarge 20040801

Package: installation-reports

There is a possibility this bug report has gone its way in the BTS, but
there is a much more high probability it has been forwarded to Dave Null
because the first time I have sent it, I have forgotten the "Package:"
line (just because I didn't know what package it was all about).

So here is the bug report, it all about Sarge official snapshot 20040801.

In the first days of August, using the ADSL connection of my father I
have downloaded the 7 first CD of Sarge 20040801 (becoming Sarge
20040808 for the last 2 CDs). 
Back to my house with a new Centino NoteBook, I tried to install the
Sarge on it.
* 1) The ACPI problem:
The only way to boot the first CD was to enter "expert26 acpi=off' boot
option. There is no problem with that, the first part of the
installation ran OK (except the point with partman: see below). 
But at the end of the first part of the installation procedure, there is
no way to edit the /etc/lilo.conf. (I tried but the "boot=/dev/hda" line
was rejected for unknow reasons).
And the "acpi=off" option is not added to this file... :/ 
So the reboot crashed...
I turned the problem around by booting with the first CD of the Woody in
rescue mode, corrected the /etc/lilo.conf and ran /sbin/lilo.

So, please add to the bootloader configuration files the options the
user passed to boot on the first CD.

It seems as an evidence that if the user (luser, lurker) passed the
"acpi=off" option when booting the first CD, this option as to be added
to the /etc/lilo.conf file (forget about grub... I'm too old :)
* 2) The partman problem
During the first process install you are prompted to make partitions on
your disk(s). The only problem (but it is a big one) is that it is
nowhere said that you should press the "F12" key to edit the fields you
can see.
I wanted to make a 4 GB partition for Windows as hda1 (for an eventually
future install), then a /dev/hda2 (1GB) for Linux swap and /dev/hda3 (6
GB) for OpenBSD and hda4 extented and full of hda5 to hda14 partitions
for my new Linux/Debian/Sarge OS.
The problem is that you have to strike the "F12" to modify the fields of
partman, but it is not said anywhere. I found this out by striking all
the keys of the keyboard in a «aléatoire» way which is not a good idea
in a partition program !
(Sorry I don't know how to translate «aléatoire», it means I stroke
all keys on the keyboard and finally (finlandly ? (it's ajoke: have a
smile)) found out "F12" makes something).
Off course I opened the shell that is proposed in the install menu...
The problem is that it is said the HDD partitions are mounted on /target
but there is no /target directory.
But even if there would have been a /target directory, it would have
been helpless because the lilo program was not present in the /sbin
directory (where there a /sbin directory ? I can not remember).
Here are my suggestions:
Always include in /etc/lilo.conf (or in grup machin/bidule (I don't know
anything about grub)) the boot options the user passed to boot on the
first CD.
Please had an help-screen in partman so the user knows about this
f*****g "F12" key to edit the fields.
The shell you provide with the first-part installation processe is too
minimal (and no /target at the horizon).
Hugues Fertin (aka Hugolino (aka "I_likeparenthesis_don't_I_?))

PS: Did I enter the famous B.T.S ? Please let me now ! What thing can I
win ? A Tux muppet ? A "Designed for SargePack 2" sticker to replace
that ugly thing near the keyboard of my notebook ?

Hugo NPN    (i --> ee)
> ...tentatives de connexion de sa part, diminue au final le download.
 ... c'est extrait du "Naibed Internals" ??
                                    -+- Naibed on fsf -+-

Reply to: