[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#269728: Installation report - RAID1 on / (without extra /boot)

Package: installation-reports


Debian-installer-version: sarge-di 31/08/2004
uname -a: Linux legolas.iuw.uni-vechta.de 2.6.8third #1 Thu Sep 2 09:04:21 CEST 2004 i686 GNU/Linux
	  Installation kernel was debian 2.6.7 - afterwards upgrade to a custom kernel
	  build from debian kernel-source-2.6.8-5 (unstable)
Date: 01/09/2004 - 16:00
Method: Netinstall CD - Sarge-DI 31/08/2004

Machine: Custom Server
Processor: Athlon XP 3000+
Memory: 1 GB DDR
Root Device: SATA 160 GB Maxtor
Root Size/partition table:

Server with two 250 GB Maxtor ATA Harddisks Maxtor 7Y250P0 (dev/hda + hdb)
and two 160 GB Maxtor SATA Harddisks Maxtor 6Y160M0 (dev/sda + sdb)

Installation with / (no extra /boot) on a RAID1
on the two SATA Harddisks

The two ATA Harddisks are used as backup media.

Output of lspci and lspci -n:

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge (rev 80)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
0000:00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
0000:00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
0000:00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
0000:00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800 South]
0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]

lspci -n:
0000:00:00.0 0600: 1106:3189 (rev 80)
0000:00:01.0 0604: 1106:b198
0000:00:0f.0 0104: 1106:3149 (rev 80)
0000:00:0f.1 0101: 1106:0571 (rev 06)
0000:00:10.0 0c03: 1106:3038 (rev 81)
0000:00:10.1 0c03: 1106:3038 (rev 81)
0000:00:10.2 0c03: 1106:3038 (rev 81)
0000:00:10.3 0c03: 1106:3038 (rev 81)
0000:00:10.4 0c03: 1106:3104 (rev 86)
0000:00:11.0 0601: 1106:3227
0000:00:12.0 0200: 1106:3065 (rev 78)
0000:01:00.0 0300: 1002:5159

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E/O]
Reboot:                 [E]


Installation with expert26.
Partitioned and RAID 1 build with partman/mdcfg.

/dev/sdb1  - RAID 1 with ext3 - mounted /

/dev/sdb2  - RAID 1 as SWAP

Installation almost perfect. Detecting harddrives, Sata controller,
ethernet etc. all worked. Partitioning and Raid setup worked. Proceeded
although the Warning - Root/Boot an RAID not supported.

First tried to install lilo as boot loader - Doesn't worked at all.
Second tried to install grub as boot loader - Worked.

Reboot doesn't worked automatically. After changing the root (see below)
from (hd0,0) to (hd2,0) or (hd3,0) booting from the Raid 1 worked without
any problems. The problem is only the two ATA Harddisks so the grub installation
doesn't realized that the SATA Harddisks are 2 and 3.

title           Debian GNU/Linux, kernel 2.6.7-1-k7
root            (hd2,0)
kernel          /boot/vmlinuz-2.6.7-1-k7 root=/dev/md0 vga=791 ro
initrd          /boot/initrd.img-2.6.7-1-k7

Well - except the change of the root device in grub menu.lst everything worked
fine. As I tried to install lilo first as the boot loader there was no concrete
failure messages.

All in all - perfect. I think the warning / or /boot on RAID is not
supported could be deleted - maybe adding a note for changing the root device
in the grub menu depending if the disks are the firsts in the bios or not.
The grub boot problem wouldn't have shown up if I had done
the RAID on the two ATA Disks as there hd0,0 would have worked.

If you need any further informations plese contact me.

Thanks for your very good job. It was a pleasure to install !



Reply to: