[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#265520: [i386][rc1][floppy,netinst] aic7xxx crash, partition table CHS damage

Package: installation-reports


Debian-installer-version: RC1 (20040801) from
uname -a: Linux guitar 2.4.26-1-586tsc #1 Thu Jul 22 12:53:42 JST 2004 i586
Date: 2004-08-12 16:00 CEST
- How did you install?
- What did you boot off?
    2 floppies (boot,root), no additional driver disks
- If network install, from where?
- Proxied?
    yes, squid proxy, no authentication needed

Machine: custom-built PC
Processor: Pentium 100
Memory: 64MB
Root Device: /dev/hda5
Root Size/partition table:
Disk /dev/hda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          65      516064+   6  FAT16
Partition 1 does not end on cylinder boundary.
/dev/hda2              65       19458   155774777    f  W95 Ext'd (LBA)
/dev/hda5              65         130      524632+  83  Linux
/dev/hda6             130         130         472+   6  FAT16
/dev/hda7             130         391     2097112+   6  FAT16
/dev/hda8             391         652     2097112+   7  HPFS/NTFS
/dev/hda9             652        4096    27660496+  8e  Linux LVM
/dev/hda10           4096        4112      131008+  82  Linux swap
/dev/hda11           4112        8311    33729664+  8e  Linux LVM
/dev/hda12           8311       12511    33730168+  8e  Linux LVM
/dev/hda13          12511       16710    33730168+  8e  Linux LVM
/dev/hda14          16710       19458    22073656+  8e  Linux LVM
Oops, the installer changed the CHS geometry! :-(
It used to be 16 heads/63 sectors, now it is 255 heads/63 sectors.
I already wondered during installation why the installer wanted to write
to the partition table at all, since I hadn't changed any of the
This problem was also reported to occur in Fedora Core 2:
The sfdisk fix mentioned there didn't work for me, however.
I fixed it (hopefully without data loss) by removing all partitions,
changing the number of heads, and then re-creating every partition with
exactly the same size and type as before. Fortunately, I had kept a copy
of the original "fdisk -l" output, as before the installation.
This is the partition table as intended:
Disk /dev/hda: 160.0 GB, 160041885696 bytes
16 heads, 63 sectors/track, 310101 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System     mount point
/dev/hda1   *           1        1024      516064+   6  FAT16      /mnt/dos
/dev/hda2            1025      310101   155774808    f  W95 Ext'd (LBA)
/dev/hda5            1025        2065      524632+  83  Linux      /
/dev/hda6            2066        2066         472+   6  FAT16      /mnt/spacer
/dev/hda7            2067        6227     2097112+   6  FAT16      /mnt/win98
/dev/hda8            6228       10388     2097112+   7  HPFS/NTFS  /mnt/nt
/dev/hda9           10389       65270    27660496+  8e  Linux LVM
/dev/hda10          65271       65530      131008+  82  Linux swap
/dev/hda11          65531      132454    33729664+  8e  Linux LVM
/dev/hda12         132455      199379    33730168+  8e  Linux LVM
/dev/hda13         199380      266304    33730168+  8e  Linux LVM
/dev/hda14         266305      310101    22073656+  8e  Linux LVM
logical volumes:

  LV                    VG   Attr   LSize      mount point
  lv_afscache           vg0  -wn-ao 224.00M    /var/cache/openafs
  lv_home               vg0  -wn-ao  20.53G    /home
  lv_mirror             vg0  -wn-ao  20.00G    /mnt/mirror
  lv_rescue             vg0  -rn-ao  59.38G    /mnt/rescue
  lv_restore_2003-12-22 vg0  -rn-a-   1.09G    /mnt/restore_2003-12-22
  lv_tmp                vg0  -wn-ao 256.00M    /tmp
  lv_usr                vg0  -wn-ao   6.00G    /usr
  lv_usr_local          vg0  -wn-ao 512.00M    /usr/local
  lv_usr_src            vg0  -wn-ao   1.00G    /usr/src
  lv_var                vg0  -wn-ao   1.00G    /var

Output of lspci and lspci -n:
# lspci
0000:00:00.0 Host bridge: Intel Corp. 430FX - 82437FX TSC [Triton I] (rev 02)
0000:00:07.0 ISA bridge: Intel Corp. 82371FB PIIX ISA [Triton I] (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371FB PIIX IDE [Triton I] (rev 02)
0000:00:09.0 Ethernet controller: Digital Equipment Corporation DECchip 21140
[FasterNet] (rev 22)
0000:00:0a.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W
[Millennium II]
0000:00:0b.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev
0000:00:0b.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev
0000:00:0c.0 SCSI storage controller: Adaptec AHA-2940U/UW/D / AIC-7881U

# lspci -n
0000:00:00.0 0600: 8086:122d (rev 02)
0000:00:07.0 0601: 8086:122e (rev 02)
0000:00:07.1 0101: 8086:1230 (rev 02)
0000:00:09.0 0200: 1011:0009 (rev 22)
0000:00:0a.0 0300: 102b:051b
0000:00:0b.0 0401: 1102:0002 (rev 04)
0000:00:0b.1 0980: 1102:7002 (rev 01)
0000:00:0c.0 0100: 9004:8178

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [E]
Mount partitions:       [E]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]

Initial boot, aic7xxx:
  - several SCSI resets during device discovery, finally hung the machine
    (not even console switching worked anymore), this was reproducible
  - retried with all SCSI devices' power unplugged -> success
  - once the install was finished, I shut down to re-plug the SCSI CDRW
    drive, which works fine as always

network HW:
  - installer used tulip.o -> no ethernet link
  - needed to unplug and re-plug network cable after the interface is "up",
    this restarts autonegotiation and establishes the ethernet link
  - installer should have used de4x5.o instead (for this particular
    ethernet card)
  - I couldn't find an rmmod command on the installer shell
    for removing the unwanted module tulip.o

partition hard drives:
  CHS geometry changed, although I didn't want to repartition at all
  see above under Root Size/partition table

I prepared the harddisk in another machine (partitions, logical volumes)
and then told the installer where to mount these.
Result: some partitions already containing FAT 16 filesystems and
        the read-only LVs were rejected as containing errors, although
        fsck.msdos or fsck.ext2 now say they are OK.
        Creating a FAT 16 filesystem also failed on one of the partions:
        /dev/hda6, if I remember correctly.
my workaround: leave them unused during installation,
               edit /etc/fstab afterwards.

additional system information:

# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: SONY     Model: CD-RW  CRX140S   Rev: 1.0e
  Type:   CD-ROM                           ANSI SCSI revision: 04

# further hardware (not discovered automatically)
- ISA Soundcard, modprobe ad1816
isapnp: Scanning for PnP cards...
isapnp: Card 'Analog Devices AD1815'
isapnp: 1 Plug & Play card detected total
ad1816: Analog Devices AD1815 detected
ad1816: ISAPnP reports 'Analog Devices AD1815' at i/o 0x100, irq 5, dma 1, 3
ad1816: AD1816 sounddriver Copyright (C) 1998 by Thorsten Knabe
ad1816: io=0x100, irq=5, dma=1, dma2=3, clockfreq=33000, options=0 isadmabug=0
- ISA Ethernet card, modprobe ne.o io=0x300
ne.c:v1.10 9/23/94 Donald Becker (becker@scyld.com)
Last modified Nov 1, 2000 by Paul Gortmaker
NE*000 ethercard probe at 0x300: 00 80 ad 17 11 b8
eth1: NE2000 found at 0x300, using IRQ 10.

# cat /proc/interrupts
  0:    5889055          XT-PIC  timer
  1:      11178          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  4:       1557          XT-PIC  serial
  5:          0          XT-PIC  SoundPort
  8:          6          XT-PIC  rtc
  9:       1327          XT-PIC  aic7xxx, EMU10K1, eth0
 10:          1          XT-PIC  NE2000
 14:      43256          XT-PIC  ide0
NMI:          0
LOC:          0
ERR:          0
MIS:          0

additional notes:
read-edid and mdetect were automatically installed, but when running
aptitude for the first time, they were atomatically removed again.

The partitioner showed only the physical partitions, not the logical
volumes. That was, until I discovered that I needed to scroll down. :-)

I find the display of logical volumes confusing. There are two
selectable lines for each LV, only the second of which is suitable for
defining the mount point - the first will give a strange error like
"this is a whole disk". Maybe the first line should be made
non-selectable if it doesn't have any other than informational purpose.

The partitioning interface feels slow.
But maybe this wasn't written for a 100MHz machine.

I couldn't find a way to use a local mirror for the first part of a
network installation.  But since I had fast Internet connection,
I didn't look further and used one of the mirrors offered.

Not really installer related:
The debconf dialog of ca-certificates is wider than the 80-column
screen, but this is rather cosmetic, since mainly the frame is off-screen.

Thanks for reading this far.

Reply to: