[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#264367: Sarge BETA4 Installation Report

Package: installation-reports


 2004-05-05 BETA4 of sarge-i386-netinst.iso (109MB) from

uname -a:
Linux mirage 2.4.25-1-386 #2 Wed Apr 14 19:38:08 EST 2004 i686 GNU/Linux

Date: 2004-08-02 and 2004-08-03. See:

  How did you install?        from floppy ---> CDROM ---> dial-up modem
  What did you boot off?           floppy (see below)
  If network install, from where?  ftp.uk.debian.org
  Proxied?                         No

Machine: AOpen AX6BC motherboard

Processor: Pentium III 450MHz

Memory: 512MB

Root Device: Samsung Spinpoint P80 80GB IDE drive SP0812N
(limited by motherboard to 33GB running at ATA33 :-()

Root Size/partition table:

# sfdisk -l /dev/hda
Disk /dev/hda: 4111 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0
   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1   *      0+      2       3-     24066   83  Linux
/dev/hda2          3      95      93     747022+  82  Linux swap
/dev/hda3         96    4110    4015   32250487+   5  Extended
/dev/hda4          0       -       0          0    0  Empty
/dev/hda5         96+   4110    4015-  32250456   83  Linux

$ cat /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /boot           ext2    defaults        0       2
/dev/hda2       none            swap    sw              0       0
/dev/hda5       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdc        /media/cdrom    iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy   auto    rw,user,noauto  0       0
/dev/hdc        /cdrom          iso9660 ro,user,noauto  0       0

Output of lspci:
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:0a.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
0000:00:0d.0 Multimedia audio controller: Yamaha Corporation YMF-724F [DS-1 Audio Controller] (rev 03)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC AGP (rev 7a)

Output of lspci -n:
0000:00:00.0 0600: 8086:7190 (rev 03)
0000:00:01.0 0604: 8086:7191 (rev 03)
0000:00:07.0 0601: 8086:7110 (rev 02)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 02)
0000:00:0a.0 0200: 10b7:9055 (rev 30)
0000:00:0d.0 0401: 1073:000d (rev 03)
0000:01:00.0 0300: 1002:475a (rev 7a)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


The main problem was that the CDROM .iso image would not boot on any of
my three computers (AOpen AX6BC motherboard), giving the error:

ISOLINUX 2.04 2003-04-16
isolinux: Disk error 01, AX = 42 BA, 9F

I tried the CDROM on Mama's newer Duron 800MHz system, and it booted fine
(I resisted the temptation to install Sarge over her Windoze partition ;-)

Googling found some other mention of this error, and talk of floppy emulation:

My old Woody CD set all booted fine. (Why is there a difference?)
So I made some boot floppies from the CD, and these worked.

Once the process was started, it went like a dream.
I am amazed how simple it all was - my hat goes off to you guys,
getting something this complex to all work like clockwork!

I messed up the network config by typing in the wrong Gateway address.This
stalled the whole apt-get process, as I couldn't get online via my modem.
Then I was caught in loops for a while trying to go back and
'Enter The Hostname' in the hope it would let me reconfigure the network
options, but each time I could only enter the hostname; the other details
were assumed to be previously set. Asking friends yielded a few clues, and
I started searching around in my old Woody installation /etc backup files
to try and fathom out which file stores the IP numbers. Eventually I found
/etc/network/interfaces (what could be simpler :-) and set it right.
Still not getting online, I realised I had to manually type 'pon' to get
the modem to dial out. Rebooting the install process finally got me
connected to ftp.uk.debian.org and the rest was blissful...

mutt, fetchmail, lynx, less, ftp, xterm,
x-window-system, icewm, mozilla-firefox, gimp1.2, abiword, ...

Many many thanks!


Install logs and other status info is available in /var/log/debian-installer/.
*** Do you really want me to send any of these HUGE files? ***

Once you have filled out this report, mail it to submit@bugs.debian.org.

Malcolm Smith

Reply to: