[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#264135: installation-reports: scsi devices detected in wrong order

Package: installation-reports

Debian-installer-version: 20040806 - http://people.debian.org/~joeyh/d-i/images/daily/hd-media/
uname -a: Linux  2.4.26-1-386 #2 Sat May 1 16:31:24 EST 2004 i686 unknown
Date: 20040807 03:30 IST
Method: Floppy + USB keychain. Businesscard ISO. network (ftp.ie.debian.org)

Machine: Dell PowerEgde 1650, Perc 3/DC (Adaptec based hardware raid)
Processor: Dual P3 1266 MHz
Memory: 2GB
Root Device: sdb1 during install, sda1 on reboot after install
Root Size/partition table: 72 GB (hardware raid 1), XFS
Output of lspci:

Base System Installation Checklist:

Initial boot worked:    [X]
Configure network HW:   [X]
Config network:         [X]
Detect CD:              [X]
Load installer modules: [X]
Detect hard drives:     [X]
Partition hard drives:  [X]
Create file systems:    [X]
Mount partitions:       [X]
Install base system:    [X]
Install boot loader:    [X]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


The problem is the order in the SCSI chain. The USB key is the first SCSI device during boot, but not on reboot, which is a problem.
After the reboot swap and root partitions are in different places due to USB keychain detected after raid-controller, also at some point
the usb key will be removed. Another problem was, that the aix7xxx driver was tried to load several times (because the raid controller is
such a controller, if it not is raid enabled.) That failed, as it is supposed to, every time. The controller uses the aacraid module, once
raid enabled.

I'm going to try to install from floppies instead now. 

Reply to: