[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#240760: marked as done ([arm] [20040328] [netboot] successful report on Rebel Netwinder)

Your message dated Mon, 26 Jul 2004 23:54:05 +0200
with message-id <200407262354.10432.frederik@dannemare.net>
and subject line Processed: Bug#240760: successful report on Rebel Netwinder
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 29 Mar 2004 02:47:23 +0000
>From tbm@cyrius.com Sun Mar 28 18:47:23 2004
Return-path: <tbm@cyrius.com>
Received: from sorrow.cyrius.com [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B7mo7-00029J-00; Sun, 28 Mar 2004 18:47:23 -0800
Received: by sorrow.cyrius.com (Postfix, from userid 10)
	id 3C9DD64D50; Mon, 29 Mar 2004 02:47:18 +0000 (UTC)
Received: by deprecation.cyrius.com (Postfix, from userid 1000)
	id 4AC99FF32; Mon, 29 Mar 2004 03:46:34 +0100 (BST)
Date: Mon, 29 Mar 2004 03:46:34 +0100
From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: Successful report on Rebel Netwinder (ARM)
Message-ID: <20040329024634.GA18221@deprecation.cyrius.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports


Debian-installer-version: daily snapshot from 2004-03-28
uname -a: 2.4.25
Method: I netbooted boot.img obtained from
via TFTP.  I did one installation with a VGA monitor and PS/2 keyboard, and
another one via the serial console

Machine: Corel/Rebel Netwinder
Processor: ARM
Memory: 128
Root Device: IDE
Output of lspci:
0000:00:00.0 Co-processor: Digital Equipment Corporation StrongARM DC21285 (rev 03)
0000:00:09.0 VGA compatible controller: Intergraphics Systems CyberPro 2000A (rev 01)
0000:00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)
0000:00:0c.0 ISA bridge: Symphony Labs W83C553 (rev 10)
0000:00:0c.1 IDE interface: Symphony Labs SL82c105 (rev 05)
0000:00:0d.0 Ethernet controller: Winbond Electronics Corp W89C940F

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O] initially some problems, most of them solved
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O] should warn if using ext3 for root
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [ ] doesn't need a boot loader
Reboot:                 [O]


I think this is the first installation with debian-installer on a
Netwinder.  I used the boot.img image (a daily snapshot) and booted via
TFTP.  I passsed the following arguments to the kernel:
    root=/dev/ram0 devfs=mount

The first time I tried it, it looked for hardware and then I got the
error "Error: No Ethernet card was found on the system".  I noticed
that the network driver was not compiled into the kernel, and neither
were modules part of the initrd.  I talked to Vince on IRC, and we
checked a fix for pkg-list into SVN.  Vince prepared a new image and I
tried again.  This time, I was presented with a list of various
modules.  I choose the one I needed (e2k-pci) and it worked.  I
suggested to Vince that discover should be part of the initrd.  He
gave me new images and automatic recogniztion of modules worked.
There is a problem, however: Netwinder have 2 NICs: eth0 is commonly
the e2k-pci 10 MBit, while eth1 is the Tulip 10/100 MBit device.
Unfortunately, lspci shows them in the other order, and thus discover
reverses this very common naming scheme (all the Netwinder info refers
to the e2k-pci device as "eth0").  I don't think that it's possible to
tell discover to use a different order.  I think one solution would be
to build the e2k-pci module into the kernel, and have the tulip driver
as a module.  Comments on this?

The installation went pretty smoothly.  cfdisk was started, I
partitioned the disks.  I noticed ext3 was not available and pointed
this out to Vince; he added it to the initrd... I then chose to use
ext3 for the root partition, but this turned out to be a bad choice
because the firmware cannot boot from it.  I had to re-install on an
ext2 partition.  Can d-i warn about such things?  Are there hooks for
this?  Also, should ARM switch to partman?

The base system was installed without any problems.  Well, one minor,
cosmetic problem.  The machine is kinda slow, and therefore it would
be nice if the progress bar would be more fine grained.

Oh, and the wrong kernel was installed: kernel-image-2.4.19-riscstation.
It turns out that 2.4.25-netwinder is not in testing yet, so it falls
back to 19-riscstation.  It's not quite clear to me why it didn't
present a list of all ARM kernel in testing.  However, I later
installed unstable, and the right kernel was installed.

For the Netwinder there is a package called nwutil to change some
hardware settings.  This should be installed after the base.
According to Joey, base-installer has some hooks to install sub-arch
specific packages.

Also, while looking through the logs, I noticed this message:
 | GNU parted was miscompiled: the FAT boot sector should be 512 bytes.  FAT
 | support will be disabled.
I guess this is a problem on ARM in general.

After the install, /etc/fstab was empty.  I don't know why, though.
I also got this message:
    WARNING: Your /etc/fstab does not contain the fsck passno field.  I will
    kludge around things for you, but you should fix your /etc/fstab file as
    soon as you can.
But I suppose this is because my /etc/fstab was empty. (empty: there was a
heading saying /etc/fstab was unconfigured.)

serial install

I later tried booting via serial console.  Unfortunately, once it
started booting the kernel I didn't have any output anymore.  Passing
console=ttyS0 to the kernel did not help.  I needed
console=ttyS0,115200.  This should be documented.  So the full line
   setenv cmdappend root=/dev/ram0 devfs=mount console=ttyS0,115200


For reference, my firmware settings were (for the VGA install):

netconfig_eth0    dhcp                           dhcp
kernconfig        tftp                           tftp
kerntftpfile      boot.img                       boot.img
cmdappend         root=/dev/ram0 devfs=mount     root=/dev/ram0 devfs=mount

General issues

  - I wanted to use a custom (FTP) mirror.  I chose: mirror -> custom ->
       hostname -> path -> error because it used HTTP.  When I try again,
       I can choose between FTP and HTTP, but then it has forgotten the
       hostname and path I entered previously.  I think it should ask
       FTP/HTTP all the time when choosing a custom mirror, and remember
       what I entered before.

  - It asked me to choose a mirror, I chose the country, and then was
    presented a list of mirrors.  I went back, opened a shell, and then
    went back and got the following menu:

   [!] Choose a mirror of the Debian archive 

   Debian archive mirror country:

    That is, the country names were not shown anymore.

  - In the logs, i found:
Setting up exim4-cofig
hostname: Unknown host
    /etc/hosts did not exit, /etc/hostname did and had the hostname.  I
    don't know if this is serious.

  - Overlapping windows:

    No boot loader is installed on the Netwinder.  When it tries to finish up,
    a menu is displayed like this:

Finishing the install 
Running the final message

    Then it shows this message:

[!!] Finish the installation and reboot
    Installation complete
Installation is complete, so it is time to boot into your new Debian  

    This is pretty ugly because the old window can still be seen. (i.e. the 2nd
    window is on top of the 1st)

  - In base-config, it asked me to choose APT methods.  I decided to choose
    "FTP", then realized I had done that before, checked out
    /etc/apt/sources.list, noticed my mirror is in there already, and
    canceled the mirror selection in base-config: afterwards my apt config
    line was commented out.
    Also, apt-config did not know about the custom mirror I entered during
    the first stage.

Thanks to Vincent Sanders for his ARM work, and to Petter Reinholdtsen
for making this machine available.
Martin Michlmayr

Received: (at 240760-done) by bugs.debian.org; 26 Jul 2004 21:53:25 +0000
>From frederik@dannemare.net Mon Jul 26 14:53:25 2004
Return-path: <frederik@dannemare.net>
Received: from cpe.atm0-0-0-2421032.0x3ef2dbfa.arcnxx7.customer.tele.dk (host.kl-teknik.com) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BpDPR-0005Bc-00; Mon, 26 Jul 2004 14:53:25 -0700
Received: from mail.thepenguininvasion.dk (0x5358aaae.abnxx12.adsl-dhcp.tele.dk [::ffff:])
  (AUTH: PLAIN admin@sentinel.dk)
  by host.kl-teknik.com with esmtp; Mon, 26 Jul 2004 23:58:25 +0200
  id 00003E7B.41057E81.000056B3
From: Frederik Dannemare <frederik@dannemare.net>
To: 240760-done@bugs.debian.org, Martin Michlmayr <tbm@cyrius.com>
Subject: Processed: Bug#240760: successful report on Rebel Netwinder
Date: Mon, 26 Jul 2004 23:54:05 +0200
User-Agent: KMail/1.6.2
Cc: frederik@dannemare.net
MIME-Version: 1.0
Content-Disposition: inline
Content-Type: Text/Plain;
Content-Transfer-Encoding: quoted-printable
Message-Id: <200407262354.10432.frederik@dannemare.net>
Delivered-To: 240760-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Hash: SHA1

Martin, I'm currently processing old installation reports, and have come=20
across an old one of yours. I am closing it, since you already cloned=20
off the relevant issues back in April. Please reopen, if you disagree.

=2D --=20
=46rederik Dannemare | mailto:frederik@dannemare.net
GnuPG key: search for 'dannemare' on http://pgpkeys.mit.edu
Key fingerprint: BB7B 078A 0DBF 7663 180A  F84A 2D25 FAD5 9C4E B5A8
http://frederik.dannemare.net | http://www.linuxworlddomination.dk
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: