[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#260093: debian-installer installation-report AlphaStation 500/333

Package: installation-reports


Debian-installer-version: 20040716,
Linux alphabox 2.4.26-1-generic #2 Sat May 1 16:31:16 EST 2004 alpha
Date: Sun Jul 18 13:54:13 CEST 2004
Method: Network install, initiated from a bootable "businesscard" CD.
The CD is booted from the Alpha's SRM console with `boot DSKA600`. I've
tried to install from the regular CD too, but kernel panics are
experienced when the CDRom drive is accessed extensively.

>From /etc/apt/sources.list:
deb ftp://ftp.surfnet.nl/pub/os/Linux/distr/debian/ testing main

Machine: Digital AlphaStation 500/333
Processor: Alpha EV5
Memory: 189488 kB
Root Device: SCSI disk on /dev/sdb
Root Size/partition table:

alphabox:/home/polarwolf# fdisk -l /dev/sdb
Disk /dev/sdb: 4550 MB, 4550934016 bytes
255 heads, 63 sectors/track, 553 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

3 partitions:
#       start       end      size     fstype   [fsize bsize   cpg]
 a:        2       500       499       ext2                      
 b:      501       554*       53*      ext2

Output of lspci and lspci -n:
alphabox:/home/polarwolf# lspci
0000:00:06.0 Ethernet controller: Digital Equipment Corporation DECchip
21040 [Tulip] (rev 24)
0000:00:08.0 VGA compatible unclassified device: S3 Inc. 86c864 [Vision
864 DRAM] vers 0
0000:00:09.0 SCSI storage controller: QLogic Corp. ISP1020 Fast-wide
SCSI (rev 02)
0000:00:0a.0 Non-VGA unclassified device: Intel Corp. 82375EB (rev 05)
0000:00:0c.0 Fibre Channel: Emulex Corporation LP7000 Fibre Channel Host
Adapter (rev 04)

alphabox:/home/polarwolf# lspci -n
0000:00:06.0 Class 0200: 1011:0002 (rev 24)
0000:00:08.0 Class 0001: 5333:88c0
0000:00:09.0 Class 0100: 1077:1020 (rev 02)
0000:00:0a.0 Class 0000: 8086:0482 (rev 05)
0000:00:0c.0 Class 0c04: 10df:f700 (rev 04)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]

It works well, until in the last phase it tries to write an aboot
configuration out to disk. The error which shows up in the logging
console is:

main-menu[261]: (process:12921): error: bootcode overlaps with partition
#1. If you really want this, use -f1
aboot-installer: info: Installing aboot on '/dev/sdb'

So I've done some investigation, and it appears that to install aboot
you need some free space on the disk before the first partition
(according to the FAQ on
We suggest that the disk be partitioned such that the first partition
starts at an offset of 2048 sectors. This leaves 1MB of space for
storing aboot. On a properly partitioned disk, it is then possible to
install aboot as follows (assuming the disk is /dev/sda):
# swriteboot /dev/sda bootlx

On systems where partition c in the entire disk it will be necessary to
'force' the write of aboot. In this case use the -f flag followed by the
partition number (in the case of partition c this is 3):
# swriteboot /dev/sda bootlx -f3

Well, it appears that the partitioning tool neither takes the bit of
free space into account nor does it create one bigass BSD label
partition across the entire disk, so the installer will try to write the
boot block right over the partition boundary of the first partition.
That obviously won't work (I know, I tried to force install the boot
block with -f1, it leaves an unbootable system). So, what I did to
resolve this issue is to manually partition the harddisk in the console
on tty2, starting the first partition on the second cylinder of the
disk, leaving ~8MB of free space before the first partition. After
partitioning the disk, I've started the installer's partitioning tool to
format and mount the partitions, and after that d-i happily installs
everything, including aboot. I now have a functional Sarge installation
on my AS500/333, installed with debian-installer.

On a side note, this is the first time I've use debian-installer, and I
can only say that it's very, very nice. I find the partitioning tool a
bit combersome to use though. But maybe that's because I always choose
to do that stuff by hand instead of automagically :-)


Ferdinand O. Tempel

Your friendly neighborhood linuxops.net administrator.

Reply to: