[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#258010: AMD64 install report for HP DL585, cciss detection problem

On Thu, Jul 08, 2004 at 12:24:11PM +0200, Mattias Wadenstein wrote:
> On Wed, 7 Jul 2004, Joey Hess wrote:
> > Mattias Wadenstein wrote:
> > > Then I tried to do an lvm install, only to be greeted by "no physical
> > > volumes available" (paraphrased from memory) no matter what I did. So I
> > > went for a guided partition creaton and then converted the large /home to
> > > an lvm2 physical volume after the install.
> > >
> > > Installing the boot loader failed with grub claiming not being able to
> > > install to "hd0" (whatever it meant by that). Installing lilo from the
> > > menu worked fine though.
> >
> > Could you send the syslog, messages, and partman logs from
> > /var/log/debian-installer/ on the installed system?
> http://www.acc.umu.se/~maswan/debian/dl585/syslog
> http://www.acc.umu.se/~maswan/debian/dl585/messages
> http://www.acc.umu.se/~maswan/debian/dl585/partman
> > Can you try running grub-install on the installed system, and maybe work
> > out what the problem is in more detail?
> m192-h:~# grub-install /dev/cciss/c0d0
> /dev/cciss/c0d0 does not have any corresponding BIOS drive.
> m192-h:~# grep boot= /etc/lilo.conf
> boot=/dev/cciss/c0d0

>From the first-stage installer, whn grub fails to install, please try
 echo "(hd0) /dev/cciss/c0d0/" >> /target/boot/grub/device.map

end try to reinstall grub from the menu. 
If that doesn't work do a "chroot /target"
check if /boot/grub/device.map contains the line above, and if not
readd the line. (without /target)
then run grub-install from within the chroot

I installed sarge-based Debian-edu on one of those fro Guadec, but I
had to return the nice box afterwards. 

Finn-Arne Johansen 

Reply to: