[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#257970: debian-installer: vesafb driver in 2.6.7 problem (or VMware?)

Package: debian-installer
Severity: important
Version: sid_d-i 20040705

I don't what this problem is from, but report for recording.

When I tried to install to VMware(4.5.2 build8848) with 'linux26',
framebuffer won't be loaded.
I know this is because rootskel's problem, but I find another
(more critical) problem.

When I run "modprobe vesafb", this command doesn't return any error
code, and looks be registered correctly (from lsmod information).
But, syslog says "vesafb: probe of vesafb0 failed with error -6", and
/proc/fb is still empty. fbcon won't install.
"modprobe vga16fb" works correctly.
And, if I provide vesa boot option, such as "vga=785", vesafb works.

All of problem looks kernel(or modprobe) loads vesafb in spite of it
reports an error.

This problem is only happened with 2.6.7. 2.4.26 works correctly. And
I remember 2.6.5 works.
I'll try to clarify who's wrong.

Kenshi Muto

Reply to: