[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

s390 d-i report

It still doesn't work, but with the new zipl-installer.postinst it comes
a lot closer.

netcfg (actually netcfg-static) still doesn't work the first time.  What
you have to do is to select IUCV, which generates an error, and then go
back in from the main menu, select option #3 (network config), and
everything works fine the second time.

The symptoms are as follows: whatever you enter is sort of
recognized--that is, if you choose CTC and you don't have any CTC
devices in your configuration, you're told so.  But if you do choose the
interface type you have (qeth, in my case), the installer simply asks
you to choose an interface type again.

I have no idea why this is.  I've looked through s390/netdevice and I'm
not seeing the problem.  I'm going to try to add IUCV support soon,
because that should be pretty straightforward.

Once you've gotten past the network device configuration, everything
goes smoothly up until "Make System Bootable".  At this point, the stock
install fails, because of a missing symlink for /vmlinuz.  The patch I
just posted for zipl-installer.postinst fixes this and adds a correct
parmline for the DASD configuration.

Installing this could in theory be done from the 3270 console.  I find
that a huge pain, so I've been doing a chroot to /target, removing
/etc/securetty, and enabling inetd, so I have a smarter terminal to work
with.  Then I can telnet to the chroot'ed /target, use cat and ^D to
copy zipl-installer.postinst to /tmp, and then, from the console, 

cp /target/tmp/zipl* /var/lib/dpkg/info
chmod 755 /var/lib/dpkg/info/zipl*

Rebooting the system from the installer doesn't work.  Woody just ran
/sbin/halt and advised the user to IPL from the root DASD device; I
think a similar trick will be needed for Sarge.  The problem with reboot
is that it, in the S/390 world, attempts to boot from the last device
you IPLed from, which will be either the card deck or the tape drive,
rather than your new root disk.  

After that, the next problem is that base-config tries to run on the
console.  Since the 3270 is a line-mode EBCIDC terminal that does not
understand ANSI terminal codes, this fails messily.  

The workaround is to replace /etc/inittab with /etc/inittab.real.  Then
run /sbin/halt, and, from the console, IPL from your root device. 
Remember that you will have inetd running and a root telnet session will
be enabled.

Then telnet in as root (it'll be nice when we have sshd on the install
system), and run base-config from your telnet session.  After that
everything goes smoothly again.  Once it's done and you've installed
sshd, put /etc/securetty back and disable telnetd in /etc/inetd.conf.


Reply to: