[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#256389: installation-reports: loading scsi drivers during netboot

Package: installation-reports
Version: sarge
Severity: grave
Tags: sid
Justification: renders package unusable

I've tried no net-boot install a box with scsi-disks. ok, setting up the
network environment, and which images to use took me some time to find
out. But once the installer was running, it was not possible to get my
scsi-controller detected. under the point cdrom detection (which is a
real brain dead name for that point imho) was the ability to load a
driver disk. But I think, starting a netboot in most cases implies, that
one doesn't have a floppy. I don't know if i missed a point downloading
modules from the net, but i think this should happen without
userinteraction, or just ask if it shoult try to netload modules.

After taking those steps, getting a floppy with the modules started, i
was able to proceed installation. Next step failed with disk
partitioning. I don't know why, but somehow the kernel wouldn't update
its partition-table. I did the partitioning with the commandline-tool,
but the devices in /dev/scsi/h...../lun0/ did not change in an
apropriate way. I've tried to unload the scsi-module, to reload it, but
i think rmmod is missing? 
so another reboot, loading the modules under nasty circumstances.
now, partitioning were right, formating, enabling and installing worked
well. Next point failing was installation of grub. aborted with some
errors... Using lilo fixed the problem. 
Last time a debian base installation took me more than hitting enter a
dozend times was my notebook not having a floppy anymore and not
accepting any boot disk, just a knoppix one...
Well, it finally works.
I would be glad spending time retrying it with an altered version of the

Kind regards, Wilfried Goesgens
-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.6
Locale: LANG=de_DE, LC_CTYPE=de_DE

Reply to: