[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#255796: Package: installation-reports

Package: installation-reports

Debian-installer-version: Sarge Test Candidate 1, June 8, 2004, from 
uname -a: Linux sol 2.4.26-1-386 #2 Sat May 1 16:31:24 EST 2004 i686
Date: June 8, 2004, 9:40pm
Method: From installation CD, Debian Sarge Test Candidate 1

Machine: No-name PC
Processor: Duron 800
Memory: 256 MB
Root Device: IDE /dev/hda
Root Size/partition table:

sol:/home/dustin# fdisk -l /dev/hda

Disk /dev/hda: 20.0 GB, 20020396032 bytes
255 heads, 63 sectors/track, 2434 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System    Mounted on
/dev/hda1   *           1         765     6144831   83  Linux        unused
/dev/hda2             766         831      530145   82  Linux swap
/dev/hda3             832        1469     5124735   83  Linux        /
/dev/hda4            1470        2434     7751362+  83  Linux        unused

Output of lspci:
sol:/home/dustin# lspci
pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133]
(rev 03)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super
South] (rev 40)
0000:00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 16)
0000:00:07.3 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 16)
0000:00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super
ACPI] (rev 40)
0000:00:0e.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M
[Tornado] (rev 78)
0000:00:0f.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 08)
0000:00:0f.1 Input device controller: Creative Labs SB Live! MIDI/Game
Port (rev 08)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA
TNT2 Model 64/Model 64 Pro] (rev 15)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Did a virtually default install, not creating new partitions, but I let
the installer format a partition.  The initial install was flawless.  I
was jumping for joy that Debian installer had finally got it right.  But I
wasn't out of the woods yet!

Here are the snags I encountered:

1) Next I used "tasksel" to install these categories:

Desktop environment
Linux Standard Base
Office environment
Custom kernel compilation
Debian Jr.
Scientific applications
TeX/LaTeX environment

At first, I chose the Debian mirror "mirror.direct.ca".  That mirror was
missing the package libmpeg, so the apt-getting crapped out ungracefully! 
Repeated attempts to download failed, even when the "apt-get update"-ing
was repeated.  The problem was solved by choosing a different mirror. 
**Perhaps the advice to back up a few steps and and try a different mirror
would have been helpful to more novice users, if not all packages could be
downloaded by apt.**

2) Once the actual packages were getting installed en masse (and many
packages ask questions), all of a sudden there was a huge jump in

The questions asked during package installation, *****which novice users
will view as part of the initial install***** (even though they are
technically out of the hands of the Debian Installer) were very

Many packages did not offer recommendations as default answers.  I can't
remember quite which ones, but any and all packages that ask questions
that are part of the tasks:

Desktop environment
Linux Standard Base
Office environment

...in tasksel should refrain from asking the end user questions, or make
it very easy and dumbed down, and always recommend a default answer if
they're unsure (like the linux kernel does when you configure it).  In
other words, these "critical path" packages (which every novice will
install) need to be very easy to configure at the time of package

Two prime examples:

-the package "resolvconf" should have not asked its question, it should
have just done the default thing, putting a note in a file in
/usr/share/doc/resolvconf/, which all geeks who run into a snag will
figure out to look to.

-the package xserver-xfree86 talked about the DDC protocol, then I chose
for the autodection of my monitor's powers to be attempted, then the next
thing I knew, I was being asked to chose between simple, medium, or
advanced configuring (of XF86Config).  I was not told how the DDC
autodetection went!!  For all I know it didn't even occur.  The questions
about autodetecting got my hopes up that configuring X would be easy, but
no, I had to do it the hard way (by using advanced mode, and manually
entering my Horiz and Vert frequencies, which has been proven to be the
only way to get it right in the past).  There needs to be informational
messages like "Now trying DDC detection, please wait", and "DDC detection
failed, now you'll have to configure manually.

Why can't there be a graphical config interface where you try different
modes, clicking Yes when you see the one you like, each mode temporarily
showing for 10 seconds?  Every other Linux distro has this problem licked!
 Configuring X has got to be easier!

3) Once I actually got to my KDE desktop, I was annoyed that there was no
menu icon anywhere for launching mozilla (like in "Internet" in the menu),
even though it's probably the most heavily used piece of Linux software of
all time.  There should also be an icon on the menu bar, beside Konqueror.
 Choice is good!  There are other web browsers in the menu alongside
Konqueror, why not Mozilla?

4) K3B, which is the best burning software ever, should have been
installed by default under whatever task the package "grip" is under. 
This is a killer app, please include it by default!!  Also, the K3B should
also depend on the cdrdao package, but doesn't.

Dustin Harriman

Reply to: