[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#255296: installation-reports: [sparc64] cdrom, keyboard problems

Package: installation-reports
Version: testing daily 20040619
Severity: normal

Debian-installer-version: 20040619 testing netinst

uname -a: kernel 2.4.26 I think

Date: 20040620

Method: netinst cdrom, noted above
 Booted the machine with "boot cdrom" from OBP prompt.

Machine: Sun Blade 100, OpenBoot Prom 4.5.9, POST 2.0.1

I booted with sun usb keyboard and mouse, and a CRT monitor plugged into
the "ATI PGX PCI 8-bit [m64]" graphics card. No serial console attempts.

Processor: Ultrasparc IIe (sparc9+vis) 502MHz
Memory: 640Mb
 128Mb in slot0
 512Mb in slot1
(ie contiguous from the first slot, and plenty of it)

Root Device: IDE, detected as /dev/hda

Root Size/partition table:
 could not get a console to generate this output
 system has 1x20Gb ide disk, formatted with sun partition table and
 solaris UFS filesystems.

Output of lspci:
 could not get a console to generate this output

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [E]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

I ran this test in hopes of helping with the sparc64 problems.
The problem reported exists in TC1 as well, I tried it and then the daily.

I booted with these options

  linux debconf_priority=low  (made no difference)

  linux cdrom ramdisk_size=8192 rootfstype=ext2

All gave the same behaviour, documented below.

0. The ramdisk_size=8192 rootfstype=ext2 arguments appear to be
   unnecessary now, when the installer booted it always said it was
   using 8Mb ramdisk.

1. The boot goes well at first, with the hard disk detected etc.
   Frame buffer is started & I see Tux with the sun shining out of
   his ... belly button.

2. International character sets are not displayed in the "Choose Language"
   page. I think this is a known problem.

3. I select en_US or en_AU (return & arrow keys work fine at this point)

4. The system jumps into hardware detection, and shows the error dialog
   at the "Detect and Mount CDROM" stage.

   The cdrom is listed as a "LITEON CD-ROM LTN486S" from within solaris.
   What is it about me & cdroms?
   The detection failure might be solved by Osamu's patch in Bug#255128.

5. At this point, the keyboard is messed up.

   The only key that seems to work is <return> (interpreted as <TAB>,
   so I can bounce from Yes to No and back again, whee).

   <TAB> itself does noting as far as I can tell.

   Maybe <esc> works - once I got into the installer main menu somehow
   but could not use the arrow keys.

   <ctrl>-<alt>-F2 did not get me into the shell window, neither did
   <alt>-F2,  <meta>-F2,  <alt-gr>-F2 etc.

   <stop>-A also works, but after that none of the keys work.
   The only avenue at this point is to power cycle.

   All the above occurs whether I select en_US or en_AU.

   The keyboard is "Sun type 6 usb".
   There is no provision for another type of keyboard.
   The only other thing on the USB bus is a sun usb mouse.

Additional note: I managed to panic the system during boot, with

  linux cdrom devfs=nomount ramdisk_size=8192 rootfstype=ext2

This is because the installer kernel sets up the hard disks as devfs
devices; you get this message -
  Panic: VFS: Unable to mount rootfs on 00:00

So this course of action (recommended in debian-boot thread "Take 3:
sparc64 CDs work?") doesn't necessarily apply anymore. Maybe there
is some other boot argument I missed.

One useful thing the panic did was freeze the display so that I could
see that the following usb drivers are loaded:
   usb-uhci (seems to load ok)
   usb-ohci (this finds something to drive)
   usbmouse (I think)

Is it correct that the usbkbd driver is loaded?

Reply to: