[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#254764: sarge-i386-netinst (20040616) fails .... I may have found fix

I used 1 day newer CD on this slow CDROM PC again.

Again it failed on mounting CD (when done automatically).

CD integrity did not work either after this from menu.

Then I went to console and "umount /cdrom".

This time, instead of manually mounting disk from console to /cdrom, I
used install menu to mount it and everything worked fine.

As I see code, any mount erroris will exit initial auto mount.  If it is
mounted with error, next run will not be tried, I think.  /cdrom need to
be always clean.

How about this to avoid this situation.

--- cdrom-detect.postinst.org	2004-06-18 00:27:01.000000000 +0200
+++ cdrom-detect.postinst	2004-06-18 00:30:07.000000000 +0200
@@ -45,6 +45,9 @@
 	    db_set cdrom-detect/cdrom_device $device
+        else
+            # Many reasons to exit with error.  Maybe mounted.
+            umount /cdrom

I may be better off doing "umount /cdrom 2>/dev/null 1>/dev/null" :)


       mount has the following return codes (the bits can be ORed):
       0      success
       1      incorrect invocation or permissions
       2      system error (out of memory, cannot fork, no more loop devices)
       4      internal mount bug or missing nfs support in mount
       8      user interrupt
       16     problems writing or locking /etc/mtab
       32     mount failure
       64     some mount succeeded

Reply to: