[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#252164: Package: lvm2

On 11 Jun 2004 at 17:25, Patrick Caulfield wrote:

> On Fri, Jun 11, 2004 at 03:10:18PM +0100, Martin Michlmayr wrote:

> > > > In any case, can you type:
> > > >   vgchange -a y
> > > > and restart the partitioner; then they should show up.
> > > > 
> > > Done.  For each lv, I get:
> > > Incorrect metadata area header checksum
> > > Incorrect metadata area header checksum
> > > Volume group vg1 metadata is inconsistent
> > > Voume group for uuid not found: <about 50 characters> 
> Does it only happen with this box or is it more generic?

I've only seen it on this box, 
but haven't tried it yet on 
other boxes.

> The reason I ask is
> because it might be down to O_DIRECT causing odd problems on older hardware - I
> have seem this sort of behaviour before and it sort of magically fixed it self
> later. If you like I can build you a udeb (or you could do it yourself) with
> O_DIRECT disabled to try.
Indeed this is an old box.  I'm 
a bit of a newbie and don't 
know how to disable 
O_DIRECT or build a udeb.  I 
could learn....

> There was an odd bug in earlier lvm2 that used to cause checksum failures but I
> can't locate which version that was and I assume that you'll be using a fairly
> recent udeb anyway.
This is from the Sarge daily 
build dated 6/01/04.

> One other idea - the disks look quite small, it might be worth using a small PE
> size in the vgcreate command.

I didn't see an option in the d-
i, so will try it from the 
command line.

Reply to: